summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-03-29 15:25:02 +0100
committerJoe MacDonald <joe.macdonald@windriver.com>2013-04-02 08:53:13 -0400
commit6fc248efc70dc38626b5f2f518900df2cee78959 (patch)
tree257db5b9fa1d381a5f85488e23c971ef3c77ae9f /meta-networking
parent7d6f5f468566b7f475da246328ff95844ba60f61 (diff)
downloadmeta-openembedded-6fc248efc70dc38626b5f2f518900df2cee78959.tar.gz
crda: add 1.1.3
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/crda/crda_1.1.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
new file mode 100644
index 000000000..d736c7a2d
--- /dev/null
+++ b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Wireless Central Regulatory Domain Agent"
2HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA"
3
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
6
7
8DEPENDS = "python-m2crypto-native python-native libgcrypt libnl"
9
10SRC_URI = "http://wireless.kernel.org/download/crda/${P}.tar.bz2;name=crda \
11 http://wireless.kernel.org/download/wireless-regdb/regulatory.bins/2013.01.11-regulatory.bin;name=bin \
12 "
13SRC_URI[crda.md5sum] = "29579185e06a75675507527243d28e5c"
14SRC_URI[crda.sha256sum] = "aa8a7fe92f0765986c421a5b6768a185375ac210393df0605ee132f6754825f0"
15SRC_URI[bin.md5sum] = "e0c8a5ca63fb8bf803213f9a0c90b50b"
16SRC_URI[bin.sha256sum] = "b1ee0b20c123c612dfdb6851ab42c01666f66fb583e0e590942f19bb54cf84be"
17
18inherit python-dir pythonnative
19# Recursive make problem
20EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D}"
21
22do_compile() {
23 oe_runmake all_noverify
24}
25
26do_install() {
27 oe_runmake install
28
29 install -d ${D}${libdir}/crda/
30
31 install -m 0644 ${WORKDIR}/2013.01.11-regulatory.bin ${D}${libdir}/crda/regulatory.bin
32}
33
34
35RDEPENDS_${PN} = "udev"
36FILES_${PN} += "${libdir}crda/regulatory.bin \
37 ${base_libdir}/udev/rules.d/85-regulatory.rules \
38 "