summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2013-02-14 13:40:04 -0800
committerJoe MacDonald <joe.macdonald@windriver.com>2013-02-14 22:49:03 -0500
commit5346f2f092e6f6d52bbb225f482fbe054bdbe19b (patch)
tree8134498e93006300ea0e80927ecd9f1e646d77e5 /meta-networking
parenta3f1c77cf5d7d350502ff6eb1784fbf432ea6fc5 (diff)
downloadmeta-openembedded-5346f2f092e6f6d52bbb225f482fbe054bdbe19b.tar.gz
arptables: defeat multi-job for install
CQID: 399299 The make install target is not parallel job safe, but doesn't do all that much, so we limit make to one job for that. The make target is of the form install: x y z Unfortunately, z depends on y, so if z is started before y (almost) completes, we will fail. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
index 2faccec7d..86b900a5d 100644
--- a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
+++ b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
@@ -3,6 +3,8 @@ PRIORITY = "optional"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4SECTION = "console/network" 4SECTION = "console/network"
5 5
6PR = "r2"
7
6RDEPENDS_${PN} += "perl" 8RDEPENDS_${PN} += "perl"
7 9
8LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 10LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
@@ -20,6 +22,11 @@ do_compile () {
20 oe_runmake 22 oe_runmake
21} 23}
22 24
25# the install target is not multi-job safe, but it doesn't do much
26# so we just install serially
27#
28PARALLEL_MAKEINST = "-j1"
29
23fakeroot do_install () { 30fakeroot do_install () {
24 oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install 31 oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install
25} 32}