summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2013-01-18 12:13:32 -0500
committerJoe MacDonald <joe.macdonald@windriver.com>2013-01-24 10:35:49 -0500
commitb7ff6ac09affebe72b7587d7e345adaae427ef3d (patch)
tree3c5f0650d7e21ae48177d262194aca40484c89d0 /meta-networking
parentaf502674e6d0dc184215ff02d92938c168118911 (diff)
downloadmeta-openembedded-b7ff6ac09affebe72b7587d7e345adaae427ef3d.tar.gz
autofs: fails to compile with openldap disabled
As of 5.0.6, it appears that changes were introduced so that if you compile with openldap disabled and openldap headers are not available, then autofs fails to build. Since autofs no longer depends on openldap, remove the dependency. Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch42
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb5
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch
new file mode 100644
index 000000000..31c8510a6
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch
@@ -0,0 +1,42 @@
1autofs: fails to compile with openldap disabled
2
3As of 5.0.6, it appears that changes were introduced so that
4if you compile with openldap disabled and openldap headers are not
5available, then autofs fails to build.
6
7Upstream-Status: Pending
8
9Signed-off-by: Amy Fong <amy.fong@windriver.com>
10--
11 lookup_ldap.h | 4 ++++
12 1 file changed, 4 insertions(+)
13
14---
15 include/lookup_ldap.h | 4 ++++
16 1 file changed, 4 insertions(+)
17
18--- a/include/lookup_ldap.h
19+++ b/include/lookup_ldap.h
20@@ -1,7 +1,9 @@
21 #ifndef LOOKUP_LDAP_H
22 #define LOOKUP_LDAP_H
23
24+#ifdef WITH_LDAP
25 #include <ldap.h>
26+#endif
27
28 #ifdef WITH_SASL
29 #include <openssl/ssl.h>
30@@ -109,10 +111,12 @@
31
32 #define LDAP_AUTH_USESIMPLE 0x0008
33
34+#ifdef WITH_LDAP
35 /* lookup_ldap.c */
36 LDAP *init_ldap_connection(unsigned logopt, const char *uri, struct lookup_context *ctxt);
37 int unbind_ldap_connection(unsigned logopt, LDAP *ldap, struct lookup_context *ctxt);
38 int authtype_requires_creds(const char *authtype);
39+#endif
40
41 #ifdef WITH_SASL
42 /* cyrus-sasl.c */
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
index bf679b4e6..1afbe812a 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
@@ -3,7 +3,9 @@ SECTION = "base"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS += "openldap libtirpc flex-native bison-native" 6PR = "r1"
7
8DEPENDS += "libtirpc flex-native bison-native"
7 9
8inherit autotools 10inherit autotools
9 11
@@ -31,6 +33,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.bz2 \
31 file://libtirpc.patch \ 33 file://libtirpc.patch \
32 file://libtirpc-name-clash-backout.patch \ 34 file://libtirpc-name-clash-backout.patch \
33 file://autofs-5.0.7-do-not-check-for-modprobe.patch \ 35 file://autofs-5.0.7-do-not-check-for-modprobe.patch \
36 file://fix_disable_ldap.patch \
34 " 37 "
35 38
36SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431" 39SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431"