summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-06-17 15:04:00 +0800
committerJoe MacDonald <joe.macdonald@windriver.com>2013-06-17 09:50:53 -0400
commita4c953b35d082c9ef45c6e41212bf9c8f7b0ff74 (patch)
tree7aeb662ef33c2cdce0703cb5a4115ab31bddbb7e /meta-networking
parente34f1f1ad765a324116dfb296895cd4276230487 (diff)
downloadmeta-openembedded-a4c953b35d082c9ef45c6e41212bf9c8f7b0ff74.tar.gz
arptables: fix the redefinition of 'arpt_get_target' error
Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch30
-rw-r--r--meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch b/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch
new file mode 100644
index 000000000..0875344fe
--- /dev/null
+++ b/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch
@@ -0,0 +1,30 @@
1arptables: fix the redefinition of 'arpt_get_target'
2
3Upstream-Status: Pending
4
5This function is already defined as a static inline function in
6include/linux/netfilter_arp/arp_tables.h, once GCC uses -O0, the
7inline will not work, and the redefinition error will happen
8
9Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
10Signed-off-by: Roy.Li <rongqing.li@windriver.com>
11
12diff --git a/libarptc/libarptc_incl.c b/libarptc/libarptc_incl.c
13index 35736db..addd3f9 100644
14--- a/libarptc/libarptc_incl.c
15+++ b/libarptc/libarptc_incl.c
16@@ -11,14 +11,6 @@
17 /* (C)1999 Paul ``Rusty'' Russell - Placed under the GNU GPL (See
18 COPYING for details). */
19
20-#ifndef __OPTIMIZE__
21-STRUCT_ENTRY_TARGET *
22-GET_TARGET(STRUCT_ENTRY *e)
23-{
24- return (void *)e + e->target_offset;
25-}
26-#endif
27-
28 static int sockfd = -1;
29 static void *arptc_fn = NULL;
30
diff --git a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
index fe14b61e1..f3deaeb5d 100644
--- a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
+++ b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
@@ -12,6 +12,7 @@ SRC_URI = " \
12 ${SOURCEFORGE_MIRROR}/ebtables/arptables-v${PV}.tar.gz;name=arptables \ 12 ${SOURCEFORGE_MIRROR}/ebtables/arptables-v${PV}.tar.gz;name=arptables \
13 file://arptables-compile-install.patch \ 13 file://arptables-compile-install.patch \
14 file://arptables-init-busybox.patch \ 14 file://arptables-init-busybox.patch \
15 file://arptables-arpt-get-target-fix.patch \
15" 16"
16SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5" 17SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
17SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928" 18SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"