summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJoe MacDonald <joe@deserted.net>2013-10-07 12:12:56 -0400
committerJoe MacDonald <joe@deserted.net>2013-10-07 13:36:46 -0400
commit37660c2e812996331d3c1a6e4d5dec3847ac4575 (patch)
tree951152fa6e9454231c480306a01d86929869882a /meta-networking
parent2a463dddcf76d7fa437e96f6cf0210143e97a904 (diff)
downloadmeta-openembedded-37660c2e812996331d3c1a6e4d5dec3847ac4575.tar.gz
openflow: import and tweak
Based on work by David Nyström (meta-virtualization) and Laszlo Papp (meta-oe). - Import OpenFlow 1.0 from meta-virtualization and provide an updated version of the recipe for the head of tree in the OpenFlow git repository. - Minor tweak in both recipes for do_install_append() spacing. - Update 'libssl' PACKAGECONFIG flag in both to follow the 'openssl' convention used elsewhere in meta-oe. - Create common include file for both versioned and git recipes. Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow.inc35
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow_1.0.bb4
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow_git.bb4
3 files changed, 43 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/openflow/openflow.inc b/meta-networking/recipes-protocols/openflow/openflow.inc
new file mode 100644
index 000000000..43af54ea5
--- /dev/null
+++ b/meta-networking/recipes-protocols/openflow/openflow.inc
@@ -0,0 +1,35 @@
1SUMMARY = "OpenFlow communications protocol"
2DESCRIPTION = "\
3Open standard that enables researchers to run experimental protocols in \
4contained networks. OpenFlow is a communications interface between \
5control and forwarding planes of a software-defined networking architecture.\
6"
7HOMEPAGE = "http://www.openflow.org"
8
9SECTION = "networking"
10LICENSE = "GPLv2"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=e870c934e2c3d6ccf085fd7cf0a1e2e2"
13
14SRC_URI = "git://gitosis.stanford.edu/openflow.git;protocol=git"
15
16DEPENDS = "virtual/libc"
17
18EXTRA_OECONF += "KARCH=${TARGET_ARCH}"
19
20PACKAGECONFIG ??= "openssl"
21PACKAGECONFIG[openssl] = "--enable-ssl,--disable-ssl, openssl, libssl"
22
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27do_configure() {
28 ./boot.sh
29 oe_runconf
30}
31
32do_install_append() {
33 # Remove /var/run as it is created on startup
34 rm -rf ${D}${localstatedir}/run
35}
diff --git a/meta-networking/recipes-protocols/openflow/openflow_1.0.bb b/meta-networking/recipes-protocols/openflow/openflow_1.0.bb
new file mode 100644
index 000000000..a7e254dd8
--- /dev/null
+++ b/meta-networking/recipes-protocols/openflow/openflow_1.0.bb
@@ -0,0 +1,4 @@
1include ${BPN}.inc
2
3SRCREV = "5ccca75a69f99791659bcfbcf35353ab1921320a"
4PV = "1.0"
diff --git a/meta-networking/recipes-protocols/openflow/openflow_git.bb b/meta-networking/recipes-protocols/openflow/openflow_git.bb
new file mode 100644
index 000000000..6403bfb22
--- /dev/null
+++ b/meta-networking/recipes-protocols/openflow/openflow_git.bb
@@ -0,0 +1,4 @@
1include ${BPN}.inc
2
3SRCREV = "c84f33f09d5dbcfc9b489f64cb30475bf36f653a"
4PV = "1.0+git${SRCPV}"