summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2013-07-24 11:38:25 -0400
committerJoe MacDonald <joe.macdonald@windriver.com>2013-08-01 11:19:24 -0400
commit2b33380048d1d4f02e4537c369fca33e2b16eabe (patch)
tree01bc88400cdc3a03f32c164f7880937623e264d0 /meta-networking
parent4a192445658cb109a4c4002db2dfd997987e2083 (diff)
downloadmeta-openembedded-2b33380048d1d4f02e4537c369fca33e2b16eabe.tar.gz
cyrus-sasl: Add patches from Debian to fix linking
This fixes the build on at least Fedora 19 x86_64 as a host; we were trying to link a non-PIC static object into a shared library. Signed-off-by: Colin Walters <walters@verbum.org> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0009_sasldb_al.diff14
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0014_avoid_pic_overwrite.diff27
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb5
3 files changed, 45 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0009_sasldb_al.diff b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0009_sasldb_al.diff
new file mode 100644
index 000000000..8eff5a8bd
--- /dev/null
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0009_sasldb_al.diff
@@ -0,0 +1,14 @@
1Author: Fabian Fagerholm <fabbe@debian.org>
2Description: Fix linking with libsasldb.a when saslauthd is built with sasldb
3support.
4--- a/saslauthd/configure.in
5+++ b/saslauthd/configure.in
6@@ -77,7 +77,7 @@ if test "$authsasldb" != no; then
7 AC_DEFINE(AUTH_SASLDB,[],[Include SASLdb Support])
8 SASL_DB_PATH_CHECK()
9 SASL_DB_CHECK()
10- SASL_DB_LIB="$SASL_DB_LIB ../sasldb/.libs/libsasldb.al"
11+ SASL_DB_LIB="$SASL_DB_LIB ../sasldb/.libs/libsasldb.a"
12 fi
13
14 AC_ARG_ENABLE(httpform, [ --enable-httpform enable HTTP form authentication [[no]] ],
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0014_avoid_pic_overwrite.diff b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0014_avoid_pic_overwrite.diff
new file mode 100644
index 000000000..2e5b1750d
--- /dev/null
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/debian_patches_0014_avoid_pic_overwrite.diff
@@ -0,0 +1,27 @@
1Author: Fabian Fagerholm <fabbe@debian.org>
2Description: This patch makes sure the non-PIC version of libsasldb.a, which
3is created out of non-PIC objects, is not going to overwrite the PIC version,
4which is created out of PIC objects. The PIC version is placed in .libs, and
5the non-PIC version in the current directory. This ensures that both non-PIC
6and PIC versions are available in the correct locations.
7--- a/lib/Makefile.am
8+++ b/lib/Makefile.am
9@@ -78,7 +78,7 @@ endif
10
11 libsasl2.a: libsasl2.la $(SASL_STATIC_OBJS)
12 @echo adding static plugins and dependencies
13- $(AR) cru .libs/$@ $(SASL_STATIC_OBJS)
14+ $(AR) cru $@ $(SASL_STATIC_OBJS)
15 @for i in ./libsasl2.la ../sasldb/libsasldb.la ../plugins/lib*.la; do \
16 if test ! -f $$i; then continue; fi; . $$i; \
17 for j in $$dependency_libs foo; do \
18--- a/sasldb/Makefile.am
19+++ b/sasldb/Makefile.am
20@@ -63,6 +63,6 @@ libsasldb_a_SOURCES =
21 EXTRA_libsasldb_a_SOURCES =
22
23 libsasldb.a: libsasldb.la $(SASL_DB_BACKEND_STATIC)
24- $(AR) cru .libs/$@ $(SASL_DB_BACKEND_STATIC)
25+ $(AR) cru $@ $(SASL_DB_BACKEND_STATIC)
26
27
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
index 7dcef26db..f05ab8510 100644
--- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
@@ -6,7 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396"
6 6
7SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \ 7SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \
8 file://avoid-to-call-AC_TRY_RUN.patch \ 8 file://avoid-to-call-AC_TRY_RUN.patch \
9 file://Fix-hardcoded-libdir.patch" 9 file://Fix-hardcoded-libdir.patch \
10 file://debian_patches_0009_sasldb_al.diff \
11 file://debian_patches_0014_avoid_pic_overwrite.diff \
12 "
10 13
11inherit autotools pkgconfig useradd 14inherit autotools pkgconfig useradd
12 15