diff options
author | changqing.li@windriver.com <changqing.li@windriver.com> | 2018-07-05 11:28:58 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-05 10:19:03 -0700 |
commit | 7041cdd3b47b410b59a0b0dea92a1b831224e461 (patch) | |
tree | 4dbeeff652a3852acd401c004a9941969d14170a /meta-networking/recipes-support | |
parent | 215ac2480564fda29b40721aaa8c887a04c918f8 (diff) | |
download | meta-openembedded-7041cdd3b47b410b59a0b0dea92a1b831224e461.tar.gz |
drbd-utils: add submodule drbd-headers into SRC_URI
1. add submodule drbd-headers into SRC_URI
drbd-headers is git submodule of drbd-utils, so drbd-headers's
code will not fetch during do_fetch. but it will get during
do_compile(there is a logic in drbd-utils's makefile to do this),
but if during do_compile, network is broken, fetch drbd-headers
will fail, then do_compile will fail since missing header file.
2. add patch for fix drbd init script
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r-- | meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch | 43 | ||||
-rw-r--r-- | meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb | 7 |
2 files changed, 48 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch new file mode 100644 index 000000000..c0f3adf24 --- /dev/null +++ b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | Subject: drbd-tools: only rmmod if DRBD is a module | ||
2 | |||
3 | Account for the case if the DRBD drive is built into | ||
4 | the kernel. Otherwise, errors, like the following, | ||
5 | will occur: | ||
6 | |||
7 | root@localhost:~# /etc/init.d/drbd stop | ||
8 | Stopping all DRBD resources: ERROR: Module drbd | ||
9 | does not exist in /proc/modules | ||
10 | |||
11 | Upstream-Status: Submitted [https://github.com/LINBIT/drbd-utils/pull/2] | ||
12 | |||
13 | Signed-off-by: Aws Ismail <aws.ismail@windriver.com> | ||
14 | Signed-off-by: Jason Wessel <jason.wessel@windriver.com> | ||
15 | |||
16 | [ refresh to 8.4.4: squash Aws' and Jason's patches ] | ||
17 | Signed-off-by: Michel Thebeau <michel.thebeau@windriver.com> | ||
18 | |||
19 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | ||
20 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
21 | |||
22 | --- | ||
23 | scripts/drbd | 4 +++- | ||
24 | 1 file changed, 3 insertions(+), 1 deletion(-) | ||
25 | |||
26 | diff --git a/scripts/drbd b/scripts/drbd | ||
27 | index 20bf628..de589dc 100755 | ||
28 | --- a/scripts/drbd | ||
29 | +++ b/scripts/drbd | ||
30 | @@ -241,7 +241,9 @@ case "$1" in | ||
31 | if [ -d /sys/module/drbd/holders ]; then | ||
32 | (cd /sys/module/drbd/holders; for tr in *; do [ -d ${tr} ] && ${RMMOD} ${tr}; done) | ||
33 | fi | ||
34 | - $RMMOD drbd && break | ||
35 | + if [ ! -z "$(cat /proc/modules | grep -w drbd)" ]; then | ||
36 | + $RMMOD drbd && break | ||
37 | + fi | ||
38 | fi | ||
39 | done | ||
40 | run_hook stop | ||
41 | -- | ||
42 | 1.9.1 | ||
43 | |||
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb b/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb index d6e913f00..98d4a49c7 100644 --- a/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb +++ b/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb | |||
@@ -8,10 +8,13 @@ SECTION = "admin" | |||
8 | LICENSE = "GPLv2+" | 8 | LICENSE = "GPLv2+" |
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/LINBIT/drbd-utils \ | 11 | SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \ |
12 | git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \ | ||
13 | file://0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch \ | ||
12 | " | 14 | " |
13 | # v9.4.0 | 15 | # v9.4.0 |
14 | SRCREV = "eff6423ee72931aa0f8d0eb51742acee7c7cd3e1" | 16 | SRCREV_drbd-utils = "eff6423ee72931aa0f8d0eb51742acee7c7cd3e1" |
17 | SRCREV_drbd-headers = "d9ef0576d0f29992e0539ed7ca14d4f12658cd25" | ||
15 | 18 | ||
16 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
17 | 20 | ||