summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-08 09:20:11 -0800
committerKhem Raj <raj.khem@gmail.com>2019-03-08 09:52:54 -0800
commitec3307cebe5b6c2a020b535aa222f3220f97ce33 (patch)
tree868b4d76cd0ff33351f3579eaa434d3914d9dd0b /meta-networking/recipes-support
parent0857abadcc6b0ef9a05067599cecf31b5887cd12 (diff)
downloadmeta-openembedded-ec3307cebe5b6c2a020b535aa222f3220f97ce33.tar.gz
linux-atm: Fix build with linux 5.x headers
Fixes error: 'IFNAMSIZ' undeclared here Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/linux-atm/linux-atm/0001-IFNAMSIZ-is-defined-in-net-if.h.patch48
-rw-r--r--meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm/0001-IFNAMSIZ-is-defined-in-net-if.h.patch b/meta-networking/recipes-support/linux-atm/linux-atm/0001-IFNAMSIZ-is-defined-in-net-if.h.patch
new file mode 100644
index 000000000..a7c7093e0
--- /dev/null
+++ b/meta-networking/recipes-support/linux-atm/linux-atm/0001-IFNAMSIZ-is-defined-in-net-if.h.patch
@@ -0,0 +1,48 @@
1From 29b37e45577c0921846c1709a190f08a3b032666 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 8 Mar 2019 09:08:38 -0800
4Subject: [PATCH] IFNAMSIZ is defined in net/if.h
5
6Fixes
7/mnt/a/yoe/build/tmp/work/qemuriscv64-yoe-linux-musl/linux-atm/2.5.2-r0/recipe-sysroot/usr/include/linux/if_arp.h:121:16: error: 'IFNAMSIZ' undeclared here (not in a function)
8| char arp_dev[IFNAMSIZ];
9| ^~~~~~~~
10In file included from ../../../linux-atm-2.5.2/src/arpd/itf.c:17:
11/mnt/a/yoe/build/tmp/work/qemuriscv64-yoe-linux-musl/linux-atm/2.5.2-r0/recipe-sysroot/usr/include/linux/if_arp.h:121:16: error: 'IFNAMSIZ' undeclared here (not in a function)
12| char arp_dev[IFNAMSIZ];
13| ^~~~~~~~
14
15Upstream-Status: Pending
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 src/arpd/arp.c | 1 +
19 src/arpd/itf.c | 1 +
20 2 files changed, 2 insertions(+)
21
22diff --git a/src/arpd/arp.c b/src/arpd/arp.c
23index 92d3787..ff1574c 100644
24--- a/src/arpd/arp.c
25+++ b/src/arpd/arp.c
26@@ -17,6 +17,7 @@
27 #include <netinet/in.h> /* for ntohs, etc. */
28 #define _LINUX_NETDEVICE_H /* very crude hack for glibc2 */
29 #include <linux/types.h>
30+#include <net/if.h>
31 #include <linux/if_arp.h>
32 #include <linux/if_ether.h>
33 #include <atm.h>
34diff --git a/src/arpd/itf.c b/src/arpd/itf.c
35index 92f0951..d285e3b 100644
36--- a/src/arpd/itf.c
37+++ b/src/arpd/itf.c
38@@ -14,6 +14,7 @@
39 #include <sys/socket.h>
40 #define _LINUX_NETDEVICE_H /* glibc2 */
41 #include <linux/types.h>
42+#include <net/if.h>
43 #include <linux/if_arp.h>
44
45 #include "atmd.h"
46--
472.21.0
48
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
index 9fce4fba6..51682b1ed 100644
--- a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
+++ b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb
@@ -14,6 +14,7 @@ SRC_URI = "http://nchc.dl.sourceforge.net/project/${BPN}/${BPN}/${PV}/${BPN}-${P
14 file://0001-ttcp-Add-printf-format-string.patch \ 14 file://0001-ttcp-Add-printf-format-string.patch \
15 file://0002-sigd-Replace-on_exit-API-with-atexit.patch \ 15 file://0002-sigd-Replace-on_exit-API-with-atexit.patch \
16 file://0003-mpoad-Drop-old-hack-to-compile-with-very-old-glibc.patch \ 16 file://0003-mpoad-Drop-old-hack-to-compile-with-very-old-glibc.patch \
17 file://0001-IFNAMSIZ-is-defined-in-net-if.h.patch \
17" 18"
18 19
19SRC_URI[md5sum] = "d49499368c3cf15f73a05d9bce8824a8" 20SRC_URI[md5sum] = "d49499368c3cf15f73a05d9bce8824a8"