summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-06-17 00:52:28 -0700
committerKhem Raj <raj.khem@gmail.com>2018-06-17 00:52:28 -0700
commit803a69aa677b5dd31f5e7939bffc6c326e9673df (patch)
tree3f06a5d210048e0983f95f6854284b3503552d47 /meta-networking/recipes-support
parentad8129041e1fdd4b7fa6f854f12c25b4e924456c (diff)
downloadmeta-openembedded-803a69aa677b5dd31f5e7939bffc6c326e9673df.tar.gz
move cpprest to meta-oe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch59
-rw-r--r--meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb17
2 files changed, 0 insertions, 76 deletions
diff --git a/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch b/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch
deleted file mode 100644
index 56fd704ad..000000000
--- a/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch
+++ /dev/null
@@ -1,59 +0,0 @@
1Description: install cmake files into /usr/lib/cmake/cpprestsdk
2Author: Gianfranco Costamagna <locutusofborg@debian.org>
3Upstream-Status: https://github.com/Microsoft/cpprestsdk/pull/737
4Forwarded: https://github.com/Microsoft/cpprestsdk/pull/737
5Last-Update: 2018-04-19
6
7Index: cpprest/CMakeLists.txt
8===================================================================
9--- cpprest.orig/CMakeLists.txt
10+++ cpprest/CMakeLists.txt
11@@ -18,7 +18,6 @@
12 set(WERROR ON CACHE BOOL "Treat Warnings as Errors.")
13 set(CPPREST_EXCLUDE_WEBSOCKETS OFF CACHE BOOL "Exclude websockets functionality.")
14 set(CPPREST_EXCLUDE_COMPRESSION OFF CACHE BOOL "Exclude compression functionality.")
15-set(CPPREST_EXPORT_DIR lib/cpprestsdk CACHE STRING "Directory to install CMake config files.")
16 set(CPPREST_INSTALL_HEADERS ON CACHE BOOL "Install header files.")
17 set(CPPREST_INSTALL ON CACHE BOOL "Add install commands.")
18
19@@ -63,6 +62,9 @@
20 include(cmake/cpprest_find_openssl.cmake)
21 include(cmake/cpprest_find_websocketpp.cmake)
22 include(CheckIncludeFiles)
23+if(UNIX)
24+include(GNUInstallDirs)
25+endif(UNIX)
26
27 find_package(Threads REQUIRED)
28 if(THREADS_HAVE_PTHREAD_ARG)
29Index: cpprest/src/CMakeLists.txt
30===================================================================
31--- cpprest.orig/src/CMakeLists.txt
32+++ cpprest/src/CMakeLists.txt
33@@ -250,21 +250,21 @@
34 install(
35 TARGETS ${CPPREST_TARGETS}
36 EXPORT cpprestsdk-targets
37- RUNTIME DESTINATION bin
38- LIBRARY DESTINATION lib
39- ARCHIVE DESTINATION lib
40+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
41+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
42+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
43 )
44
45 configure_file(../cmake/cpprestsdk-config.in.cmake "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake" @ONLY)
46
47 install(
48 FILES "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake"
49- DESTINATION ${CPPREST_EXPORT_DIR}
50+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
51 )
52 install(
53 EXPORT cpprestsdk-targets
54 FILE cpprestsdk-targets.cmake
55 NAMESPACE cpprestsdk::
56- DESTINATION ${CPPREST_EXPORT_DIR}
57+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
58 )
59 endif()
diff --git a/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb b/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb
deleted file mode 100644
index 2ba6fc66c..000000000
--- a/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
2SECTION = "libs/network"
3HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${S}/../license.txt;md5=a2e15b954769218ff912468eecd6a02f"
6DEPENDS = "openssl websocketpp zlib boost"
7
8SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master"
9
10SRC_URI += "file://fix-cmake-install.patch"
11
12# tag 2.10.2
13SRCREV= "fea848e2a77563cf2a6f28f8eab396fd6e787fbf"
14
15S = "${WORKDIR}/git/Release"
16
17inherit cmake