diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-05-23 08:23:53 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-05-23 10:46:34 -0700 |
commit | 4ee7becad0b72d5d637bf304d7c0666b3fd5af32 (patch) | |
tree | 5270d92f84b0dceb6bf81fe7b2b9c1305dc8bd1d /meta-networking/recipes-support | |
parent | 321a62261dee657b219d4396e9cbafb7b1425e39 (diff) | |
download | meta-openembedded-4ee7becad0b72d5d637bf304d7c0666b3fd5af32.tar.gz |
spice,spice-protocol: Uprev to 0.14.0
Drop the patch for fixing printf formatting, its fixed differently
upstream
Forward port pthread_t printf patch
Add -Wno-address-of-packed-member needed with gcc9
replace _append += with just _append syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
4 files changed, 17 insertions, 59 deletions
diff --git a/meta-networking/recipes-support/spice/spice-protocol_git.bb b/meta-networking/recipes-support/spice/spice-protocol_git.bb index 30d0a7675..be9dba32f 100644 --- a/meta-networking/recipes-support/spice/spice-protocol_git.bb +++ b/meta-networking/recipes-support/spice/spice-protocol_git.bb | |||
@@ -13,9 +13,9 @@ architectures." | |||
13 | LICENSE = "BSD" | 13 | LICENSE = "BSD" |
14 | LIC_FILES_CHKSUM = "file://COPYING;md5=b37311cb5604f3e5cc2fb0fd23527e95" | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=b37311cb5604f3e5cc2fb0fd23527e95" |
15 | 15 | ||
16 | PV = "0.12.13+git${SRCPV}" | 16 | PV = "0.14.0+git${SRCPV}" |
17 | 17 | ||
18 | SRCREV = "87441524f4e7b79658e42bd8f1f6c3e3c8649aa5" | 18 | SRCREV = "f72ece993aeaf23f77e2845562b20e5563e52ba0" |
19 | 19 | ||
20 | SRC_URI = " \ | 20 | SRC_URI = " \ |
21 | git://anongit.freedesktop.org/spice/spice-protocol \ | 21 | git://anongit.freedesktop.org/spice/spice-protocol \ |
diff --git a/meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch b/meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch index 505b7c890..e63cbe3b7 100644 --- a/meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch +++ b/meta-networking/recipes-support/spice/spice/0001-Convert-pthread_t-to-be-numeric.patch | |||
@@ -14,21 +14,19 @@ Upstream-Status: Pending | |||
14 | server/red-client.c | 6 +++--- | 14 | server/red-client.c | 6 +++--- |
15 | 2 files changed, 6 insertions(+), 5 deletions(-) | 15 | 2 files changed, 6 insertions(+), 5 deletions(-) |
16 | 16 | ||
17 | diff --git a/server/red-channel.c b/server/red-channel.c | ||
18 | index 1b38f04d..11dc667b 100644 | ||
19 | --- a/server/red-channel.c | 17 | --- a/server/red-channel.c |
20 | +++ b/server/red-channel.c | 18 | +++ b/server/red-channel.c |
21 | @@ -192,7 +192,7 @@ red_channel_constructed(GObject *object) | 19 | @@ -204,7 +204,7 @@ red_channel_constructed(GObject *object) |
22 | { | 20 | { |
23 | RedChannel *self = RED_CHANNEL(object); | 21 | RedChannel *self = RED_CHANNEL(object); |
24 | 22 | ||
25 | - red_channel_debug(self, "thread_id 0x%lx", self->priv->thread_id); | 23 | - red_channel_debug(self, "thread_id 0x%" G_GSIZE_MODIFIER "x", self->priv->thread_id); |
26 | + red_channel_debug(self, "thread_id 0x%lx", (unsigned long)self->priv->thread_id); | 24 | + red_channel_debug(self, "thread_id 0x%" G_GSIZE_MODIFIER "x", (unsigned long)self->priv->thread_id); |
27 | 25 | ||
28 | RedChannelClass *klass = RED_CHANNEL_GET_CLASS(self); | 26 | RedChannelClass *klass = RED_CHANNEL_GET_CLASS(self); |
29 | 27 | ||
30 | @@ -475,7 +475,8 @@ void red_channel_remove_client(RedChannel *channel, RedChannelClient *rcc) | 28 | @@ -479,7 +479,8 @@ void red_channel_remove_client(RedChanne |
31 | red_channel_warning(channel, "channel->thread_id (0x%lx) != pthread_self (0x%lx)." | 29 | "pthread_self (0x%" G_GSIZE_MODIFIER "x)." |
32 | "If one of the threads is != io-thread && != vcpu-thread, " | 30 | "If one of the threads is != io-thread && != vcpu-thread, " |
33 | "this might be a BUG", | 31 | "this might be a BUG", |
34 | - channel->priv->thread_id, pthread_self()); | 32 | - channel->priv->thread_id, pthread_self()); |
@@ -37,12 +35,10 @@ index 1b38f04d..11dc667b 100644 | |||
37 | } | 35 | } |
38 | spice_return_if_fail(channel); | 36 | spice_return_if_fail(channel); |
39 | link = g_list_find(channel->priv->clients, rcc); | 37 | link = g_list_find(channel->priv->clients, rcc); |
40 | diff --git a/server/red-client.c b/server/red-client.c | ||
41 | index ddfc5400..76986640 100644 | ||
42 | --- a/server/red-client.c | 38 | --- a/server/red-client.c |
43 | +++ b/server/red-client.c | 39 | +++ b/server/red-client.c |
44 | @@ -180,7 +180,7 @@ void red_client_migrate(RedClient *client) | 40 | @@ -180,7 +180,7 @@ void red_client_migrate(RedClient *clien |
45 | spice_warning("client->thread_id (0x%lx) != pthread_self (0x%lx)." | 41 | "pthread_self (0x%" G_GSIZE_MODIFIER "x)." |
46 | "If one of the threads is != io-thread && != vcpu-thread," | 42 | "If one of the threads is != io-thread && != vcpu-thread," |
47 | " this might be a BUG", | 43 | " this might be a BUG", |
48 | - client->thread_id, pthread_self()); | 44 | - client->thread_id, pthread_self()); |
@@ -50,8 +46,8 @@ index ddfc5400..76986640 100644 | |||
50 | } | 46 | } |
51 | FOREACH_CHANNEL_CLIENT(client, rcc) { | 47 | FOREACH_CHANNEL_CLIENT(client, rcc) { |
52 | if (red_channel_client_is_connected(rcc)) { | 48 | if (red_channel_client_is_connected(rcc)) { |
53 | @@ -199,8 +199,8 @@ void red_client_destroy(RedClient *client) | 49 | @@ -199,8 +199,8 @@ void red_client_destroy(RedClient *clien |
54 | spice_warning("client->thread_id (0x%lx) != pthread_self (0x%lx)." | 50 | "pthread_self (0x%" G_GSIZE_MODIFIER "x)." |
55 | "If one of the threads is != io-thread && != vcpu-thread," | 51 | "If one of the threads is != io-thread && != vcpu-thread," |
56 | " this might be a BUG", | 52 | " this might be a BUG", |
57 | - client->thread_id, | 53 | - client->thread_id, |
@@ -61,6 +57,3 @@ index ddfc5400..76986640 100644 | |||
61 | } | 57 | } |
62 | red_client_set_disconnecting(client); | 58 | red_client_set_disconnecting(client); |
63 | FOREACH_CHANNEL_CLIENT(client, rcc) { | 59 | FOREACH_CHANNEL_CLIENT(client, rcc) { |
64 | -- | ||
65 | 2.17.1 | ||
66 | |||
diff --git a/meta-networking/recipes-support/spice/spice/0001-spice-fix-compile-fail-problem.patch b/meta-networking/recipes-support/spice/spice/0001-spice-fix-compile-fail-problem.patch deleted file mode 100644 index 1f9d5fdd7..000000000 --- a/meta-networking/recipes-support/spice/spice/0001-spice-fix-compile-fail-problem.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | From 7023732c65b4dc509c46a54fb7715da275b5597f Mon Sep 17 00:00:00 2001 | ||
2 | From: Changqing Li <changqing.li@windriver.com> | ||
3 | Date: Thu, 13 Sep 2018 12:39:44 +0800 | ||
4 | Subject: [PATCH] spice: fix compile fail problem | ||
5 | |||
6 | compile error: | ||
7 | format '%d' expects argument of type 'int', but argument 6 has | ||
8 | type 'long unsigned int' [-Werror=format=] | ||
9 | |||
10 | spice compile failed on 32bit system, since upstream commit | ||
11 | 9541cd2fe(in V0.14.1) change %ld to %PRIdPTR, %PRIdPTR is %d, but argument | ||
12 | strm.total_out is uLong. | ||
13 | |||
14 | Upstream-Status: Submitted[https://github.com/freedesktop/spice/pull/1] | ||
15 | |||
16 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
17 | --- | ||
18 | server/red-replay-qxl.c | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/server/red-replay-qxl.c b/server/red-replay-qxl.c | ||
22 | index 1fce76c..bd33b58 100644 | ||
23 | --- a/server/red-replay-qxl.c | ||
24 | +++ b/server/red-replay-qxl.c | ||
25 | @@ -266,7 +266,7 @@ static replay_t read_binary(SpiceReplay *replay, const char *prefix, size_t *siz | ||
26 | exit(1); | ||
27 | } | ||
28 | if ((ret = inflate(&strm, Z_NO_FLUSH)) != Z_STREAM_END) { | ||
29 | - spice_error("inflate error %d (disc: %" PRIdPTR ")", ret, *size - strm.total_out); | ||
30 | + spice_error("inflate error %d (disc: %ld)", ret, *size - strm.total_out); | ||
31 | if (ret == Z_DATA_ERROR) { | ||
32 | /* last operation may be wrong. since we do the recording | ||
33 | * in red_worker, when there is a shutdown from the vcpu/io thread | ||
34 | -- | ||
35 | 2.7.4 | ||
36 | |||
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb index 1ad46c2c3..6249b0422 100644 --- a/meta-networking/recipes-support/spice/spice_git.bb +++ b/meta-networking/recipes-support/spice/spice_git.bb | |||
@@ -13,10 +13,10 @@ architectures." | |||
13 | LICENSE = "BSD & LGPLv2.1+" | 13 | LICENSE = "BSD & LGPLv2.1+" |
14 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
15 | 15 | ||
16 | PV = "0.14.1+git${SRCPV}" | 16 | PV = "0.14.2+git${SRCPV}" |
17 | 17 | ||
18 | SRCREV_spice = "eaa07ef15cfc3bf57a69da2576af66f028787774" | 18 | SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b" |
19 | SRCREV_spice-common = "6b93b3fce8909b836ef1d1434d191900d8aa00be" | 19 | SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671" |
20 | 20 | ||
21 | SRCREV_FORMAT = "spice_spice-common" | 21 | SRCREV_FORMAT = "spice_spice-common" |
22 | 22 | ||
@@ -24,7 +24,6 @@ SRC_URI = " \ | |||
24 | git://anongit.freedesktop.org/spice/spice;name=spice \ | 24 | git://anongit.freedesktop.org/spice/spice;name=spice \ |
25 | git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \ | 25 | git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \ |
26 | file://0001-Convert-pthread_t-to-be-numeric.patch \ | 26 | file://0001-Convert-pthread_t-to-be-numeric.patch \ |
27 | file://0001-spice-fix-compile-fail-problem.patch \ | ||
28 | " | 27 | " |
29 | 28 | ||
30 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
@@ -37,6 +36,8 @@ DEPENDS_append_class-nativesdk = "nativesdk-openssl" | |||
37 | export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" | 36 | export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" |
38 | export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages" | 37 | export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages" |
39 | 38 | ||
39 | CFLAGS += "-Wno-address-of-packed-member" | ||
40 | |||
40 | PACKAGECONFIG_class-native = "" | 41 | PACKAGECONFIG_class-native = "" |
41 | PACKAGECONFIG_class-nativesdk = "" | 42 | PACKAGECONFIG_class-nativesdk = "" |
42 | PACKAGECONFIG ?= "sasl" | 43 | PACKAGECONFIG ?= "sasl" |
@@ -54,4 +55,4 @@ COMPATIBLE_HOST = '(x86_64|i.86).*-linux' | |||
54 | 55 | ||
55 | BBCLASSEXTEND = "native nativesdk" | 56 | BBCLASSEXTEND = "native nativesdk" |
56 | 57 | ||
57 | EXTRA_OECONF_toolchain-clang += "--disable-werror" | 58 | EXTRA_OECONF_append_toolchain-clang = " --disable-werror" |