summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-03-01 18:30:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-07 13:30:26 +0100
commit0c31f55bcfd6630d894dd2dda6ca483bea5de4ab (patch)
tree362ae6300bfa295709e24a4879639fb4c0fb5116 /meta-networking/recipes-support
parentb4524eb786472e69e28212a58a329a5e44e40547 (diff)
downloadmeta-openembedded-0c31f55bcfd6630d894dd2dda6ca483bea5de4ab.tar.gz
Make use of the new bb.utils.filter() function
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/chrony/chrony_2.4.bb2
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq.inc6
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.2.25.bb5
-rw-r--r--meta-networking/recipes-support/fping/fping_3.5.bb2
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.1.29.bb2
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb2
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb2
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb2
-rw-r--r--meta-networking/recipes-support/mtr/mtr_0.86.bb2
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb2
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_1.38.bb2
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_2.2.bb2
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p9.bb2
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.5.1.bb2
-rw-r--r--meta-networking/recipes-support/stunnel/stunnel_5.35.bb4
-rw-r--r--meta-networking/recipes-support/tnftp/tnftp_20151004.bb2
16 files changed, 18 insertions, 23 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony_2.4.bb b/meta-networking/recipes-support/chrony/chrony_2.4.bb
index deb2148e6..ad8170199 100644
--- a/meta-networking/recipes-support/chrony/chrony_2.4.bb
+++ b/meta-networking/recipes-support/chrony/chrony_2.4.bb
@@ -59,7 +59,7 @@ inherit update-rc.d systemd
59# - 'scfilter' enables support for system call filtering, but requires the 59# - 'scfilter' enables support for system call filtering, but requires the
60# kernel to have CONFIG_SECCOMP enabled. 60# kernel to have CONFIG_SECCOMP enabled.
61PACKAGECONFIG ??= "editline scfilter \ 61PACKAGECONFIG ??= "editline scfilter \
62 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ 62 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
63" 63"
64PACKAGECONFIG[readline] = "--without-editline,--without-readline,readline" 64PACKAGECONFIG[readline] = "--without-editline,--without-readline,readline"
65PACKAGECONFIG[editline] = ",--without-editline,libedit" 65PACKAGECONFIG[editline] = ",--without-editline,libedit"
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
index 424a06b32..ef79c5f82 100644
--- a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
@@ -53,7 +53,7 @@ do_install () {
53 53
54 install -d ${D}${systemd_unitdir}/system 54 install -d ${D}${systemd_unitdir}/system
55 55
56 if [ "${@bb.utils.contains('PACKAGECONFIG', 'resolvconf', 'resolvconf', '', d)}" != "" ]; then 56 if [ "${@bb.utils.filter('PACKAGECONFIG', 'resolvconf', d)}" ]; then
57 install -m 0644 ${WORKDIR}/dnsmasq-resolvconf.service ${D}${systemd_unitdir}/system/dnsmasq.service 57 install -m 0644 ${WORKDIR}/dnsmasq-resolvconf.service ${D}${systemd_unitdir}/system/dnsmasq.service
58 else 58 else
59 install -m 0644 ${WORKDIR}/dnsmasq-noresolvconf.service ${D}${systemd_unitdir}/system/dnsmasq.service 59 install -m 0644 ${WORKDIR}/dnsmasq-noresolvconf.service ${D}${systemd_unitdir}/system/dnsmasq.service
@@ -61,11 +61,11 @@ do_install () {
61 61
62 install -m 0755 ${S}/contrib/lease-tools/dhcp_release ${D}${bindir} 62 install -m 0755 ${S}/contrib/lease-tools/dhcp_release ${D}${bindir}
63 63
64 if [ "${@bb.utils.contains('PACKAGECONFIG', 'dbus', 'dbus', '', d)}" != "" ]; then 64 if [ "${@bb.utils.filter('PACKAGECONFIG', 'dbus', d)}" ]; then
65 install -d ${D}${sysconfdir}/dbus-1/system.d 65 install -d ${D}${sysconfdir}/dbus-1/system.d
66 install -m 644 dbus/dnsmasq.conf ${D}${sysconfdir}/dbus-1/system.d/ 66 install -m 644 dbus/dnsmasq.conf ${D}${sysconfdir}/dbus-1/system.d/
67 fi 67 fi
68 if [ "${@bb.utils.contains('PACKAGECONFIG', 'resolvconf', 'resolvconf', '', d)}" != "" ]; then 68 if [ "${@bb.utils.filter('PACKAGECONFIG', 'resolvconf', d)}" ]; then
69 install -d ${D}${sysconfdir}/resolvconf/update.d/ 69 install -d ${D}${sysconfdir}/resolvconf/update.d/
70 install -m 0755 ${WORKDIR}/dnsmasq.resolvconf ${D}${sysconfdir}/resolvconf/update.d/dnsmasq 70 install -m 0755 ${WORKDIR}/dnsmasq.resolvconf ${D}${sysconfdir}/resolvconf/update.d/dnsmasq
71 71
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.25.bb b/meta-networking/recipes-support/dovecot/dovecot_2.2.25.bb
index 66af361e4..b2ead4b19 100644
--- a/meta-networking/recipes-support/dovecot/dovecot_2.2.25.bb
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.2.25.bb
@@ -16,10 +16,7 @@ DEPENDS = "openssl xz zlib bzip2 libcap icu"
16 16
17inherit autotools pkgconfig systemd useradd 17inherit autotools pkgconfig systemd useradd
18 18
19PACKAGECONFIG ??= " \ 19PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ldap pam', d)}"
20 ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
22 "
23 20
24PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam," 21PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
25PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap," 22PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
diff --git a/meta-networking/recipes-support/fping/fping_3.5.bb b/meta-networking/recipes-support/fping/fping_3.5.bb
index 2f5f2b6c6..82e3bf073 100644
--- a/meta-networking/recipes-support/fping/fping_3.5.bb
+++ b/meta-networking/recipes-support/fping/fping_3.5.bb
@@ -21,5 +21,5 @@ inherit autotools
21 21
22EXTRA_OECONF = "--enable-ipv4" 22EXTRA_OECONF = "--enable-ipv4"
23 23
24PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}" 24PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
25PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," 25PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta-networking/recipes-support/libldb/libldb_1.1.29.bb b/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
index 28cb8479f..a90919ba4 100644
--- a/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
+++ b/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
@@ -12,7 +12,7 @@ SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \
12 " 12 "
13 13
14PACKAGECONFIG ??= "\ 14PACKAGECONFIG ??= "\
15 ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \ 15 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \ 16 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
17" 17"
18PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl" 18PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
index 26bd1d58a..0283088ff 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
+++ b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "22d14911164d4de67ff76b5269fa5250d01f78c955bc77e28615350996
16inherit waf-samba 16inherit waf-samba
17 17
18PACKAGECONFIG ??= "\ 18PACKAGECONFIG ??= "\
19 ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \ 19 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \ 20 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
21" 21"
22PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl" 22PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb b/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
index fa1f0c5f7..e256ac9b6 100644
--- a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
+++ b/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
@@ -14,7 +14,7 @@ SRC_URI[md5sum] = "d9627e7aacd535a8251401f914bb6924"
14SRC_URI[sha256sum] = "60134e32253cac8e2efe5e0185d20123c208bcf6ad15edf2f50d80daadf8c348" 14SRC_URI[sha256sum] = "60134e32253cac8e2efe5e0185d20123c208bcf6ad15edf2f50d80daadf8c348"
15 15
16PACKAGECONFIG ??= "\ 16PACKAGECONFIG ??= "\
17 ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \ 17 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
18 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \ 18 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
19" 19"
20PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl" 20PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
index f9657d2d5..ad711e730 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
@@ -17,7 +17,7 @@ SRC_URI[sha256sum] = "4a13f2256ad804c860e84068258bd0f8be31cf0c79aa8f3019fa32f692
17inherit waf-samba 17inherit waf-samba
18 18
19PACKAGECONFIG ??= "\ 19PACKAGECONFIG ??= "\
20 ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \ 20 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \ 21 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
22" 22"
23PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl" 23PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
diff --git a/meta-networking/recipes-support/mtr/mtr_0.86.bb b/meta-networking/recipes-support/mtr/mtr_0.86.bb
index 1d8a2cf9d..92f4f3c0b 100644
--- a/meta-networking/recipes-support/mtr/mtr_0.86.bb
+++ b/meta-networking/recipes-support/mtr/mtr_0.86.bb
@@ -17,5 +17,5 @@ inherit autotools
17 17
18EXTRA_OECONF = "--without-gtk" 18EXTRA_OECONF = "--without-gtk"
19 19
20PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}" 20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
21PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," 21PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index ed713ace2..90c77c9f5 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -20,7 +20,7 @@ inherit gettext autotools pkgconfig systemd
20 20
21EXTRA_OECONF_append_class-target = " --with-driver=redhat" 21EXTRA_OECONF_append_class-target = " --with-driver=redhat"
22 22
23PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}" 23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
24PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts," 24PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts,"
25 25
26do_configure_prepend() { 26do_configure_prepend() {
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
index 9fc6406b7..b9c0aa700 100644
--- a/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
+++ b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
@@ -19,7 +19,7 @@ This is the final IPv4-only version of ypbind-mt. \
19HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html" 19HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
20DEPENDS = " \ 20DEPENDS = " \
21 yp-tools \ 21 yp-tools \
22 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ 22 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
23 " 23 "
24RDEPENDS_${PN} += "yp-tools" 24RDEPENDS_${PN} += "yp-tools"
25 25
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb b/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
index 82544e759..5e0056738 100644
--- a/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
+++ b/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
@@ -15,7 +15,7 @@ of known secure NIS server (/etc/yp.conf) Binds to \
15the server which answered as first. \ 15the server which answered as first. \
16" 16"
17HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html" 17HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
18DEPENDS = "yp-tools ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 18DEPENDS = "yp-tools ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
19PROVIDES += "ypbind" 19PROVIDES += "ypbind"
20 20
21PNBLACKLIST[ypbind-mt] ?= "BROKEN: Depends on broken yp-tools" 21PNBLACKLIST[ypbind-mt] ?= "BROKEN: Depends on broken yp-tools"
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p9.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p9.bb
index 9d74c96f3..58b31c5ca 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p9.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p9.bb
@@ -47,7 +47,7 @@ USERADD_PARAM_${PN} = "--system --home-dir ${NTP_USER_HOME} \
47 47
48# NB: debug is default-enabled by NTP; keep it default-enabled here. 48# NB: debug is default-enabled by NTP; keep it default-enabled here.
49PACKAGECONFIG ??= "cap debug refclocks openssl \ 49PACKAGECONFIG ??= "cap debug refclocks openssl \
50 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ 50 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
51" 51"
52PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \ 52PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
53 --with-openssl-incdir=${STAGING_INCDIR} \ 53 --with-openssl-incdir=${STAGING_INCDIR} \
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.5.1.bb b/meta-networking/recipes-support/strongswan/strongswan_5.5.1.bb
index 9c1190426..f9e7ae3c1 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.5.1.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.5.1.bb
@@ -22,7 +22,7 @@ EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-syst
22 22
23 23
24PACKAGECONFIG ??= "charon curl gmp openssl stroke sqlite3 \ 24PACKAGECONFIG ??= "charon curl gmp openssl stroke sqlite3 \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \ 25 ${@bb.utils.filter('DISTRO_FEATURES', 'ldap', d)} \
26" 26"
27PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni," 27PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,"
28PACKAGECONFIG[charon] = "--enable-charon,--disable-charon," 28PACKAGECONFIG[charon] = "--enable-charon,--disable-charon,"
diff --git a/meta-networking/recipes-support/stunnel/stunnel_5.35.bb b/meta-networking/recipes-support/stunnel/stunnel_5.35.bb
index 51369f4d4..3e2e2c229 100644
--- a/meta-networking/recipes-support/stunnel/stunnel_5.35.bb
+++ b/meta-networking/recipes-support/stunnel/stunnel_5.35.bb
@@ -16,8 +16,6 @@ inherit autotools
16 16
17EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips" 17EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips"
18 18
19PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)} \ 19PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)}"
20 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
21"
22PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd" 20PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
23PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," 21PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta-networking/recipes-support/tnftp/tnftp_20151004.bb b/meta-networking/recipes-support/tnftp/tnftp_20151004.bb
index 8c2c111fd..83ad11b0e 100644
--- a/meta-networking/recipes-support/tnftp/tnftp_20151004.bb
+++ b/meta-networking/recipes-support/tnftp/tnftp_20151004.bb
@@ -33,7 +33,7 @@ SRC_URI[md5sum] = "a49fbe752318d5a7893f900046ea00d5"
33SRC_URI[sha256sum] = "c94a8a49d3f4aec1965feea831d4d5bf6f90c65fd8381ee0863d11a5029a43a0" 33SRC_URI[sha256sum] = "c94a8a49d3f4aec1965feea831d4d5bf6f90c65fd8381ee0863d11a5029a43a0"
34 34
35PACKAGECONFIG ?= "openssl \ 35PACKAGECONFIG ?= "openssl \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ 36 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
37" 37"
38PACKAGECONFIG[openssl] = "--enable-ssl, --disable-ssl --with-ssl=no, openssl" 38PACKAGECONFIG[openssl] = "--enable-ssl, --disable-ssl --with-ssl=no, openssl"
39PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," 39PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"