summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-19 22:31:47 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-03-24 14:10:18 -0400
commit2b33f910134d01ee082f19202eea2aa16738b1de (patch)
tree8125ae8b790d84284e665a4e606ee612da398346 /meta-networking/recipes-support
parent762d1eb305fba89836f2912e4c077105373f30ea (diff)
downloadmeta-openembedded-2b33f910134d01ee082f19202eea2aa16738b1de.tar.gz
libmemcached: Upgrade to 1.0.18
Fix with musl along Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch38
-rw-r--r--meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch28
-rw-r--r--meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch30
-rw-r--r--meta-networking/recipes-support/libmemcached/libmemcached.inc1
-rw-r--r--meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb6
-rw-r--r--meta-networking/recipes-support/libmemcached/libmemcached_1.0.18.bb10
6 files changed, 107 insertions, 6 deletions
diff --git a/meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch b/meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch
new file mode 100644
index 000000000..26b5e250c
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/files/0001-Fix-comparison-types.patch
@@ -0,0 +1,38 @@
1From ed4422979b221c8613ca02eb5c57cb80009366d1 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Mar 2017 10:13:24 -0700
4Subject: [PATCH 1/2] Fix comparison types
5
6Fixes
7error: comparison between pointer and integer ('char *' and 'int')
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 clients/memflush.cc | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/clients/memflush.cc b/clients/memflush.cc
15index 8bd0dbf..71545ea 100644
16--- a/clients/memflush.cc
17+++ b/clients/memflush.cc
18@@ -39,7 +39,7 @@ int main(int argc, char *argv[])
19 {
20 options_parse(argc, argv);
21
22- if (opt_servers == false)
23+ if (opt_servers == NULL)
24 {
25 char *temp;
26
27@@ -48,7 +48,7 @@ int main(int argc, char *argv[])
28 opt_servers= strdup(temp);
29 }
30
31- if (opt_servers == false)
32+ if (opt_servers == NULL)
33 {
34 std::cerr << "No Servers provided" << std::endl;
35 exit(EXIT_FAILURE);
36--
372.12.0
38
diff --git a/meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch b/meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch
new file mode 100644
index 000000000..06febc5b1
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/files/0001-configure.ac-Do-not-configure-build-aux.patch
@@ -0,0 +1,28 @@
1From fa0fe001a5373c1ef9ff2175555b14fc07399e1b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Mar 2017 10:01:44 -0700
4Subject: [PATCH] configure.ac: Do not configure build-aux
5
6Fixes
7configure: error: cannot find install-sh, install.sh, or shtool
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 configure.ac | 1 -
12 1 file changed, 1 deletion(-)
13
14diff --git a/configure.ac b/configure.ac
15index 17b7351..0263112 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -17,7 +17,6 @@ AC_INIT([libmemcached],VERSION_NUMBER,[http://libmemcached.org/])
19 AC_PROG_CC([cc gcc clang])
20 AC_PROG_CXX([c++ g++ clang++])
21
22-AC_CONFIG_AUX_DIR([build-aux])
23 AC_CONFIG_MACRO_DIR([m4])
24
25 AC_CANONICAL_HOST
26--
272.12.0
28
diff --git a/meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch b/meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch
new file mode 100644
index 000000000..e1e1be8c6
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/files/0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch
@@ -0,0 +1,30 @@
1From e95609e4ae40a794ed198924505fd22d7d86a124 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Mar 2017 10:16:14 -0700
4Subject: [PATCH 2/2] POSIX_SPAWN_USEVFORK is not linux specific but glibc
5 specific
6
7Fixes
8cmdline.cc:206:12: error: use of undeclared identifier 'POSIX_SPAWN_USEVFORK'
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 libtest/cmdline.cc | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/libtest/cmdline.cc b/libtest/cmdline.cc
16index 29a22de..34f0a89 100644
17--- a/libtest/cmdline.cc
18+++ b/libtest/cmdline.cc
19@@ -201,7 +201,7 @@ Application::error_t Application::run(const char *args[])
20
21 fatal_assert(posix_spawnattr_setsigmask(&spawnattr, &mask) == 0);
22
23-#if defined(POSIX_SPAWN_USEVFORK) || defined(__linux__)
24+#if defined(POSIX_SPAWN_USEVFORK) || defined(__GLIBC__)
25 // Use USEVFORK on linux
26 flags |= POSIX_SPAWN_USEVFORK;
27 #endif
28--
292.12.0
30
diff --git a/meta-networking/recipes-support/libmemcached/libmemcached.inc b/meta-networking/recipes-support/libmemcached/libmemcached.inc
index 172443a20..e86f832f8 100644
--- a/meta-networking/recipes-support/libmemcached/libmemcached.inc
+++ b/meta-networking/recipes-support/libmemcached/libmemcached.inc
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=865490941c91ba790f0ea78dec93bd60"
7SRC_URI = "http://launchpad.net/libmemcached/1.0/${PV}/+download/libmemcached-${PV}.tar.gz" 7SRC_URI = "http://launchpad.net/libmemcached/1.0/${PV}/+download/libmemcached-${PV}.tar.gz"
8 8
9TARGET_LDFLAGS += "-luuid" 9TARGET_LDFLAGS += "-luuid"
10TARGET_CFLAGS += "-D__USE_GNU -D_GNU_SOURCE"
10 11
11PACKAGECONFIG ??= "" 12PACKAGECONFIG ??= ""
12PACKAGECONFIG[sasl] = "--enable-sasl,--disable-sasl,cyrus-sasl" 13PACKAGECONFIG[sasl] = "--enable-sasl,--disable-sasl,cyrus-sasl"
diff --git a/meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb b/meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb
deleted file mode 100644
index 18232b4ce..000000000
--- a/meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1require libmemcached.inc
2
3SRC_URI += "file://crosscompile.patch"
4
5SRC_URI[md5sum] = "616297a1aedefc52b3f6922eda5d559a"
6SRC_URI[sha256sum] = "dd7e9560029835bddf761a5b4c2339d9e5c7374558659b6c11b2c95e7d3a4325"
diff --git a/meta-networking/recipes-support/libmemcached/libmemcached_1.0.18.bb b/meta-networking/recipes-support/libmemcached/libmemcached_1.0.18.bb
new file mode 100644
index 000000000..56778c048
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/libmemcached_1.0.18.bb
@@ -0,0 +1,10 @@
1require libmemcached.inc
2
3SRC_URI += "\
4 file://crosscompile.patch \
5 file://0001-configure.ac-Do-not-configure-build-aux.patch \
6 file://0001-Fix-comparison-types.patch \
7 file://0002-POSIX_SPAWN_USEVFORK-is-not-linux-specific-but-glibc.patch \
8 "
9SRC_URI[md5sum] = "b3958716b4e53ddc5992e6c49d97e819"
10SRC_URI[sha256sum] = "e22c0bb032fde08f53de9ffbc5a128233041d9f33b5de022c0978a2149885f82"