summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-12-28 10:16:24 +0800
committerKhem Raj <raj.khem@gmail.com>2020-12-28 22:34:02 -0800
commit667a7b10273e56f0ab9c522882cbdb68f89210a4 (patch)
treeb9a0bd30f1052de2e67549a26e266c1e9508ffea /meta-networking/recipes-support
parentd8426e0637d16cfe0ee1b129f49be22455d9d859 (diff)
downloadmeta-openembedded-667a7b10273e56f0ab9c522882cbdb68f89210a4.tar.gz
libtevent: upgrade 0.10.1 -> 0.10.2
Refresh the following patch: avoid-attr-unless-wanted.patch options-0.10.0.patch 0001-waf-add-support-of-cross_compile.patch Removed since this is included in 0.10.2 Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/0001-waf-add-support-of-cross_compile.patch62
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch24
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/options-0.10.0.patch25
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.10.2.bb (renamed from meta-networking/recipes-support/libtevent/libtevent_0.10.1.bb)5
4 files changed, 32 insertions, 84 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent/0001-waf-add-support-of-cross_compile.patch b/meta-networking/recipes-support/libtevent/libtevent/0001-waf-add-support-of-cross_compile.patch
deleted file mode 100644
index a717f1bbb..000000000
--- a/meta-networking/recipes-support/libtevent/libtevent/0001-waf-add-support-of-cross_compile.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From 4b8463ff43f8983a706b181c5292491f9f954be1 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Fri, 25 Jan 2019 15:00:59 +0800
4Subject: [PATCH] waf: add support of cross_compile
5
6After upgrade, waf also upgraded.
7
8on 1.5.19, for cross_compile, subprocess.Popen is set to be
9samba_cross.cross_Popen, which will not execute testprog on
10host, but only read result from cross-answers.txt which is
11passed by option --cross-answer
12
13part of old code:
14 args = Utils.to_list(kw.get('exec_args', []))
15 proc = Utils.pproc.Popen([lastprog] + args, stdout=Utils.pproc.PIPE, stderr=Utils.pproc.PIPE)
16
17but on new version, exec_args is not used and cause do_configure
18failed with Exec format error
19
20fixed by append cross anser related args to cmd
21
22Upstream-Status: Submitted [https://gitlab.com/samba-team/samba/merge_requests/211]
23
24Signed-off-by: Changqing Li <changqing.li@windriver.com>
25---
26 third_party/waf/waflib/Tools/c_config.py | 11 ++++++-----
27 1 file changed, 6 insertions(+), 5 deletions(-)
28
29diff --git a/third_party/waf/waflib/Tools/c_config.py b/third_party/waf/waflib/Tools/c_config.py
30index 7608215..767cf33 100644
31--- a/third_party/waf/waflib/Tools/c_config.py
32+++ b/third_party/waf/waflib/Tools/c_config.py
33@@ -660,20 +660,21 @@ class test_exec(Task.Task):
34 """
35 color = 'PINK'
36 def run(self):
37+ args = self.generator.bld.kw.get('exec_args', [])
38 if getattr(self.generator, 'rpath', None):
39 if getattr(self.generator, 'define_ret', False):
40- self.generator.bld.retval = self.generator.bld.cmd_and_log([self.inputs[0].abspath()])
41- else:
42- self.generator.bld.retval = self.generator.bld.exec_command([self.inputs[0].abspath()])
43+ self.generator.bld.retval = self.generator.bld.cmd_and_log([self.inputs[0].abspath()] + args)
44+ else:
45+ self.generator.bld.retval = self.generator.bld.exec_command([self.inputs[0].abspath()] + args)
46 else:
47 env = self.env.env or {}
48 env.update(dict(os.environ))
49 for var in ('LD_LIBRARY_PATH', 'DYLD_LIBRARY_PATH', 'PATH'):
50 env[var] = self.inputs[0].parent.abspath() + os.path.pathsep + env.get(var, '')
51 if getattr(self.generator, 'define_ret', False):
52- self.generator.bld.retval = self.generator.bld.cmd_and_log([self.inputs[0].abspath()], env=env)
53+ self.generator.bld.retval = self.generator.bld.cmd_and_log([self.inputs[0].abspath()] + args, env=env)
54 else:
55- self.generator.bld.retval = self.generator.bld.exec_command([self.inputs[0].abspath()], env=env)
56+ self.generator.bld.retval = self.generator.bld.exec_command([self.inputs[0].abspath()] + args, env=env)
57
58 @feature('test_exec')
59 @after_method('apply_link')
60--
612.7.4
62
diff --git a/meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch b/meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch
index 35890335a..b71192b7d 100644
--- a/meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch
+++ b/meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch
@@ -1,8 +1,17 @@
1From 6c4a634cdf70147f773bb1806692c78bbb95c6f2 Mon Sep 17 00:00:00 2001
2From: Wang Mingyu <wangmy@cn.fujitsu.com>
3Date: Fri, 25 Dec 2020 15:10:58 +0900
4Subject: [PATCH] test
5
6---
7 lib/replace/wscript | 4 +---
8 1 file changed, 1 insertion(+), 3 deletions(-)
9
1diff --git a/lib/replace/wscript b/lib/replace/wscript 10diff --git a/lib/replace/wscript b/lib/replace/wscript
2index 079761d..07e0104 100644 11index e4642e8..163e94d 100644
3--- a/lib/replace/wscript 12--- a/lib/replace/wscript
4+++ b/lib/replace/wscript 13+++ b/lib/replace/wscript
5@@ -793,8 +793,6 @@ def build(bld): 14@@ -945,8 +945,6 @@ def build(bld):
6 if not bld.CONFIG_SET('HAVE_INET_ATON'): REPLACE_SOURCE += ' inet_aton.c' 15 if not bld.CONFIG_SET('HAVE_INET_ATON'): REPLACE_SOURCE += ' inet_aton.c'
7 if not bld.CONFIG_SET('HAVE_INET_NTOP'): REPLACE_SOURCE += ' inet_ntop.c' 16 if not bld.CONFIG_SET('HAVE_INET_NTOP'): REPLACE_SOURCE += ' inet_ntop.c'
8 if not bld.CONFIG_SET('HAVE_INET_PTON'): REPLACE_SOURCE += ' inet_pton.c' 17 if not bld.CONFIG_SET('HAVE_INET_PTON'): REPLACE_SOURCE += ' inet_pton.c'
@@ -11,12 +20,15 @@ index 079761d..07e0104 100644
11 20
12 if not bld.CONFIG_SET('HAVE_CLOSEFROM'): 21 if not bld.CONFIG_SET('HAVE_CLOSEFROM'):
13 REPLACE_SOURCE += ' closefrom.c' 22 REPLACE_SOURCE += ' closefrom.c'
14@@ -808,7 +806,7 @@ def build(bld): 23@@ -960,7 +958,7 @@ def build(bld):
15 # at the moment: 24 # at the moment:
16 # hide_symbols=bld.BUILTIN_LIBRARY('replace'), 25 # hide_symbols=bld.BUILTIN_LIBRARY('replace'),
17 private_library=True, 26 private_library=True,
18- deps='crypt dl nsl socket rt attr' + extra_libs) 27- deps='dl attr' + extra_libs)
19+ deps='crypt dl nsl socket rt ' + extra_libs) 28+ deps='dl' + extra_libs)
20 29
21 replace_test_cflags="-Wno-format-zero-length" 30 replace_test_cflags = ''
22 if bld.CONFIG_SET('HAVE_WNO_FORMAT_TRUNCATION'): 31 if bld.CONFIG_SET('HAVE_WNO_FORMAT_TRUNCATION'):
32--
332.25.1
34
diff --git a/meta-networking/recipes-support/libtevent/libtevent/options-0.10.0.patch b/meta-networking/recipes-support/libtevent/libtevent/options-0.10.0.patch
index 882af0644..42da2468f 100644
--- a/meta-networking/recipes-support/libtevent/libtevent/options-0.10.0.patch
+++ b/meta-networking/recipes-support/libtevent/libtevent/options-0.10.0.patch
@@ -1,6 +1,6 @@
1From b2b19aa9968258b22cf31db0b9dba6bcf96046cf Mon Sep 17 00:00:00 2001 1From c012aa03613e6e74a0598185b222c7b531df1e2d Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com> 2From: Wang Mingyu <wangmy@cn.fujitsu.com>
3Date: Thu, 20 Jun 2019 13:55:44 +0800 3Date: Fri, 25 Dec 2020 15:03:17 +0900
4Subject: [PATCH] Add configure options for packages 4Subject: [PATCH] Add configure options for packages
5 5
6Add configure options for the following packages: 6Add configure options for the following packages:
@@ -22,12 +22,12 @@ Signed-off-by: Joe Slater <joe.slater@windriver.com>
22Update patch to version 0.10.0 22Update patch to version 0.10.0
23Signed-off-by: Changqing Li <changqing.li@windriver.com> 23Signed-off-by: Changqing Li <changqing.li@windriver.com>
24--- 24---
25 lib/replace/wscript | 89 ++++++++++++++++++++++++++++++++++++++++------------- 25 lib/replace/wscript | 87 ++++++++++++++++++++++++++++++++++-----------
26 wscript | 6 ++++ 26 wscript | 6 ++++
27 2 files changed, 74 insertions(+), 21 deletions(-) 27 2 files changed, 73 insertions(+), 20 deletions(-)
28 28
29diff --git a/lib/replace/wscript b/lib/replace/wscript 29diff --git a/lib/replace/wscript b/lib/replace/wscript
30index 1d01e1e..5cf444a 100644 30index a2bc604..e4642e8 100644
31--- a/lib/replace/wscript 31--- a/lib/replace/wscript
32+++ b/lib/replace/wscript 32+++ b/lib/replace/wscript
33@@ -25,6 +25,41 @@ def options(opt): 33@@ -25,6 +25,41 @@ def options(opt):
@@ -81,13 +81,12 @@ index 1d01e1e..5cf444a 100644
81+ conf.CHECK_HEADERS('linux/types.h crypt.h locale.h compat.h') 81+ conf.CHECK_HEADERS('linux/types.h crypt.h locale.h compat.h')
82+ conf.CHECK_HEADERS('compat.h ctype.h dustat.h') 82+ conf.CHECK_HEADERS('compat.h ctype.h dustat.h')
83 conf.CHECK_HEADERS('fcntl.h fnmatch.h glob.h history.h krb5.h langinfo.h') 83 conf.CHECK_HEADERS('fcntl.h fnmatch.h glob.h history.h krb5.h langinfo.h')
84- conf.CHECK_HEADERS('libaio.h locale.h ndir.h pwd.h') 84 conf.CHECK_HEADERS('locale.h ndir.h pwd.h')
85- conf.CHECK_HEADERS('shadow.h sys/acl.h') 85- conf.CHECK_HEADERS('shadow.h sys/acl.h')
86- conf.CHECK_HEADERS('sys/attributes.h attr/attributes.h sys/capability.h sys/dir.h sys/epoll.h') 86- conf.CHECK_HEADERS('sys/attributes.h attr/attributes.h sys/capability.h sys/dir.h sys/epoll.h')
87+ conf.CHECK_HEADERS('locale.h ndir.h pwd.h')
88+ conf.CHECK_HEADERS('shadow.h') 87+ conf.CHECK_HEADERS('shadow.h')
89+ conf.CHECK_HEADERS('sys/attributes.h sys/dir.h sys/epoll.h') 88+ conf.CHECK_HEADERS('sys/attributes.h sys/dir.h sys/epoll.h')
90+ 89+
91+ if Options.options.enable_acl: 90+ if Options.options.enable_acl:
92+ conf.CHECK_HEADERS('acl/libacl.h sys/acl.h') 91+ conf.CHECK_HEADERS('acl/libacl.h sys/acl.h')
93+ 92+
@@ -103,7 +102,7 @@ index 1d01e1e..5cf444a 100644
103 conf.CHECK_HEADERS('port.h') 102 conf.CHECK_HEADERS('port.h')
104 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h') 103 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h')
105 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h') 104 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h')
106@@ -110,8 +158,9 @@ def configure(conf): 105@@ -121,8 +169,9 @@ def configure(conf):
107 conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h') 106 conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h')
108 conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h') 107 conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h')
109 108
@@ -115,7 +114,7 @@ index 1d01e1e..5cf444a 100644
115 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') 114 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
116 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') 115 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
117 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') 116 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
118@@ -380,20 +429,18 @@ def configure(conf): 117@@ -418,20 +467,18 @@ def configure(conf):
119 118
120 strlcpy_in_bsd = False 119 strlcpy_in_bsd = False
121 120
@@ -149,7 +148,7 @@ index 1d01e1e..5cf444a 100644
149 conf.CHECK_CODE(''' 148 conf.CHECK_CODE('''
150 struct ucred cred; 149 struct ucred cred;
151diff --git a/wscript b/wscript 150diff --git a/wscript b/wscript
152index ded182a..824a6dd 100644 151index 93af416..a0898b1 100644
153--- a/wscript 152--- a/wscript
154+++ b/wscript 153+++ b/wscript
155@@ -25,6 +25,12 @@ def options(opt): 154@@ -25,6 +25,12 @@ def options(opt):
@@ -166,5 +165,5 @@ index ded182a..824a6dd 100644
166 def configure(conf): 165 def configure(conf):
167 conf.RECURSE('lib/replace') 166 conf.RECURSE('lib/replace')
168-- 167--
1692.7.4 1682.25.1
170 169
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.10.1.bb b/meta-networking/recipes-support/libtevent/libtevent_0.10.2.bb
index f1b170daf..21f83ad35 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.10.1.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.10.2.bb
@@ -9,12 +9,11 @@ RDEPENDS_python3-tevent = "python3"
9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \ 9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
10 file://options-0.10.0.patch \ 10 file://options-0.10.0.patch \
11 file://0001-libtevent-fix-musl-libc-compile-error.patch \ 11 file://0001-libtevent-fix-musl-libc-compile-error.patch \
12 file://0001-waf-add-support-of-cross_compile.patch \
13" 12"
14LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a" 13LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
15 14
16SRC_URI[md5sum] = "1060eb69d6994a847eecb73c4d391ced" 15SRC_URI[md5sum] = "105c7a4dbb96f1751eb27dfd05e7fa84"
17SRC_URI[sha256sum] = "79a4da68b38b86ac71d8ac824ee3605ab22a6a91cfa83033a7db73f3dd6910b6" 16SRC_URI[sha256sum] = "f8427822e5b2878fb8b28d6f50d96848734f3f3130612fb574fdd2d2148a6696"
18 17
19inherit waf-samba 18inherit waf-samba
20 19