summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorMorgan Little <morgan.little@windriver.com>2012-10-23 18:04:50 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-10-25 12:16:20 -0400
commit79811942660877cedf366c542d2ee4025bf54b77 (patch)
tree4d8125b0d7d63d952869ba74785ca3cd0ee81cc7 /meta-networking/recipes-support
parentd102fc3fe64844f5c85ff350874728139a63fe78 (diff)
downloadmeta-openembedded-79811942660877cedf366c542d2ee4025bf54b77.tar.gz
traceroute: Add from OE-Classic, uprev and update
Uprev traceroute from 2.0.12 in OE-Classic to 2.0.18. Update SUMMERY, DESCRIPTION, LICENSE, LIC_FILES_CHKSUM, update do_install to be similar Fedora rpm spec files, and update update alternatives to use the update alteratives class. Signed-off-by: Morgan Little <morgan.little@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb b/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb
new file mode 100644
index 000000000..719d9fb9c
--- /dev/null
+++ b/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb
@@ -0,0 +1,43 @@
1SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
2DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
3their way to a specified network (or Internet) host. Traceroute displays \
4the IP number and host name (if possible) of the machines along the \
5route taken by the packets. Traceroute is used as a network debugging \
6tool. If you're having network connectivity problems, traceroute will \
7show you where the trouble is coming from along the route."
8SECTION = "console/network"
9HOMEPAGE = "http://traceroute.sourceforge.net/"
10LICENSE = "GPL-2.0 LGPL-2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
12 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff"
13
14inherit update-alternatives
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/traceroute-2.0.18/traceroute-2.0.18.tar.gz \
17 "
18
19SRC_URI[md5sum] = "b7254149b7f081cce07f4b9e065ba5ef"
20SRC_URI[sha256sum] = "5994a88520927fefe3c9754aaf1e02b4d0f3f8fb1f521a68fa86215c3fcab9ef"
21
22do_compile() {
23 export LDFLAGS="${TARGET_LDFLAGS} -L${S}/libsupp"
24 oe_runmake "env=yes"
25}
26
27do_install() {
28 install -d ${D}${bindir}
29 install -m755 ${PN}/${PN} ${D}${bindir}
30
31 install -m755 wrappers/tcptraceroute ${D}${bindir}
32
33 install -d ${D}${mandir}
34 install -p -m644 ${PN}/${PN}.8 ${D}${mandir}
35 pushd ${D}${mandir}
36 ln -s ${PN}.8 ${PN}6.8
37 ln -s ${PN}.8 tcptraceroute.8
38 popd
39
40}
41
42ALTERNATIVE_${PN} = "traceroute6"
43ALTERNATIVE_LINK_NAME[traceroute6] = "${bindir}/traceroute"