summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2014-07-20 13:21:25 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-01 14:23:44 +0200
commit9bfdcec4087ab5fd19dc054f2084c83c5883d010 (patch)
tree6661b2fe5cf8cae2bacd64e77829f642c062ea30 /meta-networking/recipes-support/wireshark
parentd22f4ca2e3e421615b601002061690a8f97257c0 (diff)
downloadmeta-openembedded-9bfdcec4087ab5fd19dc054f2084c83c5883d010.tar.gz
wireshark: Add recipe 1.12.0-rc2
* Inital wireshark support on gtk+, gtk3 * README with additional info Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark')
-rw-r--r--meta-networking/recipes-support/wireshark/README37
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb41
2 files changed, 78 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/README b/meta-networking/recipes-support/wireshark/README
new file mode 100644
index 000000000..0e0c52656
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/README
@@ -0,0 +1,37 @@
1#
2Wireshark - Notes
3
4URL: http://www.wireshark.org/
5User Guide: http://www.wireshark.org/docs/wsug_html_chunked/
6Secruity advisories: http://www.wireshark.org/security/
7
8Wireshark is slowly moving away from gtk and towards QT as their graphical stack.
9Currently gtk is supported with this release and I plan on integrating QT.
10
11
12
13Adding the wireshark to your build
14========================================
15
16via local.conf
17IMAGE_INSTALL_append = " wireshark"
18
19Adding the wireshark to your graphical build
20========================================
21via local.conf
22EXTRA_IMAGE_FEATURES += "x11-base"
23
24or use the "core-image-x11"
25
26
27Maintenance
28-----------
29
30Send patches, comments or questions to openembedded-devel@lists.openembedded.org
31
32When sending single patches, please using something like:
33'git send-email -1 --to openembedded-devel@lists.openembedded.org --cc akuster@mvista.com --subject-prefix=meta-security][PATCH'
34
35Maintainer: Armin Kuster <akuster@mvista.com>
36
37
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb
new file mode 100644
index 000000000..554223124
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "network"
4LICENSE = "GPL-2.0"
5
6DEPENDS = "perl-native libpcap pcre expat glib-2.0 libsmi"
7
8inherit autotools
9
10ARM_INSTRUCTION_SET = "arm"
11
12# Works with either gtk+ or gtk3.
13WHICH_GTK = "gtk3"
14
15PACKAGECONFIG ??= "gnutls gcrypt"
16PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
17PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
18
19PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+"
20PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3"
21PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark,"
22PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
23PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
24PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
25
26EXTRA_OECONF = "--with-qt=no --enable-usr-local=no -enable-tshark"
27
28LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
29SRC_URI = "http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-1.12.0-rc2.tar.bz2 "
30
31SRC_URI[md5sum] = "dc1149073066a29f91116c168558262e"
32SRC_URI[sha256sum]= "31009bb450126e9b12808267419f31016d14e6fde7b5e39c85ad37459908cffb"
33
34do_configure_prepend() {
35 # force to use fallback
36 sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags
37}
38
39ALLOW_EMPTY_${PN} = "1"
40INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
41