summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-networking/recipes-support/wireshark
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark')
-rw-r--r--meta-networking/recipes-support/wireshark/README45
-rw-r--r--meta-networking/recipes-support/wireshark/files/Do-not-set-CC_FOR_BUILD-flags.patch46
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb57
3 files changed, 148 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/README b/meta-networking/recipes-support/wireshark/README
new file mode 100644
index 000000000..63b5b7263
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/README
@@ -0,0 +1,45 @@
1#
2Wireshark - Notes
3
4URL: http://www.wireshark.org/
5User Guide: http://www.wireshark.org/docs/wsug_html_chunked/
6Secruity advisories: http://www.wireshark.org/security/
7
8Wireshark is slowly moving away from gtk and towards QT as their graphical stack.
9Currently gtk is supported with this release and I plan on integrating QT.
10
11
12
13Adding the wireshark to your build
14========================================
15
16via local.conf
17IMAGE_INSTALL_append = " wireshark"
18
19Adding the wireshark to your graphical build
20========================================
21via local.conf
22IMAGE_INSTALL_append = " wireshark"
23
24and one of:
25
26EXTRA_IMAGE_FEATURES += "x11-base"
27
28or use the "core-image-x11"
29
30
31Maintenance
32-----------
33
34Send patches, comments or questions to openembedded-devel@lists.openembedded.org
35
36When sending single patches, please use something like:
37
38 git send-email -1 -M \
39 --to openembedded-devel@lists.openembedded.org \
40 --cc akuster@mvista.com \
41 --subject-prefix=meta-networking][PATCH
42
43Maintainer: Armin Kuster <akuster@mvista.com>
44
45
diff --git a/meta-networking/recipes-support/wireshark/files/Do-not-set-CC_FOR_BUILD-flags.patch b/meta-networking/recipes-support/wireshark/files/Do-not-set-CC_FOR_BUILD-flags.patch
new file mode 100644
index 000000000..64a08add7
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/files/Do-not-set-CC_FOR_BUILD-flags.patch
@@ -0,0 +1,46 @@
1[PATCH] Do not set CC_FOR_BUILD flags
2
3Upstream-status: Pending
4
5AC_WIRESHARK_COMPILER_FLAGS_CHECK() is checking which options CC is supported,
6and put the supported options into CFLAGS, but it should not put them into
7CFLAGS_FOR_BUILD. since CC and BUILD_CC can be different, CFLAGS_FOR_BUILD is
8used by BUILD_CC
9
10BUILD_CC is used to generated host tools, do not use the gcc's optimised options,
11do not effect the running of host tools. so do not set CC_FOR_BUILD flags.
12
13Signed-off-by: Roy.Li <rongqing.li@windriver.com>
14---
15 acinclude.m4 | 8 --------
16 1 file changed, 8 deletions(-)
17
18diff --git a/acinclude.m4 b/acinclude.m4
19index 136fc27..8d3d360 100644
20--- a/acinclude.m4
21+++ b/acinclude.m4
22@@ -1755,10 +1755,6 @@ if test "x$ac_supports_gcc_flags" = "xyes" ; then
23 # just the new option.
24 #
25 CFLAGS="$CFLAGS_saved $GCC_OPTION"
26- #
27- # Add it to the flags we use when building build tools.
28- #
29- CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD $GCC_OPTION"
30 ],
31 [
32 AC_MSG_RESULT(yes)
33@@ -1771,10 +1767,6 @@ if test "x$ac_supports_gcc_flags" = "xyes" ; then
34 # just the new option.
35 #
36 CFLAGS="$CFLAGS_saved $GCC_OPTION"
37- #
38- # Add it to the flags we use when building build tools.
39- #
40- CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD $GCC_OPTION"
41 fi
42 ],
43 [
44--
451.9.1
46
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb
new file mode 100644
index 000000000..683321657
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb
@@ -0,0 +1,57 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "network"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
6
7DEPENDS = "perl-native pcre expat glib-2.0 sbc"
8
9SRC_URI = " \
10 http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \
11 file://Do-not-set-CC_FOR_BUILD-flags.patch \
12"
13
14PE = "1"
15
16SRC_URI[md5sum] = "acfa156fd35cb66c867b1ace992e4b5b"
17SRC_URI[sha256sum] = "de804e98e252e4b795d28d6ac2d48d7f5aacd9b046ee44d44266983795ebc312"
18
19inherit autotools pkgconfig
20
21ARM_INSTRUCTION_SET = "arm"
22
23# Works with either gtk+ or gtk3.
24WHICH_GTK = "gtk3"
25
26PACKAGECONFIG ??= "libcap gnutls libnl"
27PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
28PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
29
30PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_DIR_HOST}, --with-libcap=no, libcap"
31PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
32PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
33PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
34PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+"
35PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3"
36PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark,"
37PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
38PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
39PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
40PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
41PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
42PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
43PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
44
45# these next two options require addional layers
46PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns"
47PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
48
49EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --with-pcap=no --enable-pcap-ng-default"
50
51do_configure_prepend() {
52 # force to use fallback
53 sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags
54}
55
56ALLOW_EMPTY_${PN} = "1"
57INHIBIT_PACKAGE_DEBUG_SPLIT = "1"