summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_2.2.8.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-09-01 06:56:34 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-09-12 10:55:07 -0400
commitc6928f15d93a1546c47116b3244893b9f813e6e1 (patch)
treed1833d5e731c682f399e51bbc0a0f0e8c2c511e0 /meta-networking/recipes-support/wireshark/wireshark_2.2.8.bb
parent80f9a603c4c1b5edfbb54617bbfaffcac34b3264 (diff)
downloadmeta-openembedded-c6928f15d93a1546c47116b3244893b9f813e6e1.tar.gz
wireshark: update to 2.2.9
Change LIC_FILES_CHKSUM from README.linux to COPYING as COPYING contains the license info 2.2.9 security fixes: wnpa-sec-2017-38 MSDP dissector infinite loop (Bug 13933) CVE-2017-13767 wnpa-sec-2017-39 Profinet I/O buffer overrun (Bug 13847) CVE-2017-13766 wnpa-sec-2017-41 IrCOMM dissector buffer overrun (Bug 13929) CVE-2017-13765 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_2.2.8.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.2.8.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.2.8.bb b/meta-networking/recipes-support/wireshark/wireshark_2.2.8.bb
deleted file mode 100644
index f94324e27..000000000
--- a/meta-networking/recipes-support/wireshark/wireshark_2.2.8.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "net"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
6
7DEPENDS = "pcre expat glib-2.0 glib-2.0-native"
8
9SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2"
10
11PE = "1"
12
13SRC_URI[md5sum] = "bb81d0ecf3a8ed46bedfaeae6fd318a8"
14SRC_URI[sha256sum] = "ecf02c148c9ab6e809026ad5743fe9be1739a9840ef6fece6837a7ddfbdf7edc"
15
16inherit autotools pkgconfig perlnative
17
18ARM_INSTRUCTION_SET = "arm"
19
20PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
21PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
22#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
23
24PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
25PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
26PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
27PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
28PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
29PACKAGECONFIG[gtk2] = "--with-gtk=2, , gtk+"
30PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3"
31PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark,"
32PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
33PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
34PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
35PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
36PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
37PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
38PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
39PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
40PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc"
41
42PACKAGECONFIG[libssh] = "--with-ssh=yes, --with-ssh=no, libssh2"
43
44
45# these next two options require addional layers
46PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
47
48EXTRA_OECONF += "--with-qt=no --enable-tshark --enable-rawshark"
49
50# Currently wireshark does not install header files
51do_install_append () {
52
53 install -d ${D}/${includedir}/${BPN}
54 install -d ${D}/${includedir}/${BPN}/epan
55 install -d ${D}/${includedir}/${BPN}/epan/crypt
56 install -d ${D}/${includedir}/${BPN}/epan/dfilter
57 install -d ${D}/${includedir}/${BPN}/epan/dissectors
58 install -d ${D}/${includedir}/${BPN}/epan/ftypes
59 install -d ${D}/${includedir}/${BPN}/epan/wmem
60
61 install config.h ${D}/${includedir}/${BPN}
62 install ${S}/register.h ${D}/${includedir}/${BPN}
63 install -D ${S}/epan/*.h ${D}/${includedir}/${BPN}/epan
64 install -D ${S}/epan/crypt/*.h ${D}/${includedir}/${BPN}/epan/crypt
65 install -D ${S}/epan/dfilter/*.h ${D}/${includedir}/${BPN}/epan/dfilter
66 install -D ${S}/epan/dissectors/*.h ${D}/${includedir}/${BPN}/epan/dissectors
67 install -D ${S}/epan/ftypes/*.h ${D}/${includedir}/${BPN}/epan/ftypes
68 install -D ${S}/epan/wmem/*.h ${D}/${includedir}/${BPN}/epan/wmem
69}
70
71FILES_${PN} += "${datadir}*"