summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_2.2.3.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-01-24 06:52:43 -0800
committerJoe MacDonald <joe_macdonald@mentor.com>2017-02-22 08:31:58 -0500
commit085d2d487bf2a648dd749670a6b48f859e789e44 (patch)
tree1e5ac847e691a8d25ae0cc15245fd39e652450f2 /meta-networking/recipes-support/wireshark/wireshark_2.2.3.bb
parent0994337c9f263608ff4fd3d22a6eba3e0284ad8d (diff)
downloadmeta-openembedded-085d2d487bf2a648dd749670a6b48f859e789e44.tar.gz
wireshark: update package to 2.2.4
The following vulnerabilities have been fixed: * [1]wnpa-sec-2017-01 The ASTERIX dissector could go into an infinite loop. ([2]Bug 13344) * [3]wnpa-sec-2017-02 The DHCPv6 dissector could go into a large loop. ([4]Bug 13345) see: https://www.wireshark.org/docs/relnotes/wireshark-2.2.4.html Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_2.2.3.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.2.3.bb72
1 files changed, 0 insertions, 72 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.2.3.bb b/meta-networking/recipes-support/wireshark/wireshark_2.2.3.bb
deleted file mode 100644
index 21aad3bd1..000000000
--- a/meta-networking/recipes-support/wireshark/wireshark_2.2.3.bb
+++ /dev/null
@@ -1,72 +0,0 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "net"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
6
7DEPENDS = "pcre expat glib-2.0"
8
9SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2"
10
11PE = "1"
12SRC_URI[md5sum] = "68e201e06873c67cb7544d27991e79bf"
13SRC_URI[sha256sum] = "97bac89e88892054a5848a9f7e0c36aa399a2008900829b078e29cab0ddd593b"
14
15inherit autotools pkgconfig perlnative
16
17ARM_INSTRUCTION_SET = "arm"
18
19PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
20PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
21#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
22
23PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
24PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
25PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
26PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
27PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
28PACKAGECONFIG[gtk2] = "--with-gtk=2, , gtk+"
29PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3"
30PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark,"
31PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
32PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
33PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
34PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
35PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
36PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
37PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
38PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
39PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc"
40
41PACKAGECONFIG[libssh] = "--with-ssh=yes, --with-ssh=no, libssh2"
42
43
44# these next two options require addional layers
45PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
46
47EXTRA_OECONF += "--with-qt=no --enable-tshark --enable-rawshark"
48
49# Currently wireshark does not install header files
50do_install_append () {
51
52 install -d ${D}/${includedir}/${BPN}
53 install -d ${D}/${includedir}/${BPN}/epan
54 install -d ${D}/${includedir}/${BPN}/epan/crypt
55 install -d ${D}/${includedir}/${BPN}/epan/dfilter
56 install -d ${D}/${includedir}/${BPN}/epan/dissectors
57 install -d ${D}/${includedir}/${BPN}/epan/ftypes
58 install -d ${D}/${includedir}/${BPN}/epan/wmem
59
60 install config.h ${D}/${includedir}/${BPN}
61 install ${S}/register.h ${D}/${includedir}/${BPN}
62 install -D ${S}/epan/*.h ${D}/${includedir}/${BPN}/epan
63 install -D ${S}/epan/crypt/*.h ${D}/${includedir}/${BPN}/epan/crypt
64 install -D ${S}/epan/dfilter/*.h ${D}/${includedir}/${BPN}/epan/dfilter
65 install -D ${S}/epan/dissectors/*.h ${D}/${includedir}/${BPN}/epan/dissectors
66 install -D ${S}/epan/ftypes/*.h ${D}/${includedir}/${BPN}/epan/ftypes
67 install -D ${S}/epan/wmem/*.h ${D}/${includedir}/${BPN}/epan/wmem
68}
69
70FILES_${PN} += "${datadir}*"
71
72PNBLACKLIST[wireshark] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130671/"