diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2014-01-20 20:52:35 +0800 |
---|---|---|
committer | Joe MacDonald <joe.macdonald@windriver.com> | 2014-03-27 15:41:13 -0400 |
commit | d9f21ab787c8eef2cfdc1f5408f973ebbcc196e2 (patch) | |
tree | 219b4c234dea68768c5994773310a9b574b7a03b /meta-networking/recipes-support/traceroute | |
parent | 61d573ad7c9d3969db5ea3799308e5b1633bb60e (diff) | |
download | meta-openembedded-d9f21ab787c8eef2cfdc1f5408f973ebbcc196e2.tar.gz |
traceroute: filter-out patches dir
The $(subdirs) contains all the dirs under the ${B}, and this one:
do_unpack[cleandirs] = "${S}/patches"
will create a "patches" dir, then there will be compile errors, filter
out the patches will fix the problem.
Note: poky doesn't have this problem since it separates the ${S} and
${B}
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/traceroute')
-rw-r--r-- | meta-networking/recipes-support/traceroute/traceroute/filter-out-the-patches-from-subdirs.patch | 47 | ||||
-rw-r--r-- | meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb | 1 |
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/traceroute/traceroute/filter-out-the-patches-from-subdirs.patch b/meta-networking/recipes-support/traceroute/traceroute/filter-out-the-patches-from-subdirs.patch new file mode 100644 index 000000000..2c030b55d --- /dev/null +++ b/meta-networking/recipes-support/traceroute/traceroute/filter-out-the-patches-from-subdirs.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | From e273e0ebc753645555909bcc4874c72458b17891 Mon Sep 17 00:00:00 2001 | ||
2 | From: Robert Yang <liezhi.yang@windriver.com> | ||
3 | Date: Fri, 17 Jan 2014 03:17:44 -0500 | ||
4 | Subject: [PATCH] Make.rules: filter-out the patches from subdirs | ||
5 | |||
6 | The $(subdirs) contains all the dirs under the ${B}, and this one: | ||
7 | |||
8 | do_unpack[cleandirs] = "${S}/patches" | ||
9 | |||
10 | will create a "patches" dir, then there will be compile errors, filter | ||
11 | out the patches will fix the problem. | ||
12 | |||
13 | Note: poky doesn't have this problem since it separates the ${S} and | ||
14 | ${B} | ||
15 | |||
16 | Upstream-Status: Inappropriate [OE specific] | ||
17 | |||
18 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
19 | --- | ||
20 | Make.rules | 4 ++-- | ||
21 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
22 | |||
23 | diff --git a/Make.rules b/Make.rules | ||
24 | index b077cd5..0bfce2d 100644 | ||
25 | --- a/Make.rules | ||
26 | +++ b/Make.rules | ||
27 | @@ -97,7 +97,7 @@ endif | ||
28 | subdirs := $(filter-out $(SKIPDIRS), $(subdirs)) | ||
29 | endif | ||
30 | |||
31 | -install install-%: subdirs := $(filter-out $(SKIPINSTALL), $(subdirs)) | ||
32 | +install install-%: subdirs := $(filter-out $(SKIPINSTALL) patches, $(subdirs)) | ||
33 | |||
34 | |||
35 | override MAKE += srcdir=$(srcdir) subdirs="$(subdirs)" shared=$(shared) | ||
36 | @@ -106,7 +106,7 @@ override MAKE += srcdir=$(srcdir) subdirs="$(subdirs)" shared=$(shared) | ||
37 | INCLUDEDIRS := $(filter $(INCLUDEDIRS), $(subdirs)) | ||
38 | LIBDIRS := $(filter $(LIBDIRS), $(subdirs)) | ||
39 | MODDIRS := $(filter $(MODDIRS), $(subdirs)) | ||
40 | -EXEDIRS := $(filter-out $(INCLUDEDIRS) $(LIBDIRS) $(MODDIRS), $(subdirs)) | ||
41 | +EXEDIRS := $(filter-out $(INCLUDEDIRS) $(LIBDIRS) $(MODDIRS) patches, $(subdirs)) | ||
42 | MODUSERS := $(filter $(MODUSERS), $(subdirs)) | ||
43 | SBINUSERS := $(filter $(SBINUSERS), $(subdirs)) | ||
44 | |||
45 | -- | ||
46 | 1.7.10.4 | ||
47 | |||
diff --git a/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb b/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb index 83ac5a742..236bd12c3 100644 --- a/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb +++ b/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb | |||
@@ -16,6 +16,7 @@ PR = "r1" | |||
16 | inherit update-alternatives | 16 | inherit update-alternatives |
17 | 17 | ||
18 | SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/traceroute-2.0.18/traceroute-2.0.18.tar.gz \ | 18 | SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/traceroute-2.0.18/traceroute-2.0.18.tar.gz \ |
19 | file://filter-out-the-patches-from-subdirs.patch \ | ||
19 | " | 20 | " |
20 | 21 | ||
21 | SRC_URI[md5sum] = "b7254149b7f081cce07f4b9e065ba5ef" | 22 | SRC_URI[md5sum] = "b7254149b7f081cce07f4b9e065ba5ef" |