summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ssmping
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-11-07 16:08:08 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2014-11-10 15:12:05 -0500
commit4b6970c24c3fb0926fd700678c0e11de43a5bf92 (patch)
treef60d39f6d9605b279f83c1792d9e8acce46a7bae /meta-networking/recipes-support/ssmping
parentc5398fc0fe246e4828c9e950f779f437266bfaa1 (diff)
downloadmeta-openembedded-4b6970c24c3fb0926fd700678c0e11de43a5bf92.tar.gz
ssmping: add do_install to ssmping
The previous do_install is empty and do nothing. Tweak install doc dir, so the man doc could be installed to /usr/share/man rather than /usr/locale/man. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/ssmping')
-rw-r--r--meta-networking/recipes-support/ssmping/files/0001-Makefile-tweak-install-dir.patch35
-rw-r--r--meta-networking/recipes-support/ssmping/ssmping_0.9.1.bb8
2 files changed, 42 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ssmping/files/0001-Makefile-tweak-install-dir.patch b/meta-networking/recipes-support/ssmping/files/0001-Makefile-tweak-install-dir.patch
new file mode 100644
index 000000000..0cb981cf7
--- /dev/null
+++ b/meta-networking/recipes-support/ssmping/files/0001-Makefile-tweak-install-dir.patch
@@ -0,0 +1,35 @@
1From 693cfce5431e191a3955fd56fa822927d92c9e43 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 7 Nov 2014 14:27:00 +0800
4Subject: [PATCH] Makefile: tweak install dir
5
6For oe-core, the man doc should be installed to /usr/share/man
7rather than /usr/locale/man.
8
9Upstream-Status: inappropriate (oe specific)
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 Makefile | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/Makefile b/Makefile
17index b5d12f8..9b2663c 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -14,9 +14,9 @@ install: ssmping asmping ssmpingd mcfirst
21 install -D asmping $(DESTDIR)$(PREFIX)/bin/asmping
22 install -D ssmpingd $(DESTDIR)$(PREFIX)/bin/ssmpingd
23 install -D mcfirst $(DESTDIR)$(PREFIX)/bin/mcfirst
24- install -D ssmping.1 $(DESTDIR)$(PREFIX)/man/man1/ssmping.1
25- install -D asmping.1 $(DESTDIR)$(PREFIX)/man/man1/asmping.1
26- install -D mcfirst.1 $(DESTDIR)$(PREFIX)/man/man1/mcfirst.1
27+ install -D ssmping.1 $(DESTDIR)$(PREFIX)/share/man/man1/ssmping.1
28+ install -D asmping.1 $(DESTDIR)$(PREFIX)/share/man/man1/asmping.1
29+ install -D mcfirst.1 $(DESTDIR)$(PREFIX)/share/man/man1/mcfirst.1
30
31 clean:
32 rm -f $(OBJ) joinch.o joingrp.o ssmping asmping ssmpingd mcfirst
33--
341.9.1
35
diff --git a/meta-networking/recipes-support/ssmping/ssmping_0.9.1.bb b/meta-networking/recipes-support/ssmping/ssmping_0.9.1.bb
index 06d6d28fa..0eaa7ca4c 100644
--- a/meta-networking/recipes-support/ssmping/ssmping_0.9.1.bb
+++ b/meta-networking/recipes-support/ssmping/ssmping_0.9.1.bb
@@ -3,8 +3,14 @@ HOMEPAGE = "http://www.venaas.no/multicast/ssmping/"
3LICENSE = "ISC" 3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://asmping.c;beginline=2;endline=11;md5=1ca8d1a1ca931e5cfe604ebf20a78b71" 4LIC_FILES_CHKSUM = "file://asmping.c;beginline=2;endline=11;md5=1ca8d1a1ca931e5cfe604ebf20a78b71"
5 5
6SRC_URI = "http://www.venaas.no/multicast/ssmping/${BP}.tar.gz" 6SRC_URI = "http://www.venaas.no/multicast/ssmping/${BP}.tar.gz \
7 file://0001-Makefile-tweak-install-dir.patch \
8"
7SRC_URI[md5sum] = "ad8e3d13f6d72918f73be7e7975d7fad" 9SRC_URI[md5sum] = "ad8e3d13f6d72918f73be7e7975d7fad"
8SRC_URI[sha256sum] = "22103a37eaa28489169a0927bc01e0596c3485fc4d29fc8456c07fd2c70fca6d" 10SRC_URI[sha256sum] = "22103a37eaa28489169a0927bc01e0596c3485fc4d29fc8456c07fd2c70fca6d"
9 11
10CFLAGS += "-D_GNU_SOURCE " 12CFLAGS += "-D_GNU_SOURCE "
13
14do_install() {
15 oe_runmake 'DESTDIR=${D}' 'PREFIX=${prefix}' install
16}