summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/open-isns
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2016-12-05 13:53:23 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2016-12-14 09:20:10 -0500
commit3c55a185cea09612e12afd5924fb95fee223108d (patch)
tree54a61500fbfe95bc71623fe88bd786a743741a95 /meta-networking/recipes-support/open-isns
parent6d700823b526d7545ac880574df0aa33bfc30d70 (diff)
downloadmeta-openembedded-3c55a185cea09612e12afd5924fb95fee223108d.tar.gz
iscsi-initiator-utils: Update to 2.0.874
The latest iscsi-initiator-utils has been available for a while now, update our recipe. The new version no longer bundles its own ISNS server, so this update brings in open-isns as a dependency. As open-isns depends on systemd, add systemd to REQUIRED_DISTRO_FEATURES Additionally, open-iscsi.org is defunct, the new home is at open-iscsi.com, update the SRC_URI and homepage accordingly. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/open-isns')
-rw-r--r--meta-networking/recipes-support/open-isns/open-isns_0.97.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/open-isns/open-isns_0.97.bb b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
new file mode 100644
index 000000000..828d1166d
--- /dev/null
+++ b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2016 Joe MacDonald <joe_macdonald@mentor.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "iSNS daemon and utility programs"
5DESCRIPTION = "This is a partial implementation of RFC4171, the Internet \
6Storage Name Service (iSNS). The distribution includes the iSNS server, \
7supporting persisten storage of registrations, isnsadm, a command line \
8utility for managing nodes, and isnsdd, a corresponding discovery daemon."
9HOMEPAGE = "http://github.com/gonzoleeman/open-isns/"
10LICENSE = "GPLv2+ & LGPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
12SECTION = "net"
13
14DEPENDS = "openssl systemd"
15
16SRC_URI = " \
17 git://github.com/open-iscsi/open-isns \
18"
19
20SRCREV ?= "09954404e948e41eb0fce8e28836018b4ce3d20d"
21
22S = "${WORKDIR}/git"
23
24inherit systemd autotools-brokensep distro_features_check
25# depends on systemd
26REQUIRED_DISTRO_FEATURES = "systemd"
27
28EXTRA_OECONF = " --prefix=${prefix} --enable-shared"
29
30do_install_append () {
31 oe_runmake INCDIR=${D}${includedir}/libisns/ install_hdrs
32 oe_runmake LIBDIR=${D}${libdir} install_lib
33}
34
35FILES_${PN} += "${libdir}"