summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nuttcp/nuttcp_8.2.2.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-04-24 23:52:59 +0200
committerKhem Raj <raj.khem@gmail.com>2019-04-29 10:13:56 -0700
commit3e870cf1101192b0c87c70d79ab7eaa2298131f6 (patch)
treee35bf64214dd4a42de68fa3d58474268c5040fb2 /meta-networking/recipes-support/nuttcp/nuttcp_8.2.2.bb
parent1cb19a31ba1e780cb3cfb3a37150d77281688c78 (diff)
downloadmeta-openembedded-3e870cf1101192b0c87c70d79ab7eaa2298131f6.tar.gz
nuttcp: update to 8.2.2
License checksum was changed due to updated copyright years. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/nuttcp/nuttcp_8.2.2.bb')
-rw-r--r--meta-networking/recipes-support/nuttcp/nuttcp_8.2.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nuttcp/nuttcp_8.2.2.bb b/meta-networking/recipes-support/nuttcp/nuttcp_8.2.2.bb
new file mode 100644
index 000000000..2fd563123
--- /dev/null
+++ b/meta-networking/recipes-support/nuttcp/nuttcp_8.2.2.bb
@@ -0,0 +1,28 @@
1SUMMARY = "network performance measurement tool"
2DESCRIPTION = "nuttcp is a network performance measurement tool intended for use by network \
3and system managers. Its most basic usage is to determine the raw TCP (or UDP) \
4network layer throughput by transferring memory buffers from a source system \
5across an interconnecting network to a destination system, either transferring \
6data for a specified time interval, or alternatively transferring a specified \
7number of bytes."
8HOMEPAGE = "http://www.nuttcp.net/Welcome%20Page.html"
9LICENSE = "GPL-2.0"
10SECTION = "net"
11LIC_FILES_CHKSUM = "file://${BP}.c;beginline=4;endline=30;md5=496a7c0bb83c07ff528d226bf85e05c5"
12
13UPSTREAM_CHECK_URI = "https://www.nuttcp.net/nuttcp/beta/"
14
15SRC_URI = "http://nuttcp.net/${BPN}/beta/${BP}.c"
16SRC_URI[md5sum] = "d3c92c4d2f261221193c3726c1b9a42f"
17SRC_URI[sha256sum] = "8c5595bcd27c2fd66831be74c390df078cfb1870aa427f2511ac2586d236c8a1"
18
19S = "${WORKDIR}"
20
21do_compile () {
22 ${CC} ${CFLAGS} ${LDFLAGS} -o nuttcp nuttcp-${PV}.c
23}
24
25do_install () {
26 install -d ${D}${bindir}
27 install -m 0755 nuttcp ${D}${bindir}
28}