summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nuttcp/nuttcp_7.2.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-networking/recipes-support/nuttcp/nuttcp_7.2.1.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-networking/recipes-support/nuttcp/nuttcp_7.2.1.bb')
-rw-r--r--meta-networking/recipes-support/nuttcp/nuttcp_7.2.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nuttcp/nuttcp_7.2.1.bb b/meta-networking/recipes-support/nuttcp/nuttcp_7.2.1.bb
new file mode 100644
index 000000000..b931d0470
--- /dev/null
+++ b/meta-networking/recipes-support/nuttcp/nuttcp_7.2.1.bb
@@ -0,0 +1,29 @@
1# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "network performance measurement tool"
5DESCRIPTION = "nuttcp is a network performance measurement tool intended for use by network \
6and system managers. Its most basic usage is to determine the raw TCP (or UDP) \
7network layer throughput by transferring memory buffers from a source system \
8across an interconnecting network to a destination system, either transferring \
9data for a specified time interval, or alternatively transferring a specified \
10number of bytes."
11HOMEPAGE = "http://www.nuttcp.net/nuttcp/Welcome%20Page.html"
12LICENSE = "GPL-2.0"
13SECTION = "net"
14LIC_FILES_CHKSUM = "file://nuttcp-${PV}.c;beginline=4;endline=30;md5=ae7045c3c3616092e07d87f04ba0d960"
15
16SRC_URI = "http://lcp.nrl.navy.mil/nuttcp/beta/nuttcp-${PV}.c"
17SRC_URI[md5sum] = "1ebf4a08bad2a295a8155f02995e8754"
18SRC_URI[sha256sum] = "c6e33810ccce67260f8d5d627f60e429d44f532365c58ed5673d035e2a59c4db"
19
20S = "${WORKDIR}"
21
22do_compile () {
23 ${CC} ${CFLAGS} -o nuttcp nuttcp-${PV}.c
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 nuttcp ${D}${bindir}
29}