diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2015-01-05 10:51:26 +0000 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-01-07 13:49:41 -0500 |
commit | 25d6aa5e86a5f7bc7d003a8d49e74fcba13b70cd (patch) | |
tree | 7210a6c6049fcf46717f3a966b6b06c106f4e98c /meta-networking/recipes-support/ntp | |
parent | 07d5d4d5d9a4b2102d6bec163953b69e363ec2f9 (diff) | |
download | meta-openembedded-25d6aa5e86a5f7bc7d003a8d49e74fcba13b70cd.tar.gz |
ntp: fix file locations
After the upgrade to 4.2.8, ntp's configure process now uses a custom
script which looks at the host to determine what install locations it
should use. This resulted in the recipe working on some people's
machines and failing during do_install on others. Force it to use the
"redhat" configuration as this seems closest to what we used to be
using prior to the upgrade (this means that binaries are now back in
sbindir as they used to be).
Thanks to Philip Balister for reporting this.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/ntp')
-rw-r--r-- | meta-networking/recipes-support/ntp/ntp_4.2.8.bb | 21 |
1 files changed, 10 insertions, 11 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8.bb index 7e1b1c152..e14921a90 100644 --- a/meta-networking/recipes-support/ntp/ntp_4.2.8.bb +++ b/meta-networking/recipes-support/ntp/ntp_4.2.8.bb | |||
@@ -35,6 +35,7 @@ EXTRA_OECONF += "--with-net-snmp-config=no \ | |||
35 | --without-ntpsnmpd \ | 35 | --without-ntpsnmpd \ |
36 | ac_cv_header_readline_history_h=no \ | 36 | ac_cv_header_readline_history_h=no \ |
37 | --with-yielding_select=yes \ | 37 | --with-yielding_select=yes \ |
38 | --with-locfile=redhat \ | ||
38 | " | 39 | " |
39 | CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED" | 40 | CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED" |
40 | 41 | ||
@@ -71,10 +72,10 @@ do_install_append() { | |||
71 | sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync | 72 | sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync |
72 | sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync | 73 | sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync |
73 | sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${bindir}/ntpdate-sync | 74 | sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${bindir}/ntpdate-sync |
74 | sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${bindir}/ntptrace | 75 | sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${sbindir}/ntptrace |
75 | sed -i '/use/i use warnings;' ${D}${bindir}/ntptrace | 76 | sed -i '/use/i use warnings;' ${D}${sbindir}/ntptrace |
76 | sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${bindir}/ntp-wait | 77 | sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${sbindir}/ntp-wait |
77 | sed -i '/use/i use warnings;' ${D}${bindir}/ntp-wait | 78 | sed -i '/use/i use warnings;' ${D}${sbindir}/ntp-wait |
78 | 79 | ||
79 | install -d ${D}/${sysconfdir}/default | 80 | install -d ${D}/${sysconfdir}/default |
80 | install -m 644 ${WORKDIR}/ntpdate.default ${D}${sysconfdir}/default/ntpdate | 81 | install -m 644 ${WORKDIR}/ntpdate.default ${D}${sysconfdir}/default/ntpdate |
@@ -90,8 +91,6 @@ do_install_append() { | |||
90 | 91 | ||
91 | install -d ${D}${systemd_unitdir}/ntp-units.d | 92 | install -d ${D}${systemd_unitdir}/ntp-units.d |
92 | install -m 0644 ${WORKDIR}/ntpd.list ${D}${systemd_unitdir}/ntp-units.d/60-ntpd.list | 93 | install -m 0644 ${WORKDIR}/ntpd.list ${D}${systemd_unitdir}/ntp-units.d/60-ntpd.list |
93 | |||
94 | rmdir ${D}${sbindir} | ||
95 | } | 94 | } |
96 | 95 | ||
97 | PACKAGES += "ntpdate sntp ${PN}-tickadj ${PN}-utils" | 96 | PACKAGES += "ntpdate sntp ${PN}-tickadj ${PN}-utils" |
@@ -120,19 +119,19 @@ RCONFLICTS_ntpdate += "ntpdate-systemd" | |||
120 | 119 | ||
121 | RSUGGESTS_${PN} = "iana-etc" | 120 | RSUGGESTS_${PN} = "iana-etc" |
122 | 121 | ||
123 | FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd ${libdir} \ | 122 | FILES_${PN} = "${sbindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd ${libdir} \ |
124 | ${NTP_USER_HOME} \ | 123 | ${NTP_USER_HOME} \ |
125 | ${systemd_unitdir}/ntp-units.d/60-ntpd.list \ | 124 | ${systemd_unitdir}/ntp-units.d/60-ntpd.list \ |
126 | " | 125 | " |
127 | FILES_${PN}-tickadj = "${bindir}/tickadj" | 126 | FILES_${PN}-tickadj = "${sbindir}/tickadj" |
128 | FILES_${PN}-utils = "${bindir} ${datadir}/ntp/lib" | 127 | FILES_${PN}-utils = "${sbindir} ${datadir}/ntp/lib" |
129 | FILES_ntpdate = "${bindir}/ntpdate \ | 128 | FILES_ntpdate = "${sbindir}/ntpdate \ |
130 | ${sysconfdir}/network/if-up.d/ntpdate-sync \ | 129 | ${sysconfdir}/network/if-up.d/ntpdate-sync \ |
131 | ${bindir}/ntpdate-sync \ | 130 | ${bindir}/ntpdate-sync \ |
132 | ${sysconfdir}/default/ntpdate \ | 131 | ${sysconfdir}/default/ntpdate \ |
133 | ${systemd_unitdir}/system/ntpdate.service \ | 132 | ${systemd_unitdir}/system/ntpdate.service \ |
134 | " | 133 | " |
135 | FILES_sntp = "${bindir}/sntp \ | 134 | FILES_sntp = "${sbindir}/sntp \ |
136 | ${sysconfdir}/default/sntp \ | 135 | ${sysconfdir}/default/sntp \ |
137 | ${systemd_unitdir}/system/sntp.service \ | 136 | ${systemd_unitdir}/system/sntp.service \ |
138 | " | 137 | " |