summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ntimed
diff options
context:
space:
mode:
authorChristopher Larson <kergoth@gmail.com>2015-05-30 17:31:59 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2015-06-05 18:29:55 -0400
commitad4e5ab1bf32ed7a3bbd2f4f4ab26296b21f9de1 (patch)
tree30a845fd2205b58710df464cbcba81bf6cd2db17 /meta-networking/recipes-support/ntimed
parent15a2927106219bc11eb54bee7cd789f7f19b598e (diff)
downloadmeta-openembedded-ad4e5ab1bf32ed7a3bbd2f4f4ab26296b21f9de1.tar.gz
ntimed: add recipe to meta-networking (git version)
Ntimed is an unreleased ntpd replacement being sponsored by the Linux Foundation. Currently it only includes a work-in-progress client, but for future use this recipe emits an ntimed-client package and an ntimed meta package which will pull in client and server. Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/ntimed')
-rw-r--r--meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch16
-rw-r--r--meta-networking/recipes-support/ntimed/ntimed_git.bb41
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch b/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch
new file mode 100644
index 000000000..87a7778d9
--- /dev/null
+++ b/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch
@@ -0,0 +1,16 @@
1Obey LDFLAGS.
2
3Signed-off-by: Christopher Larson <kergoth@gmail.com>
4Upstream-Status: Pending
5
6--- Ntimed.orig/configure 2015-05-30 11:57:59.927796993 -0700
7+++ Ntimed/configure 2015-05-30 11:58:26.143948894 -0700
8@@ -142,7 +142,7 @@
9
10 echo
11 echo "ntimed-client: ${l}"
12- echo " \${CC} \${CFLAGS} -o ntimed-client ${l} -lm"
13+ echo " \${CC} \${CFLAGS} -o ntimed-client ${l} \${LDFLAGS} -lm"
14 echo
15 echo "clean:"
16 echo " rm -f ${l} ntimed-client"
diff --git a/meta-networking/recipes-support/ntimed/ntimed_git.bb b/meta-networking/recipes-support/ntimed/ntimed_git.bb
new file mode 100644
index 000000000..099054178
--- /dev/null
+++ b/meta-networking/recipes-support/ntimed/ntimed_git.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Network time synchronization software, NTPD replacement"
2DESCRIPTION = "This is a preview/early-access/alpha/buzzword-of-the-times \
3release of a new FOSS project written to gradually take over the world of \
4networked timekeeping."
5HOMEPAGE = "https://github.com/bsdphk/Ntimed"
6SECTION = "console/network"
7
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://main.c;startline=2;endline=24;md5=eda11d21005319bb76cbb6f911f0f66d"
10
11SRC_URI = "git://github.com/bsdphk/Ntimed \
12 file://use-ldflags.patch"
13
14PV = "0.0+git${SRCPV}"
15SRCREV = "db0abbb4c80f2ecef6bc5d9639bca5bea28532a2"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = "\
20 'CC=${CC}' \
21 'CFLAGS=${CFLAGS}' \
22 'LDFLAGS=${LDFLAGS}' \
23"
24
25do_configure () {
26 sh ./configure
27}
28
29do_compile () {
30 oe_runmake
31}
32
33do_install () {
34 install -D -m 0755 ntimed-client ${D}${sbindir}/ntimed-client
35}
36
37ALLOW_EMPTY_${PN} = "1"
38RDEPENDS_${PN} += "ntimed-client"
39
40PACKAGE_BEFORE_PN += "ntimed-client"
41FILES_ntimed-client = "${sbindir}/ntimed-client"