summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nis
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-29 14:26:07 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-30 00:14:58 -0700
commit516bded7798d64b561d754b6ea5415033f6490a8 (patch)
treee137e7b6e6dd77915907cb1c8413346204e2d550 /meta-networking/recipes-support/nis
parent61eb94c55a589a69fa3bfa84904e8729e14b6247 (diff)
downloadmeta-openembedded-516bded7798d64b561d754b6ea5415033f6490a8.tar.gz
ypbind-mt: Upgrade to 2.7.2
Disable on musl since its using some non-portable glibc only constructs Drop gettid patch its applied upstream Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/nis')
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch45
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_2.7.2.bb (renamed from meta-networking/recipes-support/nis/ypbind-mt_2.6.bb)8
2 files changed, 4 insertions, 49 deletions
diff --git a/meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch b/meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch
deleted file mode 100644
index 9484d0b00..000000000
--- a/meta-networking/recipes-support/nis/ypbind-mt/0001-Add-configure-time-check-for-gettid-API.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From 25d5daf30aa2dc451ba528712f668036d8506054 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 27 Jul 2019 07:50:26 -0700
4Subject: [PATCH] Add configure time check for gettid API
5
6glibc 2.30 has added this syscalls wrapper
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 configure.ac | 1 +
11 src/log_msg.c | 2 ++
12 2 files changed, 3 insertions(+)
13
14diff --git a/configure.ac b/configure.ac
15index 9e32a4a..6d1067b 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -33,6 +33,7 @@ if test -n "$TIRPC_LIBS"; then
19 AC_DEFINE(HAVE_TIRPC, 1, [Define to 1 if TIRPC is available])
20 fi
21
22+AC_CHECK_FUNCS(gettid)
23 dnl The difficult part: could we reconfigure NSS or must we use DNS ?
24 AC_CHECK_FUNCS(__nss_configure_lookup)
25 if eval "test \"`echo '$ac_cv_func___nss_configure_lookup'`\" != yes"; then
26diff --git a/src/log_msg.c b/src/log_msg.c
27index 49f0905..37da311 100644
28--- a/src/log_msg.c
29+++ b/src/log_msg.c
30@@ -26,6 +26,7 @@
31 #include "log_msg.h"
32
33 #include <sys/syscall.h>
34+#if !HAVE_GETTID
35 #ifdef __NR_gettid
36 static pid_t
37 gettid (void)
38@@ -39,6 +40,7 @@ gettid (void)
39 return getpid ();
40 }
41 #endif
42+#endif
43
44 int debug_flag = 0;
45 int logfile_flag = 0;
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_2.6.bb b/meta-networking/recipes-support/nis/ypbind-mt_2.7.2.bb
index 2c5e2bd93..a95062bc8 100644
--- a/meta-networking/recipes-support/nis/ypbind-mt_2.6.bb
+++ b/meta-networking/recipes-support/nis/ypbind-mt_2.7.2.bb
@@ -29,13 +29,11 @@ RDEPENDS:${PN} += "yp-tools"
29PROVIDES += "ypbind" 29PROVIDES += "ypbind"
30 30
31SRC_URI = "https://github.com/thkukuk/ypbind-mt/releases/download/v${PV}/${BPN}-${PV}.tar.xz \ 31SRC_URI = "https://github.com/thkukuk/ypbind-mt/releases/download/v${PV}/${BPN}-${PV}.tar.xz \
32 file://0001-dns_hosts-Fix-build-with-musl.patch \
32 file://ypbind.init \ 33 file://ypbind.init \
33 file://ypbind.service \ 34 file://ypbind.service \
34 file://0001-dns_hosts-Fix-build-with-musl.patch \
35 file://0001-Add-configure-time-check-for-gettid-API.patch \
36 " 35 "
37SRC_URI[md5sum] = "7cf89641fdc128d0919207e4b7caaf1d" 36SRC_URI[sha256sum] = "064f2f185673c5493df83f6400b799f3a359de56118b6ba37c4327111f2fcd8b"
38SRC_URI[sha256sum] = "0696c0263c4fd48a4ff2ce6c109f05f37aab0f71646d81cb22c7c28591bf80eb"
39 37
40inherit systemd update-rc.d 38inherit systemd update-rc.d
41 39
@@ -57,6 +55,8 @@ do_install:append () {
57 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system 55 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
58} 56}
59 57
58# uses glibc internal APIs e.g. _hostalias
59COMPATIBLE_HOST:libc-musl = "null"
60 60
61RPROVIDES:${PN} += "${PN}-systemd" 61RPROVIDES:${PN} += "${PN}-systemd"
62RREPLACES:${PN} += "${PN}-systemd" 62RREPLACES:${PN} += "${PN}-systemd"