summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2015-03-02 00:23:43 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2015-03-04 08:52:03 -0500
commite00832bc4dbeacb5eb09864674b6ba7a04fc8622 (patch)
tree97b20786b6ce441c044fbaa2e0d93d7355bf2ea9 /meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
parentbcfbe19f4a62b1a97978843b20ec4a9356b9aeb2 (diff)
downloadmeta-openembedded-e00832bc4dbeacb5eb09864674b6ba7a04fc8622.tar.gz
nis: integrate latest stable yp-tools and ypbind
Update to the latest stable NIS tools. The yp-tools libraries and headers conflict with the RPC headers provided by glibc, so install them to a different location. Systems that intend to build using the NIS-provided versions will need to specify the alternate location, but that is covered by pkg-config, so it should only be necessary to point pkg-config at the alternate .pc file. The older stable versions are suitable for IPv4-only setups, so keep them around in case those are required for some systems. Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/nis/ypbind-mt_2.2.bb')
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_2.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb b/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
new file mode 100644
index 000000000..b9607574a
--- /dev/null
+++ b/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
@@ -0,0 +1,51 @@
1# This package builds the NIS ypbind daemon
2# The source package is utils/net/NIS/ypbind-mt
3#
4require nis.inc
5
6DESCRIPTION = " \
7Multithreaded NIS bind service (ypbind-mt). \
8ypbind-mt is a complete new implementation of a NIS \
9binding daemon for Linux. It has the following \
10features. Supports ypbind protocol V1 and V2. \
11Uses threads for better response. Supports multiple \
12domain bindings. Supports /var/yp/binding/* file \
13for Linux libc 4/5 and glibc 2.x. Supports a list \
14of known secure NIS server (/etc/yp.conf) Binds to \
15the server which answered as first. \
16"
17HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
18DEPENDS = "yp-tools"
19PROVIDES += "ypbind"
20
21SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
22 file://ypbind-yocto.init \
23 file://ypbind.service \
24"
25SRC_URI[md5sum] = "54e2040d8266ae7d302d081ca310c8a8"
26SRC_URI[sha256sum] = "dc2f7d97c94dcab0acfdcd115cd8b464eb8c427e4bb0fe68404ae7465f517cd3"
27
28inherit systemd update-rc.d
29
30SYSTEMD_SERVICE_${PN} = "ypbind.service"
31INITSCRIPT_NAME = "ypbind"
32INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
33
34CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
35
36EXTRA_OECONF = "PKG_CONFIG_PATH='${STAGING_LIBDIR}/yp-nis/pkgconfig/'"
37
38do_install_append () {
39 install -d ${D}${sysconfdir}/init.d
40 install -d ${D}${sysconfdir}/rcS.d
41
42 install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind
43
44 install -d ${D}${systemd_unitdir}/system
45 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
46}
47
48
49RPROVIDES_${PN} += "${PN}-systemd"
50RREPLACES_${PN} += "${PN}-systemd"
51RCONFLICTS_${PN} += "${PN}-systemd"