diff options
author | Paul Gortmaker <paul.gortmaker@windriver.com> | 2016-05-08 15:08:12 -0400 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-05-12 11:53:30 -0400 |
commit | 00ec8bc10df539ecedc3beb2dde28a8e4665cad8 (patch) | |
tree | 1a863d84a5bab853a9179d494ada1468e865a2f9 /meta-networking/recipes-support/netcf | |
parent | 273d79740b69deb63672705848613de64acfeaf2 (diff) | |
download | meta-openembedded-00ec8bc10df539ecedc3beb2dde28a8e4665cad8.tar.gz |
autotools-bootstrap: make bootstrap package specific.
The theory behind this bbclass was reasonable, with the primary
goal being to avoid multiple downloads of gnulib, but it neglected
the fact that packages would be shipping a specific version of the
./bootstrap which will support some flags but maybe not all the
latest ones from the latest gnulib/build-aux/bootstrap file.
I attempted to simply update the two pkgs to use the latest copy
of bootstrap from gnulib but this of course triggers the descent
into autoconf hell that we all know and love. Rather than futzing
with the packages configure.ac and deviating from what the pkg
maintainers intended and tested, we can just let the packages have
independent calls to ./bootstrap with whatever flags are needed.
The goal of this commit is to move the prepend out to the packages
and then delete the class without any real functional change ; i.e.
a purely mechanical change. Then we can adjust each package to
ensure it will still build with a modern host, in an independent
fashion, while keeping the main advantage of not fetching gnulib
two extra times for netcf and fontforge.
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/netcf')
-rw-r--r-- | meta-networking/recipes-support/netcf/netcf_git.bb | 22 |
1 files changed, 21 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb index 1bc6baef0..f67f4ec60 100644 --- a/meta-networking/recipes-support/netcf/netcf_git.bb +++ b/meta-networking/recipes-support/netcf/netcf_git.bb | |||
@@ -16,13 +16,33 @@ DEPENDS += "augeas libnl libxslt libxml2 gnulib" | |||
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||
19 | inherit gettext autotools-bootstrap pkgconfig systemd | 19 | inherit gettext autotools pkgconfig systemd |
20 | 20 | ||
21 | EXTRA_OECONF_append_class-target = " --with-driver=redhat" | 21 | EXTRA_OECONF_append_class-target = " --with-driver=redhat" |
22 | 22 | ||
23 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}" | 23 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}" |
24 | PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts," | 24 | PACKAGECONFIG[systemd] = "--with-sysinit=systemd,--with-sysinit=initscripts," |
25 | 25 | ||
26 | do_configure_prepend() { | ||
27 | currdir=`pwd` | ||
28 | cd ${S} | ||
29 | |||
30 | # avoid bootstrap cloning gnulib on every configure | ||
31 | cat >.gitmodules <<EOF | ||
32 | [submodule "gnulib"] | ||
33 | path = gnulib | ||
34 | url = git://git.sv.gnu.org/gnulib | ||
35 | EOF | ||
36 | cp -rf ${STAGING_DATADIR}/gnulib ${S} | ||
37 | |||
38 | # --force to avoid errors on reconfigure e.g if recipes changed we depend on | ||
39 | # | bootstrap: running: libtoolize --quiet | ||
40 | # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite | ||
41 | # | ... | ||
42 | ./bootstrap --force | ||
43 | cd $currdir | ||
44 | } | ||
45 | |||
26 | do_install_append() { | 46 | do_install_append() { |
27 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | 47 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
28 | install -d ${D}${systemd_unitdir}/system | 48 | install -d ${D}${systemd_unitdir}/system |