summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ndisc6
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-support/ndisc6
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-support/ndisc6')
-rw-r--r--meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb36
1 files changed, 18 insertions, 18 deletions
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb
index 3920c1a5a..d75391213 100644
--- a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb
+++ b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb
@@ -11,7 +11,7 @@ RDEPENDS_${PN}-tcptraceroute6 = "${PN}-rltraceroute6"
11RDEPENDS_${PN}-tracert6 = "${PN}-rltraceroute6" 11RDEPENDS_${PN}-tracert6 = "${PN}-rltraceroute6"
12 12
13SRC_URI = "http://www.remlab.net/files/ndisc6/ndisc6-${PV}.tar.bz2 \ 13SRC_URI = "http://www.remlab.net/files/ndisc6/ndisc6-${PV}.tar.bz2 \
14 " 14"
15SRC_URI[md5sum] = "50cb4c19606cf6ff2b7388e71832f579" 15SRC_URI[md5sum] = "50cb4c19606cf6ff2b7388e71832f579"
16SRC_URI[sha256sum] = "6acec8a0cb9efa3ac98456f46c3016aeec0598b0c7557c95242b5228ad62ca7a" 16SRC_URI[sha256sum] = "6acec8a0cb9efa3ac98456f46c3016aeec0598b0c7557c95242b5228ad62ca7a"
17 17
@@ -22,25 +22,25 @@ inherit autotools gettext
22# Split into seperate packages since we normal don't want them all 22# Split into seperate packages since we normal don't want them all
23# The main package is left empty and therefore not created. 23# The main package is left empty and therefore not created.
24PACKAGES += "${PN}-ndisc6 ${PN}-tcpspray6 ${PN}-rdisc6 \ 24PACKAGES += "${PN}-ndisc6 ${PN}-tcpspray6 ${PN}-rdisc6 \
25 ${PN}-tcptraceroute6 ${PN}-rltraceroute6 \ 25 ${PN}-tcptraceroute6 ${PN}-rltraceroute6 \
26 ${PN}-tracert6 ${PN}-rdnssd ${PN}-misc" 26 ${PN}-tracert6 ${PN}-rdnssd ${PN}-misc"
27FILES_${PN} = "" 27FILES_${PN} = ""
28FILES_${PN}-ndisc6 = "${bindir}/ndisc6" 28FILES_${PN}-ndisc6 = "${bindir}/ndisc6"
29FILES_${PN}-tcpspray6 = "${bindir}/tcpspray6" 29FILES_${PN}-tcpspray6 = "${bindir}/tcpspray6"
30FILES_${PN}-rdisc6 = "${bindir}/rdisc6" 30FILES_${PN}-rdisc6 = "${bindir}/rdisc6"
31FILES_${PN}-tcptraceroute6 = "${bindir}/tcptraceroute6" 31FILES_${PN}-tcptraceroute6 = "${bindir}/tcptraceroute6"
32FILES_${PN}-rltraceroute6 = "${bindir}/rltraceroute6" 32FILES_${PN}-rltraceroute6 = "${bindir}/rltraceroute6"
33FILES_${PN}-tracert6 = "${bindir}/tracert6" 33FILES_${PN}-tracert6 = "${bindir}/tracert6"
34FILES_${PN}-rdnssd = "${sbindir}/rdnssd ${sysconfdir}/rdnssd" 34FILES_${PN}-rdnssd = "${sbindir}/rdnssd ${sysconfdir}/rdnssd"
35FILES_${PN}-misc = "${bindir}/dnssort ${bindir}/name2addr ${bindir}/tcpspray ${bindir}/addr2name" 35FILES_${PN}-misc = "${bindir}/dnssort ${bindir}/name2addr ${bindir}/tcpspray ${bindir}/addr2name"
36 36
37DESCRIPTION_${PN}-ndisc6 = "ICMPv6 Neighbor Discovery tool. \ 37DESCRIPTION_${PN}-ndisc6 = "ICMPv6 Neighbor Discovery tool. \
38Performs IPv6 neighbor discovery in userland. Replaces arping from the \ 38Performs IPv6 neighbor discovery in userland. Replaces arping from the \
39IPv4 world." 39IPv4 world."
40DESCRIPTION_${PN}-rdisc6 = "ICMPv6 Router Discovery tool. \ 40DESCRIPTION_${PN}-rdisc6 = "ICMPv6 Router Discovery tool. \
41Queries IPv6 routers on the network for advertised prefixes. Can be used \ 41Queries IPv6 routers on the network for advertised prefixes. Can be used \
42to detect rogue IPv6 routers, monitor legitimate IPv6 routers." 42to detect rogue IPv6 routers, monitor legitimate IPv6 routers."
43DESCRITPION_${PN}-tcpspray6 = "Performs bandwidth measurements of TCP \ 43DESCRITPION_${PN}-tcpspray6 = "Performs bandwidth measurements of TCP \
44sessions between the local system and a remote echo server in either IPv6 \ 44sessions between the local system and a remote echo server in either IPv6 \
45or IPv4." 45or IPv4."
46 46
@@ -48,15 +48,15 @@ DESCRITPION_${PN}-rdnssd = "Daemon to autoconfigure the list of DNS \
48servers through slateless IPv6 autoconfiguration." 48servers through slateless IPv6 autoconfiguration."
49 49
50do_install_append () { 50do_install_append () {
51 rm -rf ${D}${localstatedir} 51 rm -rf ${D}${localstatedir}
52} 52}
53# Enable SUID bit for applications that need it 53# Enable SUID bit for applications that need it
54pkg_postinst_${PN}-rltraceroute6 () { 54pkg_postinst_${PN}-rltraceroute6 () {
55 chmod 4555 ${bindir}/rltraceroute6 55 chmod 4555 ${bindir}/rltraceroute6
56} 56}
57pkg_postinst_${PN}-ndisc6 () { 57pkg_postinst_${PN}-ndisc6 () {
58 chmod 4555 ${bindir}/ndisc6 58 chmod 4555 ${bindir}/ndisc6
59} 59}
60pkg_postinst_${PN}-rdisc6 () { 60pkg_postinst_${PN}-rdisc6 () {
61 chmod 4555 ${bindir}/rdisc6 61 chmod 4555 ${bindir}/rdisc6
62} 62}