summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-networking/recipes-support/memcached/memcached_1.4.17.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-networking/recipes-support/memcached/memcached_1.4.17.bb')
-rw-r--r--meta-networking/recipes-support/memcached/memcached_1.4.17.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
new file mode 100644
index 000000000..4d93f041e
--- /dev/null
+++ b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
@@ -0,0 +1,53 @@
1SUMMARY = "A high-performance memory object caching system"
2DESCRIPTION = "\
3 memcached optimizes specific high-load serving applications that are designed \
4 to take advantage of its versatile no-locking memory access system. Clients \
5 are available in several different programming languages, to suit the needs \
6 of the specific application. Traditionally this has been used in mod_perl \
7 apps to avoid storing large chunks of data in Apache memory, and to share \
8 this burden across several machines."
9
10HOMEPAGE = "http://memcached.org/"
11LICENSE = "BSD-3-Clause"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff"
14
15inherit autotools
16
17DEPENDS += "libevent"
18RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader \
19 perl-module-tie-hash bash \
20 "
21
22SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
23 file://configure.patch \
24 file://memcached-add-hugetlbfs-check.patch"
25
26# set the same COMPATIBLE_HOST as libhugetlbfs
27COMPATIBLE_HOST = '(i.86|x86_64|powerpc|powerpc64|arm).*-linux'
28
29SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6"
30SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458"
31
32python __anonymous () {
33 endianness = d.getVar('SITEINFO_ENDIANNESS', True)
34 if endianness == 'le':
35 d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=little")
36 else:
37 d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=big")
38}
39
40PACKAGECONFIG ??= ""
41PACKAGECONFIG[hugetlbfs] = "--enable-hugetlbfs, --disable-hugetlbfs, libhugetlbfs"
42
43inherit update-rc.d
44
45INITSCRIPT_NAME = "memcached"
46INITSCRIPT_PARAMS = "defaults"
47
48do_install_append() {
49 install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
50 mkdir -p ${D}/usr/share/memcached/scripts
51 install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
52 install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
53}