summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/mctp
diff options
context:
space:
mode:
authorJeremy Kerr <jk@codeconstruct.com.au>2021-12-17 10:28:09 +0800
committerKhem Raj <raj.khem@gmail.com>2021-12-21 18:48:51 -0800
commit9da8d6eaa93b61daa091d0fef54aacf3c58af3a1 (patch)
treed158ed3fa1f1c15a775f65618edf5670ef1a2519 /meta-networking/recipes-support/mctp
parent484e0de1e4ee107f21ae2a5c5f976ed987978baf (diff)
downloadmeta-openembedded-9da8d6eaa93b61daa091d0fef54aacf3c58af3a1.tar.gz
mctp: upgrade to v1.0
We have a tag for 1.0, now: better handling of local stack configuration at runtime, and the 5.15 kernel header change has been integrated. Signed-off-by: Jeremy Kerr <jk@codeconstruct.com.au> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/mctp')
-rw-r--r--meta-networking/recipes-support/mctp/mctp/0001-build-Adjust-for-kernel-mctp.h.patch84
-rw-r--r--meta-networking/recipes-support/mctp/mctp_git.bb8
2 files changed, 3 insertions, 89 deletions
diff --git a/meta-networking/recipes-support/mctp/mctp/0001-build-Adjust-for-kernel-mctp.h.patch b/meta-networking/recipes-support/mctp/mctp/0001-build-Adjust-for-kernel-mctp.h.patch
deleted file mode 100644
index 83bf19770..000000000
--- a/meta-networking/recipes-support/mctp/mctp/0001-build-Adjust-for-kernel-mctp.h.patch
+++ /dev/null
@@ -1,84 +0,0 @@
1From 653eccc918ef993186c312694c288b2a5b39248e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 5 Nov 2021 13:14:55 -0700
4Subject: [PATCH] build: Adjust for kernel mctp.h
5
6Starting 5.15 kernel has mctp.h as well and provides some of the
7defintions, therefore move the ones we need to provide in this header
8outside the conditional check so its always provided regardless of
9header coming from kernel or not.
10
11Include linux/if_link.h so it can pre-define IFLA_MCTP_UNSPEC and other
12defines and there is a check for conditionally providing them here but
13kernel does not have such a check, so if linux/if_link.h is included
14after this header then we end up with duplicate defines
15
16linux/if_link.h:1267:2: error: redefinition of enumerator 'IFLA_MCTP_UNSPEC'
17 IFLA_MCTP_UNSPEC,
18 ^
19../git/src/mctp.h:74:2: note: previous definition is here
20 IFLA_MCTP_UNSPEC,
21 ^
22
23Upstream-Status: Submitted [https://github.com/CodeConstruct/mctp/pull/2]
24Signed-off-by: Khem Raj <raj.khem@gmail.com>
25---
26 src/mctp.h | 21 +++++++++++----------
27 1 file changed, 11 insertions(+), 10 deletions(-)
28
29diff --git a/src/mctp.h b/src/mctp.h
30index 4f73def..e602168 100644
31--- a/src/mctp.h
32+++ b/src/mctp.h
33@@ -19,6 +19,7 @@
34 #if HAVE_LINUX_MCTP_H
35 #include <linux/mctp.h>
36 #endif
37+#include <linux/if_link.h>
38
39 #ifndef AF_MCTP
40 #define AF_MCTP 45
41@@ -33,10 +34,6 @@
42
43 #ifndef MCTP_NET_ANY
44
45-#ifndef MAX_ADDR_LEN
46-#define MAX_ADDR_LEN 32
47-#endif
48-
49 typedef uint8_t mctp_eid_t;
50
51 struct mctp_addr {
52@@ -53,6 +50,16 @@ struct sockaddr_mctp {
53 uint8_t __smctp_pad1;
54 };
55
56+#define MCTP_NET_ANY 0
57+#define MCTP_ADDR_ANY 0xff
58+#define MCTP_TAG_OWNER 0x08
59+
60+#endif /* MCTP_NET_ANY */
61+
62+#ifndef MAX_ADDR_LEN
63+#define MAX_ADDR_LEN 32
64+#endif
65+
66 struct sockaddr_mctp_ext {
67 struct sockaddr_mctp smctp_base;
68 int smctp_ifindex;
69@@ -61,12 +68,6 @@ struct sockaddr_mctp_ext {
70 unsigned char smctp_haddr[MAX_ADDR_LEN];
71 };
72
73-#define MCTP_NET_ANY 0
74-#define MCTP_ADDR_ANY 0xff
75-#define MCTP_TAG_OWNER 0x08
76-
77-#endif /* MCTP_NET_ANY */
78-
79 #ifndef IFLA_MCTP_MAX
80
81 /* From if_link.h */
82--
832.33.1
84
diff --git a/meta-networking/recipes-support/mctp/mctp_git.bb b/meta-networking/recipes-support/mctp/mctp_git.bb
index 50d84d204..eabc6fa16 100644
--- a/meta-networking/recipes-support/mctp/mctp_git.bb
+++ b/meta-networking/recipes-support/mctp/mctp_git.bb
@@ -5,13 +5,11 @@ LICENSE = "GPLv2"
5 5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21"
7 7
8PV = "0.1+git${SRCPV}" 8PV = "1.0+git${SRCPV}"
9 9
10SRCREV = "072bafe725c50329f99cf9d3b2624e8799e8163a" 10SRCREV = "669740432af525c19a6a41cec777406fbbc24836"
11 11
12SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main;protocol=https \ 12SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main;protocol=https"
13 file://0001-build-Adjust-for-kernel-mctp.h.patch \
14 "
15 13
16S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
17 15