diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-10-18 22:38:26 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-11-14 10:07:27 -0500 |
commit | aebf681a9e7cf6b6018892e05f53a6c5806e6e2f (patch) | |
tree | 843115af791eeef86b457363fbe95141ac00f9f2 /meta-networking/recipes-support/lowpan-tools | |
parent | c8f78ecb9b8a39a955631ca1a415d94da588bc26 (diff) | |
download | meta-openembedded-aebf681a9e7cf6b6018892e05f53a6c5806e6e2f.tar.gz |
lowpan-tools: Fix errors found with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/lowpan-tools')
-rw-r--r-- | meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch | 34 | ||||
-rw-r--r-- | meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb | 6 |
2 files changed, 39 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch new file mode 100644 index 000000000..8e906f7ce --- /dev/null +++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-Fix-build-errors-with-clang.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 5f9e80acb0a1ac399839bf160e43f6120c4b5128 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 18 Oct 2016 23:49:09 +0000 | ||
4 | Subject: [PATCH] Fix build errors with clang | ||
5 | |||
6 | | ../../../../../../../workspace/sources/lowpan-tools/src/coordinator.c:313:50: error: format specifies type 'unsigned char' but the argument has type 'int' [-Werror,-Wformat] | ||
7 | | fprintf(stderr, "Opt: %c (%hhx)\n", (char)opt, opt); | ||
8 | | ~~~~ ^~~ | ||
9 | | %x | ||
10 | | 1 error generated. | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | src/coordinator.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/src/coordinator.c b/src/coordinator.c | ||
20 | index c139aae..f0de6d2 100644 | ||
21 | --- a/src/coordinator.c | ||
22 | +++ b/src/coordinator.c | ||
23 | @@ -310,7 +310,7 @@ int main(int argc, char **argv) | ||
24 | #else | ||
25 | opt = getopt(argc, argv, "l:f:d:m:n:i:s:p:c:hv"); | ||
26 | #endif | ||
27 | - fprintf(stderr, "Opt: %c (%hhx)\n", opt, opt); | ||
28 | + fprintf(stderr, "Opt: %c (%hhx)\n", opt, (unsigned char)opt); | ||
29 | if (opt == -1) | ||
30 | break; | ||
31 | |||
32 | -- | ||
33 | 1.9.1 | ||
34 | |||
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb index 76a4edf68..8c7dbc09a 100644 --- a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb +++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb | |||
@@ -9,7 +9,9 @@ DEPENDS = "flex-native bison-native libnl python" | |||
9 | 9 | ||
10 | PV = "0.3.1+git${SRCPV}" | 10 | PV = "0.3.1+git${SRCPV}" |
11 | SRC_URI = "git://git.code.sf.net/p/linux-zigbee/linux-zigbee \ | 11 | SRC_URI = "git://git.code.sf.net/p/linux-zigbee/linux-zigbee \ |
12 | file://no-help2man.patch" | 12 | file://no-help2man.patch \ |
13 | file://0001-Fix-build-errors-with-clang.patch \ | ||
14 | " | ||
13 | SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733" | 15 | SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733" |
14 | 16 | ||
15 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
@@ -18,6 +20,8 @@ inherit autotools python-dir pkgconfig | |||
18 | 20 | ||
19 | CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools" | 21 | CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools" |
20 | 22 | ||
23 | CFLAGS += "-Wno-initializer-overrides" | ||
24 | |||
21 | do_install_append() { | 25 | do_install_append() { |
22 | rmdir ${D}${localstatedir}/run | 26 | rmdir ${D}${localstatedir}/run |
23 | } | 27 | } |