summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/lowpan-tools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-27 17:59:24 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 15:55:35 -0400
commitb57ae5a2bdd25b9ead53561d36160b087ca56565 (patch)
treead36c9c6a28c77db344fde97fd682ab546b959cd /meta-networking/recipes-support/lowpan-tools
parent2cc844809fbc64dbdc2c2cd3f6b11467bbed85c3 (diff)
downloadmeta-openembedded-b57ae5a2bdd25b9ead53561d36160b087ca56565.tar.gz
lowpan-tools: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/lowpan-tools')
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch44
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch
new file mode 100644
index 000000000..0a81a2252
--- /dev/null
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch
@@ -0,0 +1,44 @@
1From ab725a3faaeead90ae3c63cbcd370af087c413a5 Mon Sep 17 00:00:00 2001
2From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
3Date: Mon, 27 Mar 2017 17:55:06 -0700
4Subject: [PATCH] addrdb/coord-config-parse.y: add missing <time.h> include
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9The %union definition uses the time_t structure. In order to use this
10structure, the <time.h> header has to be included. Otherwise, the build
11breaks with some C libraries, such as musl:
12
13In file included from coord-config-lex.l:23:0:
14coord-config-parse.y:107:2: error: unknown type name ‘time_t’
15 time_t timestamp;
16 ^
17
18This patch includes <time.h> using the '%code requires' directive of
19Yacc.
20
21Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
22Signed-off-by: Khem Raj <raj.khem@gmail.com>
23---
24 addrdb/coord-config-parse.y | 4 ++++
25 1 file changed, 4 insertions(+)
26
27diff --git a/addrdb/coord-config-parse.y b/addrdb/coord-config-parse.y
28index 2e10a88..85ee058 100644
29--- a/addrdb/coord-config-parse.y
30+++ b/addrdb/coord-config-parse.y
31@@ -102,6 +102,10 @@
32
33 %}
34
35+%code requires {
36+#include <time.h>
37+}
38+
39 %union {
40 unsigned long number;
41 time_t timestamp;
42--
432.12.1
44
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
index 8c7dbc09a..139eb788f 100644
--- a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -11,6 +11,7 @@ PV = "0.3.1+git${SRCPV}"
11SRC_URI = "git://git.code.sf.net/p/linux-zigbee/linux-zigbee \ 11SRC_URI = "git://git.code.sf.net/p/linux-zigbee/linux-zigbee \
12 file://no-help2man.patch \ 12 file://no-help2man.patch \
13 file://0001-Fix-build-errors-with-clang.patch \ 13 file://0001-Fix-build-errors-with-clang.patch \
14 file://0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch \
14 " 15 "
15SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733" 16SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733"
16 17