summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/lowpan-tools
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-11-19 16:25:48 +0000
committerJoe MacDonald <joe@deserted.net>2013-11-25 21:52:42 -0500
commit09b6cc46394392a385d68e2b1252ce545ec664b5 (patch)
treedb35f41d6623e60303c48f4f8bf68edb29823285 /meta-networking/recipes-support/lowpan-tools
parent6026617ea32b2c941a6de26f5c14efb9e291b100 (diff)
downloadmeta-openembedded-09b6cc46394392a385d68e2b1252ce545ec664b5.tar.gz
lowpan-tools: fix do_install failure
We don't have a proper help2man so building the manpages fails; just disable building them to fix this as we do elsewhere. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-support/lowpan-tools')
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools/no-help2man.patch41
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb3
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools/no-help2man.patch b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/no-help2man.patch
new file mode 100644
index 000000000..9ecd707b4
--- /dev/null
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/no-help2man.patch
@@ -0,0 +1,41 @@
1Disable building manpages so that make install doesn't fail due to lack of help2man
2
3Upstream-Status: Inappropriate [config]
4
5Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
6
7diff --git a/src/Makefile.am b/src/Makefile.am
8index 46c4017..d6ed312 100644
9--- a/src/Makefile.am
10+++ b/src/Makefile.am
11@@ -9,11 +9,6 @@ izcoordinator_DESC = "simple coordinator for IEEE 802.15.4 network"
12 iz_DESC = "configure an IEEE 802.15.4 interface"
13 izchat_DESC = "simple chat program using IEEE 802.15.4"
14
15-if MANPAGES
16-dist_man_MANS = $(manpages)
17-endif
18-EXTRA_DIST = $(manpages)
19-
20 izattach_SOURCES = serial.c
21
22 iz_SOURCES = iz.c iz-common.c iz-mac.c iz-phy.c
23@@ -27,18 +22,6 @@ izcoordinator_LDADD = ../addrdb/libaddrdb.la $(LDADD) $(NL_LIBS) $(LEXLIB)
24 iz_CFLAGS = $(AM_CFLAGS) $(NL_CFLAGS) -D_GNU_SOURCE
25 iz_LDADD = $(LDADD) $(NL_LIBS)
26
27-izattach.8: $(izattach_SOURCES) $(top_srcdir)/configure.ac
28- -$(HELP2MAN) -o $@ -s 8 -N -n $(izattach_DESC) $(builddir)/izattach
29-
30-izcoordinator.8: $(izcoordinator_SOURCES) $(top_srcdir)/configure.ac
31- -$(HELP2MAN) -o $@ -s 8 -N -n $(izcoordinator_DESC) $(builddir)/izcoordinator
32-
33-iz.8: $(iz_SOURCES) $(top_srcdir)/configure.ac
34- -$(HELP2MAN) -o $@ -s 8 -N -n $(iz_DESC) $(builddir)/iz
35-
36-izchat.1: $(izchat_SOURCES) $(top_srcdir)/configure.ac
37- -$(HELP2MAN) -o $@ -s 1 -N -n $(izchat_DESC) $(builddir)/izchat
38-
39 install-data-hook:
40 $(mkinstalldirs) $(DESTDIR)`dirname $(leasefile)`
41 $(mkinstalldirs) $(DESTDIR)`dirname $(pidfile)`
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
index 152ee49a8..5fc0de315 100644
--- a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -8,7 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "libnl python" 8DEPENDS = "libnl python"
9 9
10PV = "0.3+git${SRCPV}" 10PV = "0.3+git${SRCPV}"
11SRC_URI = "git://linux-zigbee.git.sourceforge.net/gitroot/linux-zigbee/linux-zigbee" 11SRC_URI = "git://linux-zigbee.git.sourceforge.net/gitroot/linux-zigbee/linux-zigbee \
12 file://no-help2man.patch"
12SRCREV = "a1d9615adde6d1a568813c24a128273ed755af04" 13SRCREV = "a1d9615adde6d1a568813c24a128273ed755af04"
13 14
14S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"