summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/lksctp-tools
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2015-01-21 10:21:29 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-01-26 09:58:31 -0500
commite54707d42613655570aeadb7a5911338f5e2f045 (patch)
treea5cf6b7fcd97d0ae29cd66b910a44e1aa96ccd11 /meta-networking/recipes-support/lksctp-tools
parentc4d1940e311a28b81d8aa1b772d468d73e88561a (diff)
downloadmeta-openembedded-e54707d42613655570aeadb7a5911338f5e2f045.tar.gz
lksctp-tools: add ptest subpackage and other updates
Some updates for lksctp-tools: * add ptest subpackage * only blacklist lksctp-tools when gold ld is used. Refer to: https://bugs.gentoo.org/show_bug.cgi?id=530318 * update licenses and add homepage. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/lksctp-tools')
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools/run-ptest5
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools/v4test.sh11
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools/v6test.sh11
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb21
4 files changed, 44 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools/run-ptest b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/run-ptest
new file mode 100644
index 000000000..e67f18e55
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/run-ptest
@@ -0,0 +1,5 @@
1#!/bin/sh
2
3sh v4test.sh
4sh v6test.sh
5
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools/v4test.sh b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/v4test.sh
new file mode 100644
index 000000000..513085699
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/v4test.sh
@@ -0,0 +1,11 @@
1#!/bin/sh
2echo "v4test starting:"
3for t in $(find -maxdepth 1 -type f \! -name test\*_v6 -name test\*); do
4 echo "$t";
5 if $t; then
6 echo "PASS: $t"; echo "";
7 else
8 echo "FAIL: $t"; echo "";
9 fi
10 sleep 1;
11done
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools/v6test.sh b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/v6test.sh
new file mode 100644
index 000000000..3a667df82
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools/v6test.sh
@@ -0,0 +1,11 @@
1#!/bin/sh
2echo "v6test starting:"
3for t in $(find -maxdepth 1 -name test\*_v6); do
4 echo "$t";
5 if $t; then
6 echo "PASS: $t"; echo "";
7 else
8 echo "FAIL: $t"; echo "";
9 fi
10 sleep 1;
11done
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
index ded6d08a7..1651eb83d 100644
--- a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
@@ -1,13 +1,18 @@
1SUMMARY = "The Linux Kernel Stream Control Transmission Protocol (lksctp) project" 1SUMMARY = "The Linux Kernel Stream Control Transmission Protocol (lksctp) project"
2HOMEPAGE = "http://lksctp.org"
2SECTION = "libs" 3SECTION = "libs"
3LICENSE = "LGPLv2" 4LICENSE = "LGPLv2.1 & GPLv2"
4 5
5LIC_FILES_CHKSUM = " \ 6LIC_FILES_CHKSUM = " \
6 file://COPYING.lib;md5=0a1b79af951c42a9c8573533fbba9a92 \ 7 file://COPYING.lib;md5=0a1b79af951c42a9c8573533fbba9a92 \
7 file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \ 8 file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \
8" 9"
9 10
10SRC_URI = "${SOURCEFORGE_MIRROR}/lksctp/${BP}.tar.gz" 11SRC_URI = "${SOURCEFORGE_MIRROR}/lksctp/${BP}.tar.gz \
12 file://run-ptest \
13 file://v4test.sh \
14 file://v6test.sh \
15 "
11 16
12SRC_URI[md5sum] = "708bb0b5a6806ad6e8d13c55b067518e" 17SRC_URI[md5sum] = "708bb0b5a6806ad6e8d13c55b067518e"
13SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae351f26" 18SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae351f26"
@@ -16,13 +21,21 @@ SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae
16#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.0/ld: error: symbol sctp_connectx has undefined version 21#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.0/ld: error: symbol sctp_connectx has undefined version
17#| collect2: error: ld returned 1 exit status 22#| collect2: error: ld returned 1 exit status
18#| make[4]: *** [libsctp.la] Error 1 23#| make[4]: *** [libsctp.la] Error 1
19PNBLACKLIST[lksctp-tools] ?= "BROKEN: fails to link against sctp_connectx symbol" 24PNBLACKLIST[lksctp-tools] ?= "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', "BROKEN: fails to link against sctp_connectx symbol", '', d)}"
20 25
21S = "${WORKDIR}/${BP}" 26S = "${WORKDIR}/${BP}"
22 27
23BBCLASSEXTEND = "native" 28BBCLASSEXTEND = "native"
24 29
25inherit autotools pkgconfig binconfig 30inherit autotools pkgconfig binconfig ptest
31
32do_install_ptest () {
33 install -m 0755 ${WORKDIR}/v4test.sh ${D}${PTEST_PATH}
34 install -m 0755 ${WORKDIR}/v6test.sh ${D}${PTEST_PATH}
35 for testcase in `find ${B}/src/apps/.libs ${B}/src/func_tests/.libs -maxdepth 1 -type f -executable`; do
36 install $testcase ${D}${PTEST_PATH}
37 done
38}
26 39
27SOLIBVERSION="${PV}" 40SOLIBVERSION="${PV}"
28SOLIBMAJORVERSION="1" 41SOLIBMAJORVERSION="1"