summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtevent
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-11-19 20:46:30 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-01-04 12:58:10 -0500
commit418d59459148621d593054dc397335d24165a655 (patch)
treec6eed96590f59a2eea8d8480c708060ba80c696b /meta-networking/recipes-support/libtevent
parent60699c92e17ef124307aded87d8e9bfe55460d22 (diff)
downloadmeta-openembedded-418d59459148621d593054dc397335d24165a655.tar.gz
libtevent: rework dependencies for deterministic build
Since waf configure infrastructure is a body blow compared to reasonable autoconf script from packager point of view, samba support libs need feature-disable-patches. This one is for libtevent removing libcap (introduced by libldap_r) and attr. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/libtevent')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch20
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb6
2 files changed, 25 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch b/meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch
new file mode 100644
index 000000000..2fc55239c
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent/avoid-attr-unless-wanted.patch
@@ -0,0 +1,20 @@
1--- a/lib/replace/wscript 2015-11-18 15:40:19.000000000 +0100
2+++ b/lib/replace/wscript 2015-11-18 15:48:09.000000000 +0100
3@@ -618,8 +618,6 @@
4 if not bld.CONFIG_SET('HAVE_INET_ATON'): REPLACE_SOURCE += ' inet_aton.c'
5 if not bld.CONFIG_SET('HAVE_INET_NTOP'): REPLACE_SOURCE += ' inet_ntop.c'
6 if not bld.CONFIG_SET('HAVE_INET_PTON'): REPLACE_SOURCE += ' inet_pton.c'
7- if not bld.CONFIG_SET('HAVE_GETXATTR') or bld.CONFIG_SET('XATTR_ADDITIONAL_OPTIONS'):
8- REPLACE_SOURCE += ' xattr.c'
9
10 bld.SAMBA_LIBRARY('replace',
11 source=REPLACE_SOURCE,
12@@ -630,7 +628,7 @@
13 # at the moment:
14 # hide_symbols=bld.BUILTIN_LIBRARY('replace'),
15 private_library=True,
16- deps='crypt dl nsl socket rt attr' + extra_libs)
17+ deps='crypt dl nsl socket rt ' + extra_libs)
18
19 bld.SAMBA_SUBSYSTEM('replace-test',
20 source='''test/testsuite.c test/strptime.c
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
index 36ce7d6f7..006b36dd8 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.21.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs" 3SECTION = "libs"
4LICENSE = "LGPLv3+" 4LICENSE = "LGPLv3+"
5 5
6DEPENDS += "libtalloc libcap" 6DEPENDS += "libbsd libtalloc"
7RDEPENDS_python-tevent = "python" 7RDEPENDS_python-tevent = "python"
8 8
9SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz" 9SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
@@ -14,6 +14,10 @@ SRC_URI[sha256sum] = "f2be7463573dab2d8210cb57fe7e7e2aeb323274cbdc865a6e29ddcfb9
14 14
15inherit waf-samba 15inherit waf-samba
16 16
17PACKAGECONFIG[attr] = ",,attr"
18
19SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
20
17S = "${WORKDIR}/tevent-${PV}" 21S = "${WORKDIR}/tevent-${PV}"
18 22
19EXTRA_OECONF += "--disable-rpath \ 23EXTRA_OECONF += "--disable-rpath \