summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libmemcached
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-04-23 08:44:50 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-26 19:43:57 +0200
commit0cedafff98a1fc62e249e5b3049de5bad39552de (patch)
tree188fdae14b4d18333cd3c31f0944f5257135a30f /meta-networking/recipes-support/libmemcached
parent7bd0ff1d90bbe1b0c831bf9e7bc60fc2ad9181dd (diff)
downloadmeta-openembedded-0cedafff98a1fc62e249e5b3049de5bad39552de.tar.gz
libmemcached: add 1.0.15 and 1.0.7 versions
1.0.15 is latest 1.0.7 is required by HipHopVM Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/libmemcached')
-rw-r--r--meta-networking/recipes-support/libmemcached/files/crosscompile.patch30
-rw-r--r--meta-networking/recipes-support/libmemcached/libmemcached.inc10
-rw-r--r--meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb6
-rw-r--r--meta-networking/recipes-support/libmemcached/libmemcached_1.0.7.bb4
4 files changed, 50 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libmemcached/files/crosscompile.patch b/meta-networking/recipes-support/libmemcached/files/crosscompile.patch
new file mode 100644
index 000000000..63511bff5
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/files/crosscompile.patch
@@ -0,0 +1,30 @@
1 libmemcached/backtrace.cc | 3 ++-
2 1 file changed, 2 insertions(+), 1 deletion(-)
3
4--- libmemcached-1.0.15.orig/libmemcached/backtrace.cc
5+++ libmemcached-1.0.15/libmemcached/backtrace.cc
6@@ -75,10 +75,11 @@ void custom_backtrace(void)
7 {
8 for (int x= 0; x < stack_frames; x++)
9 {
10 bool was_demangled= false;
11
12+#if USE_DEMANGLE == 1
13 if (USE_DEMANGLE)
14 {
15 #ifdef HAVE_DLFCN_H
16 Dl_info dlinfo;
17 if (dladdr(backtrace_buffer[x], &dlinfo))
18@@ -107,11 +108,11 @@ void custom_backtrace(void)
19 dlinfo.dli_fname);
20 }
21 }
22 #endif
23 }
24-
25+#endif
26 if (was_demangled == false)
27 {
28 fprintf(stderr, "?%d %p in %s\n", x, backtrace_buffer[x], symbollist[x]);
29 }
30 }
diff --git a/meta-networking/recipes-support/libmemcached/libmemcached.inc b/meta-networking/recipes-support/libmemcached/libmemcached.inc
new file mode 100644
index 000000000..448a15d0e
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/libmemcached.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "open source C/C++ client library and tools for the memcached server"
2DEPENDS = "libevent util-linux"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=865490941c91ba790f0ea78dec93bd60"
5
6SRC_URI = "http://launchpad.net/libmemcached/1.0/${PV}/+download/libmemcached-${PV}.tar.gz"
7
8TARGET_LDFLAGS += "-luuid"
9
10inherit autotools gettext pkgconfig
diff --git a/meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb b/meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb
new file mode 100644
index 000000000..18232b4ce
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/libmemcached_1.0.15.bb
@@ -0,0 +1,6 @@
1require libmemcached.inc
2
3SRC_URI += "file://crosscompile.patch"
4
5SRC_URI[md5sum] = "616297a1aedefc52b3f6922eda5d559a"
6SRC_URI[sha256sum] = "dd7e9560029835bddf761a5b4c2339d9e5c7374558659b6c11b2c95e7d3a4325"
diff --git a/meta-networking/recipes-support/libmemcached/libmemcached_1.0.7.bb b/meta-networking/recipes-support/libmemcached/libmemcached_1.0.7.bb
new file mode 100644
index 000000000..cdf8415ff
--- /dev/null
+++ b/meta-networking/recipes-support/libmemcached/libmemcached_1.0.7.bb
@@ -0,0 +1,4 @@
1require libmemcached.inc
2
3SRC_URI[md5sum] = "d59a462a92d296f76bff2d9bc72b2516"
4SRC_URI[sha256sum] = "3efa86c9733eaad55d7119cb16769424e2aa6c22b3392e8f973946fce6678d81"