summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb
diff options
context:
space:
mode:
authorMariia Movchan -X \(mmovchan - GLOBALLOGIC INC at Cisco\) <mmovchan@cisco.com>2018-03-15 19:46:58 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:56:55 -0700
commit5b141faa25fa94a687e555c0ba1d248598580524 (patch)
treebda224c7ed9226529974479bb10c8290acbccac4 /meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb
parent66d3964b3c6e5ad7ef4712ff08aea77aa1614c2c (diff)
downloadmeta-openembedded-5b141faa25fa94a687e555c0ba1d248598580524.tar.gz
ipcalc: add initial recipe for version 0.2.2
Signed-off-by: Mariia Movchan <mmovchan@cisco.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb')
-rw-r--r--meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb b/meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb
new file mode 100644
index 000000000..3e278db68
--- /dev/null
+++ b/meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Tool to assist in network address calculations for IPv4 and IPv6."
2HOMEPAGE = "https://github.com/nmav/ipcalc"
3
4SECTION = "net"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "\
10 https://github.com/nmav/ipcalc/archive/${PV}.tar.gz;downloadfilename=ipcalc-${PV}.tar.gz \
11 file://0001-Makefile-pass-extra-linker-flags.patch \
12"
13
14SRC_URI[md5sum] = "343db932a3ad407328920b7430965faf"
15SRC_URI[sha256sum] = "bf1b95eca219e564c85fa4233fe65342963cf3e8a303a7e10b4dd7269c864794"
16
17export USE_GEOIP = "no"
18
19do_install() {
20 install -d ${D}/${bindir}
21 install -m 0755 ${S}/ipcalc ${D}/${bindir}
22}