summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/geoip
diff options
context:
space:
mode:
authorleimh <leimaohui@cn.fujitsu.com>2015-01-05 10:39:21 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-01-07 12:45:08 -0500
commita86a266a4e3ffd8e715f52b9dbeac2d1e44b3d74 (patch)
treeb9197bf36870eaa313ec1a7b9e313a25d55a6110 /meta-networking/recipes-support/geoip
parentb5afd31f7637f8a206b720f332d115c5a395cafc (diff)
downloadmeta-openembedded-a86a266a4e3ffd8e715f52b9dbeac2d1e44b3d74.tar.gz
geoipupdate: add new recipe
for update the IP geolocation databases Signed-off-by: leimh <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/geoip')
-rw-r--r--meta-networking/recipes-support/geoip/geoipupdate-2.1.0/GeoIP.conf11
-rw-r--r--meta-networking/recipes-support/geoip/geoipupdate-2.1.0/geoipupdate.cron5
-rw-r--r--meta-networking/recipes-support/geoip/geoipupdate_2.1.0.bb30
3 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/geoip/geoipupdate-2.1.0/GeoIP.conf b/meta-networking/recipes-support/geoip/geoipupdate-2.1.0/GeoIP.conf
new file mode 100644
index 000000000..134cfed1f
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoipupdate-2.1.0/GeoIP.conf
@@ -0,0 +1,11 @@
1# The following UserId and LicenseKey are required placeholders:
2UserId 999999
3LicenseKey 000000000000
4
5# Include one or more of the following ProductIds:
6# * GeoLite2-City - GeoLite 2 City
7# * GeoLite2-Country - GeoLite2 Country
8# * 506 - GeoLite Legacy Country
9# * 517 - GeoLite Legacy ASN
10# * 533 - GeoLite Legacy City
11ProductIds GeoLite2-City GeoLite2-Country 506 517 533
diff --git a/meta-networking/recipes-support/geoip/geoipupdate-2.1.0/geoipupdate.cron b/meta-networking/recipes-support/geoip/geoipupdate-2.1.0/geoipupdate.cron
new file mode 100644
index 000000000..40597a856
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoipupdate-2.1.0/geoipupdate.cron
@@ -0,0 +1,5 @@
1# top of crontab
2MAILTO=your@email.com
3
432 11 * * 4 /usr/local/bin/geoipupdate
5# end of crontab
diff --git a/meta-networking/recipes-support/geoip/geoipupdate_2.1.0.bb b/meta-networking/recipes-support/geoip/geoipupdate_2.1.0.bb
new file mode 100644
index 000000000..851ad414d
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoipupdate_2.1.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Crontab entry to provide weekly updates of the GeoIP free databases."
2DESCRIPTION = "update databases for GeoIP"
3
4HOMEPAGE = "http://dev.maxmind.com/geoip/"
5SECTION = "Development"
6
7DEPENDS = "zlib curl"
8
9SRC_URI = "https://github.com/maxmind/geoipupdate/releases/download/v2.1.0/geoipupdate-2.1.0.tar.gz \
10 file://GeoIP.conf \
11 file://geoipupdate.cron \
12 "
13
14SRC_URI[md5sum] = "9107d082f15c8e482f4b6f1080e7deaf"
15SRC_URI[sha256sum] = "7388c46f6c483ae609e5f5333a2585bc9713d56bb522da5c11b09d41c87aa5fb"
16
17LICENSE = "GPLv2"
18
19LIC_FILES_CHKSUM = "\
20file://ChangeLog.md;md5=25f3500fad03ad7e6bf135b29c9c7c2d \
21"
22
23inherit autotools
24
25do_install_append() {
26 install -d ${D}/${sysconfdir}
27 install -d ${D}/${sysconfdir}/cron.d
28 install ${WORKDIR}/GeoIP.conf ${D}/${sysconfdir}/
29 install ${WORKDIR}/geoipupdate.cron ${D}/${sysconfdir}/cron.d/
30}