summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/geoip
diff options
context:
space:
mode:
authorleimh <leimaohui@cn.fujitsu.com>2015-01-05 10:39:20 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-01-07 12:23:17 -0500
commit61002a1b431e0c7a22a28bd7d0e9d98231b74fa7 (patch)
treefe90b5832221979f1ed9f3908df6342aba804231 /meta-networking/recipes-support/geoip
parent639a2692988a21593bd4d3d10a0860dd276ec516 (diff)
downloadmeta-openembedded-61002a1b431e0c7a22a28bd7d0e9d98231b74fa7.tar.gz
GeoIP: add recipe
GeoIP app allow you to look up information about a given IP address. Signed-off-by: leimh <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/geoip')
-rw-r--r--meta-networking/recipes-support/geoip/geoip_1.6.0.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/geoip/geoip_1.6.0.bb b/meta-networking/recipes-support/geoip/geoip_1.6.0.bb
new file mode 100644
index 000000000..782d2e720
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoip_1.6.0.bb
@@ -0,0 +1,58 @@
1SUMMARY = "C library for country/city/organization to IP address or hostname mapping"
2DESCRIPTION = "GeoIP is a C library that enables the user to find the country that any IP \
3address or hostname originates from. It uses a file based database that is \
4accurate as of March 2003. This database simply contains IP blocks as keys, and \
5countries as values. This database should be more complete and accurate than \
6using reverse DNS lookups."
7
8HOMEPAGE = "http://dev.maxmind.com/geoip/"
9SECTION = "Development/Libraries"
10
11SRC_URI = "http://www.maxmind.com/download/geoip/api/c/GeoIP-1.6.0.tar.gz;name=tarball \
12 http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz;apply=no;name=GeoIP-dat \
13 http://geolite.maxmind.com/download/geoip/database/GeoIPv6.dat.gz;apply=no;name=GeoIPv6-dat \
14 http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz;apply=no;name=GeoLiteCity-dat \
15 http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz;apply=no;name=GeoLiteCityv6-dat \
16"
17
18SRC_URI[tarball.md5sum] = "89f4cdfdab43f1d67364cd7c85bbe8ca"
19SRC_URI[tarball.sha256sum] = "075a0c2815cd099e9ec35c9569db716a3fefcdbb6a10dbfa1ce7c6cd48d4a635"
20
21SRC_URI[GeoIP-dat.md5sum] = "53416cd33e556a8048ac522fc9a98e05"
22SRC_URI[GeoIP-dat.sha256sum] = "a423a0c87bf9a78ef8d68153b424987c6bbddec85b5f784ca747706f4df10361"
23
24SRC_URI[GeoIPv6-dat.md5sum] = "f1a4abf4015c0300267f4717c9d7ead2"
25SRC_URI[GeoIPv6-dat.sha256sum] = "1a8e61732e39ac9d9acc20d648b2530d7bd0ff1c250f51fd18148931fbfe2830"
26
27SRC_URI[GeoLiteCity-dat.md5sum] = "48af3b8a204d7c5f8e42a4f5f4dd1874"
28SRC_URI[GeoLiteCity-dat.sha256sum] = "2f3f62f171c333cdd4e68534585e51978cb3a12dc7b269786f50daf10071d7d6"
29
30SRC_URI[GeoLiteCityv6-dat.md5sum] = "a42504adfd8030c3a10f749191598b4a"
31SRC_URI[GeoLiteCityv6-dat.sha256sum] = "4a5eeaa4a9107e6ccdbe94ad1c7c987dc70cd250cd40624ada1e3a03836bbbdb"
32
33
34LICENSE = "LGPL-2.1"
35
36LIC_FILES_CHKSUM = "file://COPYING;md5=d5d53d6b948c064f4070183180a4fa89 \
37 file://LICENSE;md5=f04db71812ba70aaba8b38da91984cd2 "
38
39S = "${WORKDIR}/GeoIP-1.6.0"
40
41inherit autotools
42
43EXTRA_OECONF = "--disable-static \
44 --disable-dependency-tracking "
45
46do_install() {
47 make DESTDIR=${D} install
48 install -d ${D}/${datadir}/GeoIP
49 install ${WORKDIR}/GeoIP.dat ${D}/${datadir}/GeoIP/
50 install ${WORKDIR}/GeoIPv6.dat ${D}/${datadir}/GeoIP/
51 install ${WORKDIR}/GeoLiteCity.dat ${D}/${datadir}/GeoIP/
52 install ${WORKDIR}/GeoLiteCityv6.dat ${D}/${datadir}/GeoIP/
53}
54
55PACKAGES =+ "${PN}-database"
56FILES_${PN}-database = ""
57FILES_${PN}-database += "${datadir}/GeoIP/*"
58