summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/geoip
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-08-18 18:53:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:56:28 +0200
commit289217bbc3c5c53f486ab5615a6d6196e3c12cf2 (patch)
treef9551306e700a0ba0218177f3ec417f76d1f5759 /meta-networking/recipes-support/geoip
parentf2bec07b87b3f1118aa1d1f194d230920f1afe01 (diff)
downloadmeta-openembedded-289217bbc3c5c53f486ab5615a6d6196e3c12cf2.tar.gz
meta-oe: fix indentation
* remove tabs which sneaked in since last cleanup * meta-oe layers are using consistent indentation with 4 spaces, see http://www.openembedded.org/wiki/Styleguide Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/geoip')
-rw-r--r--meta-networking/recipes-support/geoip/geoip-perl_1.45.bb10
-rw-r--r--meta-networking/recipes-support/geoip/geoip_1.6.9.bb45
2 files changed, 26 insertions, 29 deletions
diff --git a/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
index 728ad5843..fd3aae94b 100644
--- a/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
+++ b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
@@ -12,8 +12,8 @@ LIC_FILES_CHKSUM = "file://README;md5=b0fa745303912bd2d64430f7ae69487d"
12# Note that we do not want to use the upstream file name locally. 12# Note that we do not want to use the upstream file name locally.
13# 13#
14SRC_URI = "http://github.com/maxmind/geoip-api-perl/archive/v${PV}.tar.gz;downloadfilename=${BPN}-${PV}.tar.gz \ 14SRC_URI = "http://github.com/maxmind/geoip-api-perl/archive/v${PV}.tar.gz;downloadfilename=${BPN}-${PV}.tar.gz \
15 file://run-ptest \ 15 file://run-ptest \
16 " 16"
17 17
18SRC_URI[md5sum] = "0ce57140890bf81958e0cea4fe1885b2" 18SRC_URI[md5sum] = "0ce57140890bf81958e0cea4fe1885b2"
19SRC_URI[sha256sum] = "c56437b1cc8887736cb1e435d0320c1c1ff3754830249516317b99137005fb23" 19SRC_URI[sha256sum] = "c56437b1cc8887736cb1e435d0320c1c1ff3754830249516317b99137005fb23"
@@ -30,10 +30,10 @@ EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'"
30# perl scripts and some special small data files 30# perl scripts and some special small data files
31# 31#
32do_install_ptest () { 32do_install_ptest () {
33 install -d -m 0755 ${D}${PTEST_PATH}/t/data 33 install -d -m 0755 ${D}${PTEST_PATH}/t/data
34 34
35 install ${S}/t/*.t* ${D}${PTEST_PATH}/t 35 install ${S}/t/*.t* ${D}${PTEST_PATH}/t
36 install ${S}/t/data/* ${D}${PTEST_PATH}/t/data 36 install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
37} 37}
38 38
39FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug" 39FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
diff --git a/meta-networking/recipes-support/geoip/geoip_1.6.9.bb b/meta-networking/recipes-support/geoip/geoip_1.6.9.bb
index f46b3eb72..9e8e0714f 100644
--- a/meta-networking/recipes-support/geoip/geoip_1.6.9.bb
+++ b/meta-networking/recipes-support/geoip/geoip_1.6.9.bb
@@ -62,32 +62,29 @@ RDEPENDS_${PN} += "${PN}-database"
62inherit ptest 62inherit ptest
63 63
64do_configure_ptest() { 64do_configure_ptest() {
65 sed -i -e "s/noinst_PROGRAMS = /test_PROGRAMS = /g" \ 65 sed -i -e "s/noinst_PROGRAMS = /test_PROGRAMS = /g" \
66 -e 's:SRCDIR=\\"$(top_srcdir)\\":SRCDIR=\\"$(testdir)\\":' \ 66 -e 's:SRCDIR=\\"$(top_srcdir)\\":SRCDIR=\\"$(testdir)\\":' \
67 ${S}/test/Makefile.am 67 ${S}/test/Makefile.am
68 68
69 if ! grep "^testdir = " ${S}/test/Makefile.am ; then 69 if ! grep "^testdir = " ${S}/test/Makefile.am ; then
70 sed -e '/EXTRA_PROGRAMS = /itestdir = ${PTEST_PATH}/tests' \ 70 sed -e '/EXTRA_PROGRAMS = /itestdir = ${PTEST_PATH}/tests' \
71 -i ${S}/test/Makefile.am 71 -i ${S}/test/Makefile.am
72 fi 72 fi
73 73
74 sed -i -e "s:/usr/local/share:/usr/share:g" \ 74 sed -i -e "s:/usr/local/share:/usr/share:g" \
75 ${S}/test/benchmark.c 75 ${S}/test/benchmark.c
76 76
77 sed -i -e 's:"../data/:"/usr/share/GeoIP/:g' \ 77 sed -i -e 's:"../data/:"/usr/share/GeoIP/:g' \
78 ${S}/test/test-geoip-city.c \ 78 ${S}/test/test-geoip-city.c \
79 ${S}/test/test-geoip-isp.c \ 79 ${S}/test/test-geoip-isp.c \
80 ${S}/test/test-geoip-asnum.c \ 80 ${S}/test/test-geoip-asnum.c \
81 ${S}/test/test-geoip-netspeed.c \ 81 ${S}/test/test-geoip-netspeed.c \
82 ${S}/test/test-geoip-org.c \ 82 ${S}/test/test-geoip-org.c \
83 ${S}/test/test-geoip-region.c 83 ${S}/test/test-geoip-region.c
84} 84}
85 85
86 86
87do_install_ptest() { 87do_install_ptest() {
88 oe_runmake -C test DESTDIR=${D} install-testPROGRAMS 88 oe_runmake -C test DESTDIR=${D} install-testPROGRAMS
89 install ${S}/test/*.txt ${D}${PTEST_PATH}/tests 89 install ${S}/test/*.txt ${D}${PTEST_PATH}/tests
90} 90}
91
92
93