diff options
author | Shrikant Bobade <Shrikant_Bobade@mentor.com> | 2014-08-04 14:42:57 +0530 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-10 16:07:17 +0200 |
commit | 3740ef263860f6fc94305f32253b1a4e9338e3b9 (patch) | |
tree | 78d5ca2f2d68560acece1dc05d1fff2904ad949b /meta-networking/recipes-support/dnsmasq | |
parent | 6576cddf6b66c34e9ea550d8dd0819c559237b5a (diff) | |
download | meta-openembedded-3740ef263860f6fc94305f32253b1a4e9338e3b9.tar.gz |
dnsmasq: fix parallel make failure
The dnsmasq target depends on .configured and $(objs). .configured does an rm
-f *.o. Yet the only thing telling make to build the .configured target before
the $(objs) target was the order of the dependencies of the dnsmasq target. We
can't rely on that order when doing a paralllel make build, so add an explicit
rule to enforce that order.
Signed-off-by: Christopher Larson <kergoth@gmail.com>
Signed-off-by: Shrikant Bobade <Shrikant_Bobade@mentor.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/dnsmasq')
-rw-r--r-- | meta-networking/recipes-support/dnsmasq/dnsmasq.inc | 1 | ||||
-rw-r--r-- | meta-networking/recipes-support/dnsmasq/files/parallel-make.patch | 18 |
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc index e57ab727e..1955d6fef 100644 --- a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc +++ b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc | |||
@@ -11,6 +11,7 @@ SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/${@['archive/', ''][float(d.getV | |||
11 | file://init \ | 11 | file://init \ |
12 | file://dnsmasq.conf \ | 12 | file://dnsmasq.conf \ |
13 | file://dnsmasq.service \ | 13 | file://dnsmasq.service \ |
14 | file://parallel-make.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | inherit update-rc.d systemd | 17 | inherit update-rc.d systemd |
diff --git a/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch b/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch new file mode 100644 index 000000000..3d1040cf3 --- /dev/null +++ b/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | The dnsmasq target depends on .configured and $(objs). .configured does an rm | ||
2 | -f *.o. Yet the only thing telling make to build the .configured target before | ||
3 | the $(objs) target was the order of the dependencies of the dnsmasq target. We | ||
4 | can't rely on that order when doing a paralllel make build, so add an explicit | ||
5 | rule to enforce that order. | ||
6 | |||
7 | Signed-off-by: Christopher Larson <chris_larson@mentor.com> | ||
8 | |||
9 | --- dnsmasq-2.68.orig/Makefile | ||
10 | +++ dnsmasq-2.68/Makefile | ||
11 | @@ -139,6 +139,8 @@ bloatcheck : $(BUILDDIR)/dnsmasq_baselin | ||
12 | @rm -f *.o | ||
13 | @touch $@ | ||
14 | |||
15 | +$(objs): .configured | ||
16 | + | ||
17 | $(objs:.o=.c) $(hdrs): | ||
18 | ln -s $(top)/$(SRC)/$@ . | ||