diff options
author | Kai Kang <kai.kang@windriver.com> | 2017-03-22 00:35:11 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-03-24 14:10:18 -0400 |
commit | f2dfae565531dd126131474b8a15dfe1d2871cc3 (patch) | |
tree | ad57b363e423d7f75a0ce16625d6c2877d91ea79 /meta-networking/recipes-support/curlpp | |
parent | cb3561aa22640e27d2bcadd541f247e90a7f1436 (diff) | |
download | meta-openembedded-f2dfae565531dd126131474b8a15dfe1d2871cc3.tar.gz |
curlpp: 0.7.3 -> 0.8.1
Upgrade curlpp from 0.7.3 to 0.8.1. The main difference between 0.7.x
and 0.8.0 is that it replaces autotools with cmake, see
https://github.com/jpbarrette/curlpp/releases/tag/v0.8.0
The homepage of curlpp on googlecode is obsoleted, so update it and use
soure code repo on github.
Remove dependency boost which is dropped by upstream. And remove extra
CXXFLAGS which has been fixed by upstream.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/curlpp')
-rw-r--r-- | meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb | 40 | ||||
-rw-r--r-- | meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb | 33 |
2 files changed, 33 insertions, 40 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb deleted file mode 100644 index c3a242a31..000000000 --- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | SUMMARY = "C++ library for client-side URL transfers" | ||
2 | HOMEPAGE = "http://code.google.com/p/curlpp/" | ||
3 | SECTION = "libdevel" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
6 | |||
7 | DEPENDS = "curl boost" | ||
8 | DEPENDS_class-native = "curl-native" | ||
9 | |||
10 | SRC_URI = "http://curlpp.googlecode.com/files/curlpp-${PV}.tar.gz \ | ||
11 | file://example21.cpp-remove-deprecated-code.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "ccc3d30d4b3b5d2cdbed635898c29485" | ||
15 | SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a653bd5" | ||
16 | |||
17 | inherit autotools-brokensep pkgconfig binconfig | ||
18 | |||
19 | EXTRA_OECONF = "--with-boost=${STAGING_DIR_HOST}${prefix}" | ||
20 | # Upstream is currently working on porting the code to use std::unique_ptr instead of the | ||
21 | # deprecated auto_ptr. For now, ignore the issue. | ||
22 | CXXFLAGS += "-Wno-error=deprecated-declarations" | ||
23 | |||
24 | do_install_append () { | ||
25 | sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc | ||
26 | } | ||
27 | |||
28 | PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev" | ||
29 | |||
30 | FILES_lib${BPN} = "${libdir}/lib*.so.*" | ||
31 | |||
32 | FILES_lib${BPN}-dev = "${includedir} \ | ||
33 | ${libdir}/lib*.la \ | ||
34 | ${libdir}/pkgconfig \ | ||
35 | ${bindir}/*-config \ | ||
36 | " | ||
37 | |||
38 | FILES_lib${BPN}-staticdev = "${libdir}/lib*.a" | ||
39 | |||
40 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb new file mode 100644 index 000000000..340f57dc7 --- /dev/null +++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "C++ library for client-side URL transfers" | ||
2 | HOMEPAGE = "http://www.curlpp.org/" | ||
3 | SECTION = "libdevel" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
6 | |||
7 | DEPENDS = "curl" | ||
8 | DEPENDS_class-native = "curl-native" | ||
9 | |||
10 | SRC_URI = "git://github.com/jpbarrette/curlpp.git" | ||
11 | |||
12 | SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | inherit cmake pkgconfig binconfig | ||
17 | |||
18 | do_install_append () { | ||
19 | sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc | ||
20 | } | ||
21 | |||
22 | PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev" | ||
23 | |||
24 | FILES_lib${BPN} = "${libdir}/lib*.so.*" | ||
25 | |||
26 | FILES_lib${BPN}-dev = "${includedir} \ | ||
27 | ${libdir}/pkgconfig \ | ||
28 | ${bindir}/*-config \ | ||
29 | " | ||
30 | |||
31 | FILES_lib${BPN}-staticdev = "${libdir}/lib*.a" | ||
32 | |||
33 | BBCLASSEXTEND = "native nativesdk" | ||