summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch b/meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch
new file mode 100644
index 000000000..ad73c0088
--- /dev/null
+++ b/meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch
@@ -0,0 +1,38 @@
1Upstream-Status: Inappropriate [packaging]
2
3
4Index: curl-7.20.0/libcurl.pc.in
5===================================================================
6--- curl-7.20.0.orig/libcurl.pc.in 2009-11-17 18:11:07.000000000 +0000
7+++ curl-7.20.0/libcurl.pc.in 2010-03-25 12:13:26.814051066 +0000
8@@ -35,6 +35,7 @@
9 URL: http://curl.haxx.se/
10 Description: Library to transfer files with ftp, http, etc.
11 Version: @CURLVERSION@
12-Libs: -L${libdir} -lcurl @LIBS@
13-Libs.private: @LIBCURL_LIBS@ @LIBS@
14+Requires.private: @GNUTLS_REQUIRED@
15+Libs: -L${libdir} -lcurl
16+Libs.private: -ldl -lz
17 Cflags: -I${includedir}
18Index: curl-7.20.0/configure.ac
19===================================================================
20--- curl-7.20.0.orig/configure.ac 2010-02-04 21:41:46.000000000 +0000
21+++ curl-7.20.0/configure.ac 2010-03-25 12:12:18.673129001 +0000
22@@ -1668,6 +1668,7 @@
23 AC_SUBST(USE_GNUTLS, [1])
24 GNUTLS_ENABLED=1
25 USE_GNUTLS="yes"
26+ GNUTLS_REQUIRED="gnutls"
27 curl_ssl_msg="enabled (GnuTLS)"
28 ],
29 [
30@@ -1696,6 +1697,8 @@
31
32 fi dnl OPENSSL != 1
33
34+AC_SUBST(GNUTLS_REQUIRED)
35+
36 dnl ----------------------------------------------------
37 dnl NSS. Only check if GnuTLS and OpenSSL are not enabled
38 dnl ----------------------------------------------------