diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-11-20 02:05:11 -0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-02-29 16:23:34 -0500 |
commit | 36fa2355a028e47a302b2fa723144ea3ea731fb0 (patch) | |
tree | 58c263b29a2ea38167ca49f90633905de38dbe96 /meta-networking/recipes-support/cim-schema | |
parent | 4ebf44dda042db55db2ae7deb7ff5acc184d59a7 (diff) | |
download | meta-openembedded-36fa2355a028e47a302b2fa723144ea3ea731fb0.tar.gz |
cim-schema-exper: fix host-user-contaminated
Fixed:
cim-schema-exper-2.39.0: cim-schema-exper: /cim-schema-exper/usr/share/mof/cimv2.39.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]
cim-schema-final-2.40.0: cim-schema-final: /cim-schema-final/usr/share/mof/cimv2.40.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]
lib32-cim-schema-exper-2.39.0: lib32-cim-schema-exper: /lib32-cim-schema-exper/usr/share/mof/cimv2.39.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]
lib32-cim-schema-final-2.40.0: lib32-cim-schema-final: /lib32-cim-schema-final/usr/share/mof/cimv2.40.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]
It uses cp -a to install the files, so fix the owner to root:root
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/cim-schema')
-rw-r--r-- | meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb | 1 | ||||
-rw-r--r-- | meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb | 1 |
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb index 62e50df1d..e4ed7b362 100644 --- a/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb +++ b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb | |||
@@ -17,6 +17,7 @@ do_install() { | |||
17 | install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV} | 17 | install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV} |
18 | 18 | ||
19 | cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/ | 19 | cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/ |
20 | chown -R root:root ${D}${datadir}/mof/cimv${PV} | ||
20 | for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do | 21 | for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do |
21 | sed -i -e 's/\r//g' $i | 22 | sed -i -e 's/\r//g' $i |
22 | done | 23 | done |
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb index 1694f3182..7ab9c4d49 100644 --- a/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb +++ b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb | |||
@@ -22,6 +22,7 @@ do_install() { | |||
22 | install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV} | 22 | install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV} |
23 | 23 | ||
24 | cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/ | 24 | cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/ |
25 | chown -R root:root ${D}${datadir}/mof/cimv${PV}/ | ||
25 | for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do | 26 | for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do |
26 | sed -i -e 's/\r//g' $i | 27 | sed -i -e 's/\r//g' $i |
27 | done | 28 | done |