summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/cim-schema
diff options
context:
space:
mode:
authorYao Xinpan <yaoxp@cn.fujitsu.com>2014-06-15 13:45:09 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2014-06-15 23:21:33 -0400
commite35a1fe480d3aa5cd0b0b8764f57796f3d7992d7 (patch)
tree946bc745d71c5f2b1279e1be9f179ce6a20c6705 /meta-networking/recipes-support/cim-schema
parent8316933b400ae6fda688637fcc3e202b38a8e12b (diff)
downloadmeta-openembedded-e35a1fe480d3aa5cd0b0b8764f57796f3d7992d7.tar.gz
add recipe cim-schema, cim-schema-docs and license file DMTF.
Common Information Model (CIM) is a model for describing overall management information in a network or enterprise environment. CIM consists of a specification and a schema. The specification defines the details for integration with other management models. The schema provides the actual model descriptions. Signed-off-by: Yao Xinpan <yaoxp@cn.fujitsu.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/cim-schema')
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb23
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema.inc9
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema_2.40.0.bb31
-rw-r--r--meta-networking/recipes-support/cim-schema/files/LICENSE34
4 files changed, 97 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb
new file mode 100644
index 000000000..06c0dd985
--- /dev/null
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb
@@ -0,0 +1,23 @@
1require cim-schema.inc
2
3LICENSE = "DMTF"
4
5SRC_URI = "http://dmtf.org/sites/default/files/cim/cim_schema_v2400/cim_schema_${PV}Final-Doc.zip \
6 file://LICENSE \
7 "
8SRC_URI[md5sum] = "3d01940bc1085c6c42184c25fb61f739"
9SRC_URI[sha256sum] = "3174cf0f8657b19d80dc59e184778d8e553da424728cb2966fe9d5428dd84267"
10LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=eecc6f71a56ff3caf17f15bf7aeac7b4"
11
12do_unpack() {
13 unzip -q ${DL_DIR}/cim_schema_${PV}Final-Doc.zip -d ${S}
14 cp -f ${FILE_DIRNAME}/files/LICENSE ${WORKDIR}/
15}
16
17do_install() {
18 install -d -m 0755 ${D}${datadir}/doc/cim-schema-${PV}-docs
19 cp -a ${S}/* ${D}${datadir}/doc/cim-schema-${PV}-docs
20}
21
22FILES_${PN} = "${datadir}/doc/*"
23FILES_${PN}-doc = ""
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema.inc b/meta-networking/recipes-support/cim-schema/cim-schema.inc
new file mode 100644
index 000000000..e35bff69c
--- /dev/null
+++ b/meta-networking/recipes-support/cim-schema/cim-schema.inc
@@ -0,0 +1,9 @@
1SUMMARY = "Common Information Model (CIM) Schema"
2DESCRIPTION = "Common Information Model (CIM) is a model for describing overall\
3management information in a network or enterprise environment. CIM\
4consists of a specification and a schema. The specification defines the\
5details for integration with other management models. The schema\
6provides the actual model descriptions."
7
8HOMEPAGE = "http://www.dmtf.org/"
9SECTION = "Development/Libraries"
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema_2.40.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema_2.40.0.bb
new file mode 100644
index 000000000..ff6c29dc5
--- /dev/null
+++ b/meta-networking/recipes-support/cim-schema/cim-schema_2.40.0.bb
@@ -0,0 +1,31 @@
1require cim-schema.inc
2
3LICENSE = "DMTF"
4
5SRC_URI = "http://dmtf.org/sites/default/files/cim/cim_schema_v2400/cim_schema_${PV}Final-MOFs.zip \
6 file://LICENSE \
7 "
8SRC_URI[md5sum] = "a9bdf17c7374e3b5b7adeaac4842c4ad"
9SRC_URI[sha256sum] = "dbfa3064ea427acd71a4bebbc172ca2dc44b0b09a6d83b0945b9ffa988a9058a"
10LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=eecc6f71a56ff3caf17f15bf7aeac7b4"
11
12do_unpack() {
13 unzip -q ${DL_DIR}/cim_schema_${PV}Final-MOFs.zip -d ${S}
14 cp -f ${FILE_DIRNAME}/files/LICENSE ${WORKDIR}/
15}
16
17do_install() {
18 install -d -m 0755 ${D}${datadir}/mof/cimv${PV}/
19 install -d -m 0755 ${D}${datadir}/doc/cim-schema-${PV}
20 install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV}
21
22 cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/
23 for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do
24 sed -i -e 's/\r//g' $i
25 done
26 ln -s cimv${PV} ${D}${datadir}/mof/cim-current
27 ln -s cim_schema_${PV}.mof ${D}${datadir}/mof/cim-current/CIM_Schema.mof
28}
29
30FILES_${PN} = "${datadir}/mof/* ${datadir}/doc/*"
31FILES_${PN}-doc = ""
diff --git a/meta-networking/recipes-support/cim-schema/files/LICENSE b/meta-networking/recipes-support/cim-schema/files/LICENSE
new file mode 100644
index 000000000..54a28120e
--- /dev/null
+++ b/meta-networking/recipes-support/cim-schema/files/LICENSE
@@ -0,0 +1,34 @@
1// Copyright 1998-2008 Distributed Management Task Force, Inc. (DMTF).
2// All rights reserved.
3// DMTF is a not-for-profit association of industry members dedicated
4// to promoting enterprise and systems management and interoperability.
5// DMTF specifications and documents may be reproduced by
6// members and non-members, provided that correct attribution is given.
7// As DMTF specifications may be revised from time to time,
8// the particular version and release date should always be noted.
9//
10// Implementation of certain elements of this standard or proposed
11// standard may be subject to third party patent rights, including
12// provisional patent rights (herein "patent rights"). DMTF makes
13// no representations to users of the standard as to the existence
14// of such rights, and is not responsible to recognize, disclose, or
15// identify any or all such third party patent right, owners or
16// claimants, nor for any incomplete or inaccurate identification or
17// disclosure of such rights, owners or claimants. DMTF shall have no
18// liability to any party, in any manner or circumstance, under any
19// legal theory whatsoever, for failure to recognize, disclose, or
20// identify any such third party patent rights, or for such party's
21// reliance on the standard or incorporation thereof in its product,
22// protocols or testing procedures. DMTF shall have no liability to
23// any party implementing such standard, whether such implementation
24// is foreseeable or not, nor to any patent owner or claimant, and shall
25// have no liability or responsibility for costs or losses incurred if
26// a standard is withdrawn or modified after publication, and shall be
27// indemnified and held harmless by any party implementing the
28// standard from any and all claims of infringement by a patent owner
29// for such implementations.
30//
31// For information about patents held by third-parties which have
32// notified the DMTF that, in their opinion, such patent may relate to
33// or impact implementations of DMTF standards, visit
34// http://www.dmtf.org/about/policies/disclosures.php.