summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/chrony
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2017-11-18 10:07:36 -0800
committerJoe MacDonald <joe_macdonald@mentor.com>2018-01-08 12:03:36 -0500
commita6288549e612d4f88d7ed619087a03af2458443d (patch)
treef108dfbeb7f5155636fc705b48d2437cfe5a9df9 /meta-networking/recipes-support/chrony
parent286eaa380fa8dce0f2b44f2b82ff7efcb3faf2d5 (diff)
downloadmeta-openembedded-a6288549e612d4f88d7ed619087a03af2458443d.tar.gz
chrony: Update to version 3.2
Signed-of-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/chrony')
-rw-r--r--meta-networking/recipes-support/chrony/chrony/arm_eabi.patch36
-rw-r--r--meta-networking/recipes-support/chrony/chrony_3.2.bb (renamed from meta-networking/recipes-support/chrony/chrony_2.4.bb)6
2 files changed, 24 insertions, 18 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch b/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch
index d1586bba4..92a2dbd93 100644
--- a/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch
+++ b/meta-networking/recipes-support/chrony/chrony/arm_eabi.patch
@@ -1,48 +1,54 @@
1 chrony: fix build failure for arma9 1 chrony: fix build failure for arma9
2 2
3 Eliminate references to syscalls not available 3 Eliminate references to syscalls not available
4 for ARM_EABI. Also add a dependency on libseccomp 4 for ARM_EABI. Also add a dependency on libseccomp
5 which is needed for scfilter to work. 5 which is needed for scfilter to work.
6 6
7 Set PACKAGECONFIG to not enable scfilter, since 7 Set PACKAGECONFIG to not enable scfilter, since
8 kernel CONFIG_SECCOMP is unlikely to be set. This 8 kernel CONFIG_SECCOMP is unlikely to be set. This
9 aligns the usage of libseccomp with that of other packages. 9 aligns the usage of libseccomp with that of other packages.
10 10
11 Upstream-Status: Pending 11 Upstream-Status: Pending
12 12
13 Signed-off-by: Joe Slater <jslater@windriver.com> 13 Signed-off-by: Joe Slater <jslater@windriver.com>
14 14
15 Refresh patch for new upstream version.
16
17 Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org>
18
15--- a/sys_linux.c 19--- a/sys_linux.c
16+++ b/sys_linux.c 20+++ b/sys_linux.c
17@@ -453,13 +453,12 @@ SYS_Linux_EnableSystemCallFilter(int lev 21@@ -465,14 +465,14 @@ SYS_Linux_EnableSystemCallFilter(int lev
18 const int syscalls[] = { 22 const int syscalls[] = {
19 /* Clock */ 23 /* Clock */
20 SCMP_SYS(adjtimex), SCMP_SYS(gettimeofday), SCMP_SYS(settimeofday), 24 SCMP_SYS(adjtimex), SCMP_SYS(clock_gettime), SCMP_SYS(gettimeofday),
21- SCMP_SYS(time), 25- SCMP_SYS(settimeofday), SCMP_SYS(time),
26+ SCMP_SYS(settimeofday),
22 /* Process */ 27 /* Process */
23- SCMP_SYS(clone), SCMP_SYS(exit), SCMP_SYS(exit_group), SCMP_SYS(getrlimit), 28 SCMP_SYS(clone), SCMP_SYS(exit), SCMP_SYS(exit_group), SCMP_SYS(getpid),
24+ SCMP_SYS(clone), SCMP_SYS(exit), SCMP_SYS(exit_group), 29- SCMP_SYS(getrlimit), SCMP_SYS(rt_sigaction), SCMP_SYS(rt_sigreturn),
25 SCMP_SYS(rt_sigaction), SCMP_SYS(rt_sigreturn), SCMP_SYS(rt_sigprocmask), 30+ SCMP_SYS(rt_sigaction), SCMP_SYS(rt_sigreturn),
26 SCMP_SYS(set_tid_address), SCMP_SYS(sigreturn), SCMP_SYS(wait4), 31 SCMP_SYS(rt_sigprocmask), SCMP_SYS(set_tid_address), SCMP_SYS(sigreturn),
32 SCMP_SYS(wait4),
27 /* Memory */ 33 /* Memory */
28- SCMP_SYS(brk), SCMP_SYS(madvise), SCMP_SYS(mmap), SCMP_SYS(mmap2), 34- SCMP_SYS(brk), SCMP_SYS(madvise), SCMP_SYS(mmap), SCMP_SYS(mmap2),
29+ SCMP_SYS(brk), SCMP_SYS(madvise), SCMP_SYS(mmap2), 35+ SCMP_SYS(brk), SCMP_SYS(madvise), SCMP_SYS(mmap2),
30 SCMP_SYS(mprotect), SCMP_SYS(mremap), SCMP_SYS(munmap), SCMP_SYS(shmdt), 36 SCMP_SYS(mprotect), SCMP_SYS(mremap), SCMP_SYS(munmap), SCMP_SYS(shmdt),
31 /* Filesystem */ 37 /* Filesystem */
32 SCMP_SYS(access), SCMP_SYS(chmod), SCMP_SYS(chown), SCMP_SYS(chown32), 38 SCMP_SYS(access), SCMP_SYS(chmod), SCMP_SYS(chown), SCMP_SYS(chown32),
33@@ -470,14 +469,21 @@ SYS_Linux_EnableSystemCallFilter(int lev 39@@ -483,14 +483,21 @@
34 SCMP_SYS(bind), SCMP_SYS(connect), SCMP_SYS(getsockname), 40 SCMP_SYS(bind), SCMP_SYS(connect), SCMP_SYS(getsockname),
35 SCMP_SYS(recvfrom), SCMP_SYS(recvmsg), SCMP_SYS(sendmmsg), 41 SCMP_SYS(recvfrom), SCMP_SYS(recvmmsg), SCMP_SYS(recvmsg),
36 SCMP_SYS(sendmsg), SCMP_SYS(sendto), 42 SCMP_SYS(sendmmsg), SCMP_SYS(sendmsg), SCMP_SYS(sendto),
37- /* TODO: check socketcall arguments */ 43- /* TODO: check socketcall arguments */
38- SCMP_SYS(socketcall), 44- SCMP_SYS(socketcall),
39 /* General I/O */ 45 /* General I/O */
40 SCMP_SYS(_newselect), SCMP_SYS(close), SCMP_SYS(open), SCMP_SYS(pipe), 46 SCMP_SYS(_newselect), SCMP_SYS(close), SCMP_SYS(open), SCMP_SYS(openat), SCMP_SYS(pipe),
41- SCMP_SYS(poll), SCMP_SYS(read), SCMP_SYS(futex), SCMP_SYS(select), 47- SCMP_SYS(poll), SCMP_SYS(read), SCMP_SYS(futex), SCMP_SYS(select),
42+ SCMP_SYS(poll), SCMP_SYS(read), SCMP_SYS(futex), 48+ SCMP_SYS(poll), SCMP_SYS(read), SCMP_SYS(futex),
43 SCMP_SYS(set_robust_list), SCMP_SYS(write), 49 SCMP_SYS(set_robust_list), SCMP_SYS(write),
44 /* Miscellaneous */ 50 /* Miscellaneous */
45 SCMP_SYS(uname), 51 SCMP_SYS(getrandom), SCMP_SYS(sysinfo), SCMP_SYS(uname),
46+ /* not always available */ 52+ /* not always available */
47+#if ! defined(__ARM_EABI__) 53+#if ! defined(__ARM_EABI__)
48+ SCMP_SYS(time), 54+ SCMP_SYS(time),
diff --git a/meta-networking/recipes-support/chrony/chrony_2.4.bb b/meta-networking/recipes-support/chrony/chrony_3.2.bb
index 71431f4b7..8b90a354e 100644
--- a/meta-networking/recipes-support/chrony/chrony_2.4.bb
+++ b/meta-networking/recipes-support/chrony/chrony_3.2.bb
@@ -25,7 +25,7 @@ This recipe produces two binary packages: 'chrony' which contains chronyd, \
25the configuration file and the init script, and 'chronyc' which contains \ 25the configuration file and the init script, and 'chronyc' which contains \
26the client program only." 26the client program only."
27 27
28HOMEPAGE = "http://chrony.tuxfamily.org/" 28HOMEPAGE = "https://chrony.tuxfamily.org/"
29SECTION = "net" 29SECTION = "net"
30LICENSE = "GPLv2" 30LICENSE = "GPLv2"
31LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 31LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
@@ -35,8 +35,8 @@ SRC_URI = "https://download.tuxfamily.org/chrony/chrony-${PV}.tar.gz \
35 file://chronyd \ 35 file://chronyd \
36 file://arm_eabi.patch \ 36 file://arm_eabi.patch \
37" 37"
38SRC_URI[md5sum] = "d0598aa8a9be8faccef9386f6fc0d5f2" 38SRC_URI[md5sum] = "f4c4eb0dc92f35ee4bb7d3dcd8029ecb"
39SRC_URI[sha256sum] = "8d04e7cda2333289c2104b731d39c3c1db94816e43bae35d7ee4e7ae8af6391f" 39SRC_URI[sha256sum] = "329f6718dd8c3ece3eee78be1f4821cbbeb62608e7d23f25da293cfa433c4116"
40 40
41DEPENDS = "pps-tools" 41DEPENDS = "pps-tools"
42 42