diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2014-03-27 17:52:55 +0800 |
---|---|---|
committer | Joe MacDonald <joe.macdonald@windriver.com> | 2014-03-27 15:41:12 -0400 |
commit | c1d420a3b65538f80601411f85295db8f4cb30ab (patch) | |
tree | 87bd1e84186e854d52c23a4bdbd182105f5dd493 /meta-networking/recipes-protocols | |
parent | 6d121827702369b875cb7fa47303117ea74bc96f (diff) | |
download | meta-openembedded-c1d420a3b65538f80601411f85295db8f4cb30ab.tar.gz |
quagga: work with new readline
The Function and CPPFunction had been removed by in readline 6.3, use
the new functions to replace them.
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r-- | meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch | 34 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb | 1 |
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch b/meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch new file mode 100644 index 000000000..2bd333a70 --- /dev/null +++ b/meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 66df315d2a270a254c613a4d2e72c0ea47f15a71 Mon Sep 17 00:00:00 2001 | ||
2 | From: Robert Yang <liezhi.yang@windriver.com> | ||
3 | Date: Thu, 27 Mar 2014 09:35:29 +0000 | ||
4 | Subject: [PATCH] vtysh/vtysh.c: works with new readline | ||
5 | |||
6 | The Function and CPPFunction had been removed by in readline 6.3, use | ||
7 | the new functions to replace them. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
12 | --- | ||
13 | vtysh/vtysh.c | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/vtysh/vtysh.c b/vtysh/vtysh.c | ||
17 | index 431c08e..fdd82fb 100644 | ||
18 | --- a/vtysh/vtysh.c | ||
19 | +++ b/vtysh/vtysh.c | ||
20 | @@ -2212,9 +2212,9 @@ void | ||
21 | vtysh_readline_init (void) | ||
22 | { | ||
23 | /* readline related settings. */ | ||
24 | - rl_bind_key ('?', (Function *) vtysh_rl_describe); | ||
25 | + rl_bind_key ('?', (rl_command_func_t *) vtysh_rl_describe); | ||
26 | rl_completion_entry_function = vtysh_completion_entry_function; | ||
27 | - rl_attempted_completion_function = (CPPFunction *)new_completion; | ||
28 | + rl_attempted_completion_function = (rl_completion_func_t *)new_completion; | ||
29 | /* do not append space after completion. It will be appended | ||
30 | * in new_completion() function explicitly. */ | ||
31 | rl_completion_append_character = '\0'; | ||
32 | -- | ||
33 | 1.8.3.4 | ||
34 | |||
diff --git a/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb b/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb index db2a67b4a..0988b70eb 100644 --- a/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb +++ b/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb | |||
@@ -6,6 +6,7 @@ SRC_URI += "file://0001-doc-fix-makeinfo-errors-and-one-warning.patch \ | |||
6 | file://lingering-IP-address-after-deletion-BZ-486.patch \ | 6 | file://lingering-IP-address-after-deletion-BZ-486.patch \ |
7 | file://build-fix-extract.pl-for-cross-compilation.patch \ | 7 | file://build-fix-extract.pl-for-cross-compilation.patch \ |
8 | file://babel-close-the-stdout-stderr-as-in-other-daemons.patch \ | 8 | file://babel-close-the-stdout-stderr-as-in-other-daemons.patch \ |
9 | file://work-with-new-readline.patch \ | ||
9 | " | 10 | " |
10 | 11 | ||
11 | SRC_URI[quagga-0.99.21.md5sum] = "99840adbe57047c90dfba6b6ed9aec7f" | 12 | SRC_URI[quagga-0.99.21.md5sum] = "99840adbe57047c90dfba6b6ed9aec7f" |