diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-10-18 22:38:29 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-11-14 10:07:27 -0500 |
commit | dce441f95ea37356b10dfa03de794925d82089b0 (patch) | |
tree | 3f93e9b6f298684e721634815ec6173fa5d1b663 /meta-networking/recipes-protocols | |
parent | aebf681a9e7cf6b6018892e05f53a6c5806e6e2f (diff) | |
download | meta-openembedded-dce441f95ea37356b10dfa03de794925d82089b0.tar.gz |
openl2tp: Fix build with clang
Fix a typo in compile cmdline specified via
EXTRA_OECMAKE
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r-- | meta-networking/recipes-protocols/openl2tp/openl2tp/0001-test-pppd_dummy.c-Fix-return-value.patch | 38 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb | 5 |
2 files changed, 41 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-test-pppd_dummy.c-Fix-return-value.patch b/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-test-pppd_dummy.c-Fix-return-value.patch new file mode 100644 index 000000000..1f576fa71 --- /dev/null +++ b/meta-networking/recipes-protocols/openl2tp/openl2tp/0001-test-pppd_dummy.c-Fix-return-value.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From ce5f5563ab54db9d28dba44a0e25e8a8c7bb9876 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 19 Oct 2016 00:34:35 +0000 | ||
4 | Subject: [PATCH] test/pppd_dummy.c: Fix return value | ||
5 | |||
6 | pause() is defined in unistd.h, clang does not | ||
7 | like the fact that we are using a function without | ||
8 | declaration | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | test/pppd_dummy.c | 3 ++- | ||
13 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/test/pppd_dummy.c b/test/pppd_dummy.c | ||
16 | index 148e7d2..b564c36 100644 | ||
17 | --- a/test/pppd_dummy.c | ||
18 | +++ b/test/pppd_dummy.c | ||
19 | @@ -26,6 +26,7 @@ | ||
20 | #include <sys/types.h> | ||
21 | #include <sys/wait.h> | ||
22 | #include <syslog.h> | ||
23 | +#include <unistd.h> | ||
24 | |||
25 | #define PPPD_DUMMY_TMP_FILE "/tmp/pppd_dummy" | ||
26 | |||
27 | @@ -40,7 +41,7 @@ int main(int argc, char **argv) | ||
28 | |||
29 | if (file == NULL) { | ||
30 | syslog(LOG_ERR, "Failed to open %s\n", filename); | ||
31 | - return; | ||
32 | + return -1; | ||
33 | } | ||
34 | |||
35 | for (arg = 1; arg < argc; arg++) { | ||
36 | -- | ||
37 | 1.9.1 | ||
38 | |||
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb index 270472efb..5a6340486 100644 --- a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb +++ b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb | |||
@@ -15,14 +15,15 @@ SRC_URI = "http://ftp.jaist.ac.jp/pub/sourceforge/o/op/${PN}/${PN}/${PV}/${BP}.t | |||
15 | file://Makefile-modify-CFLAGS-to-aviod-build-error.patch \ | 15 | file://Makefile-modify-CFLAGS-to-aviod-build-error.patch \ |
16 | file://openl2tp-simplify-gcc-warning-hack.patch \ | 16 | file://openl2tp-simplify-gcc-warning-hack.patch \ |
17 | file://Makefile-obey-LDFLAGS.patch \ | 17 | file://Makefile-obey-LDFLAGS.patch \ |
18 | " | 18 | file://0001-test-pppd_dummy.c-Fix-return-value.patch \ |
19 | " | ||
19 | SRC_URI[md5sum] = "e3d08dedfb9e6a9a1e24f6766f6dadd0" | 20 | SRC_URI[md5sum] = "e3d08dedfb9e6a9a1e24f6766f6dadd0" |
20 | SRC_URI[sha256sum] = "1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f" | 21 | SRC_URI[sha256sum] = "1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f" |
21 | 22 | ||
22 | inherit autotools-brokensep pkgconfig | 23 | inherit autotools-brokensep pkgconfig |
23 | 24 | ||
24 | PARALLEL_MAKE = "" | 25 | PARALLEL_MAKE = "" |
25 | EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -Wno-nused-but-set-variable"' | 26 | EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -Wno-unused-but-set-variable"' |
26 | 27 | ||
27 | do_compile_prepend() { | 28 | do_compile_prepend() { |
28 | sed -i -e "s:SYS_LIBDIR=.*:SYS_LIBDIR=${libdir}:g" \ | 29 | sed -i -e "s:SYS_LIBDIR=.*:SYS_LIBDIR=${libdir}:g" \ |