diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2017-08-18 12:59:14 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-09-12 10:37:19 -0400 |
commit | 07762fd6ef60bbd3e6ab593125b18ec6fd6baa64 (patch) | |
tree | ca747a4b5603b593dd444347dc81b63da2a44edc /meta-networking/recipes-protocols | |
parent | 3ca10e7d924d94d85783dc7440096a7dab72b978 (diff) | |
download | meta-openembedded-07762fd6ef60bbd3e6ab593125b18ec6fd6baa64.tar.gz |
quagga: update to 1.2.1
* Add c-ares as dependency
* Remove variable QUAGGASUBDIR as it is not needed anymore
* Remove the duplicated RDEPENDS_${PN} += "iproute2"
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r-- | meta-networking/recipes-protocols/quagga/quagga.inc | 24 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/quagga/quagga_1.1.0.bb | 6 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/quagga/quagga_1.2.1.bb | 4 |
3 files changed, 12 insertions, 22 deletions
diff --git a/meta-networking/recipes-protocols/quagga/quagga.inc b/meta-networking/recipes-protocols/quagga/quagga.inc index 4fb6723c3..dfd6aa7eb 100644 --- a/meta-networking/recipes-protocols/quagga/quagga.inc +++ b/meta-networking/recipes-protocols/quagga/quagga.inc | |||
@@ -7,21 +7,20 @@ Ishiguro. The Quagga tree aims to build a more involved community \ | |||
7 | around Quagga than the current centralised model of GNU Zebra." | 7 | around Quagga than the current centralised model of GNU Zebra." |
8 | HOMEPAGE = "http://www.nongnu.org/quagga/" | 8 | HOMEPAGE = "http://www.nongnu.org/quagga/" |
9 | SECTION = "net" | 9 | SECTION = "net" |
10 | LICENSE = "GPL-2.0 & LGPL-2.0" | ||
11 | DEPENDS = "readline ncurses perl-native" | ||
12 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'snmp', 'net-snmp', '', d)}" | ||
13 | SNMP_CONF="${@bb.utils.contains('DISTRO_FEATURES', 'snmp', '--enable-snmp', '', d)}" | ||
14 | 10 | ||
11 | |||
12 | LICENSE = "GPL-2.0 & LGPL-2.0" | ||
15 | LIC_FILES_CHKSUM = "file://COPYING;md5=81bcece21748c91ba9992349a91ec11d \ | 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=81bcece21748c91ba9992349a91ec11d \ |
16 | file://COPYING.LIB;md5=01ef24401ded36cd8e5d18bfe947240c" | 14 | file://COPYING.LIB;md5=01ef24401ded36cd8e5d18bfe947240c" |
17 | 15 | ||
16 | DEPENDS = "readline ncurses perl-native c-ares" | ||
17 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'snmp', 'net-snmp', '', d)}" | ||
18 | SNMP_CONF="${@bb.utils.contains('DISTRO_FEATURES', 'snmp', '--enable-snmp', '', d)}" | ||
19 | |||
18 | # the "ip" command from busybox is not sufficient (flush by protocol flushes all routes) | 20 | # the "ip" command from busybox is not sufficient (flush by protocol flushes all routes) |
19 | RDEPENDS_${PN} += "iproute2" | 21 | RDEPENDS_${PN} += "iproute2" |
20 | 22 | ||
21 | QUAGGASUBDIR = "" | 23 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/quagga/quagga-${PV}.tar.gz; \ |
22 | # ${QUAGGASUBDIR} is deal with old versions. Set to "/attic" for old | ||
23 | # versions and leave it empty for recent versions. | ||
24 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/quagga${QUAGGASUBDIR}/quagga-${PV}.tar.gz; \ | ||
25 | file://quagga.init \ | 24 | file://quagga.init \ |
26 | file://quagga.default \ | 25 | file://quagga.default \ |
27 | file://watchquagga.init \ | 26 | file://watchquagga.init \ |
@@ -35,7 +34,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/quagga${QUAGGASUBDIR}/quagga-${PV}.tar.gz; \ | |||
35 | file://ripd.service \ | 34 | file://ripd.service \ |
36 | file://ripngd.service \ | 35 | file://ripngd.service \ |
37 | file://zebra.service \ | 36 | file://zebra.service \ |
38 | " | 37 | " |
39 | 38 | ||
40 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" | 39 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" |
41 | PACKAGECONFIG[cap] = "--enable-capabilities,--disable-capabilities,libcap" | 40 | PACKAGECONFIG[cap] = "--enable-capabilities,--disable-capabilities,libcap" |
@@ -108,10 +107,6 @@ do_install () { | |||
108 | sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/* ${D}${sysconfdir}/default/volatiles/volatiles.03_quagga | 107 | sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/* ${D}${sysconfdir}/default/volatiles/volatiles.03_quagga |
109 | sed -i 's!^PATH=.*!PATH=${base_sbindir}:${sbindir}:${base_bindir}:${bindir}!' ${D}${sysconfdir}/init.d/* | 108 | sed -i 's!^PATH=.*!PATH=${base_sbindir}:${sbindir}:${base_bindir}:${bindir}!' ${D}${sysconfdir}/init.d/* |
110 | 109 | ||
111 | # Remove generated info dir file, it doesn't belong in the generated | ||
112 | # package. | ||
113 | rm -f ${D}${infodir}/dir | ||
114 | |||
115 | # For PAM | 110 | # For PAM |
116 | for feature in ${DISTRO_FEATURES}; do | 111 | for feature in ${DISTRO_FEATURES}; do |
117 | if [ "$feature" = "pam" ]; then | 112 | if [ "$feature" = "pam" ]; then |
@@ -188,9 +183,6 @@ CONFFILES_${PN}-watchquagga = "${sysconfdir}/default/watchquagga" | |||
188 | DEBIAN_NOAUTONAME_${PN}-ospfd = "1" | 183 | DEBIAN_NOAUTONAME_${PN}-ospfd = "1" |
189 | DEBIAN_NOAUTONAME_${PN}-ospfclient = "1" | 184 | DEBIAN_NOAUTONAME_${PN}-ospfclient = "1" |
190 | 185 | ||
191 | # the "ip" command from busybox is not sufficient (flush by protocol flushes all routes) | ||
192 | RDEPENDS_${PN} += "iproute2" | ||
193 | |||
194 | # Main init script starts all deamons | 186 | # Main init script starts all deamons |
195 | # Seperate init script for watchquagga | 187 | # Seperate init script for watchquagga |
196 | INITSCRIPT_PACKAGES = "${PN} ${PN}-watchquagga" | 188 | INITSCRIPT_PACKAGES = "${PN} ${PN}-watchquagga" |
diff --git a/meta-networking/recipes-protocols/quagga/quagga_1.1.0.bb b/meta-networking/recipes-protocols/quagga/quagga_1.1.0.bb deleted file mode 100644 index 1b5c34c87..000000000 --- a/meta-networking/recipes-protocols/quagga/quagga_1.1.0.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | require quagga.inc | ||
2 | |||
3 | SRC_URI[md5sum] = "daa303871e07ea5856aae6fd79e89722" | ||
4 | SRC_URI[sha256sum] = "f7a43a9c59bfd3722002210530b2553c8d5cc05bfea5acd56d4f102b9f55dc63" | ||
5 | |||
6 | QUAGGASUBDIR = "" | ||
diff --git a/meta-networking/recipes-protocols/quagga/quagga_1.2.1.bb b/meta-networking/recipes-protocols/quagga/quagga_1.2.1.bb new file mode 100644 index 000000000..4d43d7b2a --- /dev/null +++ b/meta-networking/recipes-protocols/quagga/quagga_1.2.1.bb | |||
@@ -0,0 +1,4 @@ | |||
1 | require quagga.inc | ||
2 | |||
3 | SRC_URI[md5sum] = "b1546de89062f7070d56e780b30be4b1" | ||
4 | SRC_URI[sha256sum] = "aaddba5d4f41ed8e4c2f155f4584c993465d122c9096b5b52ada3fc75266fbcd" | ||